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TOPICS COVERED IN THIS WORKSHOP 

SOME COMMON ROUNDABOUT TERMS 
CREATING AND EDITING A ROUNDABOUT LIBRARY DGN 
PLACING A ROUNDABOUT ON LAYOUT GEOMETRY 
EDITING THE ROUNDABOUT DESIGN 
ANALYZING THE ROUNDABOUT DESIGN 

Lesson-1: Common Roundabout Terms 

LESSON OBJECTIVE: 

In this lesson, the user will be introduced to some common roundabout terms. Please note that any 
discussions about dimensions in this workshop are based on the U.S. Department of Transportation’s, Federal 
Highway Administration publication number FHWA-RD-00-067,” Roundabouts: An Informational Guide”. 

The following are some common terms used when designing a roundabout.   

Splitter Island:  A traffic island that is used to separate traffic entering and leaving the roundabout 

Approach Width:  The width of the approaching roadway travel lanes 

Departure Width: The width of the departing roadway travel lanes 

Inscribed Circle Diameter: The diameter of the roundabout as measured from the extreme outside edge of 
the circular travel way excluding any truck aprons 

Entry Width: Width of the lanes entering the roundabout at the intersection point of the inside edge of the 
approaching travel lanes and the Inscribed Circle Diameter.  This measurement is perpendicular to the travel 
lane. 

Exit Width: Width of the lanes exiting the roundabout at the intersection point of the inside edge of the 
Departure travel lanes and the Inscribed Circle Diameter.  This measurement is perpendicular to the travel 
lane. 

Entry radius: Is the outside radius that used to make a smooth connection from the approach lane to the 
inscribed circle diameter.  The end of this radius is also the start of the Exit Radius. 

Exit radius: Is the outside radius that used to make a smooth connection from the departure lane to the 
inscribed circle diameter.  The end of this radius is also the end of the Entry Radius. 

Central Island: The circular island in the middle of the roundabout 
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Apron: Area set off from the roundabout design so large trucks can roll over the area but this area is not used in 
normal traffic flow. 

 

The final dimensions of the roundabout are based on the approach speeds, the desirable speed of traffic in the 
roundabout and the type of traffic project to use the roundabout.  Vehicle path studies are an important part of the 
process of the design and all the approaches and departures should be check. 
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It is not the intent of this workshop to teach design and analysis but to show you how the tools are used.  
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Lesson-2: Creating Roundabout Library DGN  

LESSON OBJECTIVE: 

In this lesson, the user will create a new DGN file. Place a default EU Roundabout in the DGN and then edit 
various values within the Library DGN. 

 

EXERCISE: CREATING A NEW DGN LIBRARY FILE 

This exercise will guide you through the steps to get started 

1. Start InRoads: Start > All Programs > Bentley > InRoads Group V8i (SELECTseries 2) > InRoads 

-Or-   

Start MX: Start > All Programs > Bentley > Bentley MXRoad Suite V8i (SELECTseries 2) > Bentley 
Bentley MXRoad Suite 

-Or-   

Start GEOPAC: Start > All Programs > Bentley > Bentley GEOPAC Suite V8i (SELECTseries 2) > Bentley 
GEOPAC Civil Engineering Suite 

 

2. Navigate to the workshop data folder.   

…\X03-New Tools-Creating Roundabout Libraries\DATA 

3. Select the New icon from the MicroStation Manager.  

4. Select Browse and locate the Seed file for the Roundabout Library DGN.  
“…\X03-New Tools-Creating Roundabout Libraries\DATA\Metric.dgn” 
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5. Key-in the name of the Roundabout Library DGN file. “Metric Roundabout.dgn” 

6. Select Save from the “New” dialog 
 

 
 

7. Select the newly created file and Open.  

8. On the MicroStation menu select Tools > Roundabouts > Default Roundabouts > European Union 
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9. Select Right Hand Side for Driving Side in the Place Default EU Roundabout toolbox. 

 

 
10. When prompted to Select Center Point location, place the library roundabout at 0,0,0 via AccuDraw or 

Key-in. 

 

 
 

11. Fit the View.  
 
Note: This Roundabout Library DGN is being generated from the EU rule based model. All roundabouts 
placed using this command are metric and initially contain no feature styles.  

12. Select Settings > View Attributes and toggle off the ACS Triad. 

 

 
 

13.  Dismiss the View Attributes tool 
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EXERCISE: EDITING THE ROUNDABOUT LIBRARY DGN FILE 

This exercise will guide you through process of standardizing a roundabout library DGN. It will show 
you how to change the design settings of an approach. Then duplicate the edited approach to each 
side of the Roundabout. 

1. Toggle off the Graphic Group Lock is it is on. 

 

 
 

2. Put MicroStation in Element Selection mode.  

 

 
 

3. Zoom into the Circulatory Area and select the Inscribed Circle Diameter of the roundabout to 
inspect it. 
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4. Change the Radius value to 35m. Simply select the manipulator value and an in-place editor will 
appear where a new value can be supplied. 

 

 
 

Note: You can modify the value and if you don’t like it use ‘CTRL Z’ to undo 

5. Click in a clear area to release the Inscribed Circle Diameter graphic. 

6. Click on the inner circle of the Central Island. 
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7. Select Element Information icon  

8. Click Roundabout RA and rename to ‘Basic Metric’ 

9. Click on the + sign next to Roundabout Basic Metric 

10. Select Circulatory Area 

11. Expand Transition Offset Rule 

12. Confirm  the following within this dialog (they are contained with the rules): 

Circulatory Crown Offset = 4 

Subsiduary Crown Offset = 4 

Circulatory Width =8 

Over Run Width =1 
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13. Select the Approach on the right side of the roundabout then right click. 

14. Edit the Median Width to 0.5m either side.  

15. Set the Approach to Length and limit the geometric construction length to 100m. 

 
Note. The Element Selection tree view aids us in navigation by allowing single or multiple 
selection of components  

16. Expand the branch for the approach by selecting the [+] sign. Navigate to and expand the entry 
and exit lanes, setting a lane width to 3.5. 

 

  
 



Workshop:   New Tools: Creating Roundabout Libraries 

© 2011 Bentley Systems, Incorporated    13 

17. Select the Deflection Area and set values as shown below.  

 
 

 

Note. All the values can be modified to suit regional design requirements. 
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18. Select the “child” Island contained in the deflection area and confirm the construction values: 

 
 

19. Select the Flare (radius return). Set the following: 

 
 

20. Dismiss the Element Information tool. 
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EXERCISE: DEFINING FEATURES  

This exercise will guide you through process of adding features to the library DGN.  

1. From the Task Menu, select Civil Geometry > Set Feature Definition. 

 

     
 

2. Select EOP as the active feature definition.  

You are now in a prompt to pick the elements, so we now need to work on just one approach as 
we can then copy that approach to others 

3. Select the indicated features that fit the EOP description to define their features. 
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4. Select the indicated features that fit the ESHO description to define their features. 

 

 

5. Finally for this short exercise select the approach centerline and roundabout crown line as the 
feature Proposed Horizontal Alignment. 
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EXERCISE: DUPLICATING THE EDITS - COPY APPROACH 

This exercise will guide you through process of standardizing the library DGN from approach 
modifications we have already made by duplicating to each side of the Roundabout. 

1. From the Task Menu, select Roundabouts > Replace Approach. 

 

   
 

2. Select the Approach we edited in the previous steps and then select the approach at the top of 
the roundabout as the approach to replace. 

3. Continue this task and replace the remaining two approaches. 
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Lesson-3: Placing a Roundabout  

LESSON OBJECTIVE: 

In this lesson, the user will add the new Roundabout Library DGN file to the Civil Library Browser. Place the 
attached Roundabout in the design DGN. 

EXERCISE: ADDING A LIBRARY DGN TO THE BROWSER  

This exercise will guide you through process of adding the library DGN. You will invoke the Civil Library 
Browser and then add the DGN file to the list of available roundabout(s). 

1. Open “Design.dgn”  File > Open… 

2. Open the Library Browser by selecting the icon from the Roundabouts Task Menu.  

 

 
 

3. Within the Library Browser select Add Library. 
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4. Browse to the location of the roundabout Library DGN created in the previous lesson. 
Attach the file: “Metric Roundabout.dgn” 

 

 
 

It should now be displayed in the browser folder leaf view. 
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EXERCISE: PLACING A ROUNDABOUT ON REFERENCE GEOMETRY 

This exercise will guide you through process of placing the library roundabout DGN in your design.   

1. Select the Roundabout model from the library file just opened.  The Place Roundabout will be 
activated.  

2. Select the Place Roundabout command: 
 

 
 

3. Follow the prompts; select the approaches by selecting the two reference features. 
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4. After both reference features ‘alignments’ have been selected, use the Right mouse button, and 
then identify the Center Point of the Roundabout as the intersection of the two reference 
elements. 

Note the centre point can be any XY location and does not need to be located on the reference 
elements. 

 

 
 

5. Left Mouse button accepts the location. 
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Lesson-4: Editing a Roundabout  

LESSON OBJECTIVE: 

In this lesson, the user will review and edit the roundabout to correct an approach error. Then 
make some edits to the approaches. 

EXERCISE: CORRECTING ERRORS AND PERFORMING EDITS.  

1. Open Design.dgn in Lesson 4 

Note the roundabout that has been placed in this drawing has an error where geometry can’t be 
constructed. We need to review the error and adjust the roundabouts geometry. 

 

 
2. Select the Civil Message Center to expose the errors in the rule based geometric construction. 
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3. Click on MicroStation, Warnings and Messages in the Civil Message Center  to turn them off, this 
will leave on just the Errors.  

 

4. These errors are caused by the inability of approach deflection area to be constructed based on 
the baseline geometry.  These errors can be corrected by reviewing the approach flare on the 
right side of the roundabout. Use the Element Information dialog and  adjust the departure 
radius to 75m. 

   

 
 

Note : Remember changes made to an approach can be easily replicated onto other approaches 
using the Replace Approach command. 
 
Try editing the base alignments to see what happens – you can always undo 

  



Workshop:   New Tools: Creating Roundabout Libraries 

© 2011 Bentley Systems, Incorporated    24 

Lesson -5: Adding lanes to an Approach  

LESSON OBJECTIVE: 

In this lesson, the user will edit the roundabout approach to add auxiliary lanes along with a 
taper.  

EXERCISE: ADDING AN AUXILIARY LANE  

This exercise will guide you through process of adding lanes to an approach. You are instructed to add the 
lane, then set the lane property as a widening lane and finally set the taper type and edit the appropriate 
values. 

 

1. Select the approach at the top of the Roundabout.  

2. Bring up the Element Information dialog if you have dismissed it. Expand the Approach tree to 
expose the Entry Lanes. This is where we will add a dedicated right turn lane. 

3. Select the Entry Lanes and set the Number Of Lanes to 2. 

4. Set the Widening property to Yes. 

 

 
Note the information icon at the approach entry indicating something needs to be looked at; 
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5. In the Civil Message Center, toggle on Message  

 

 
 

6. Check the Civil Message Center for this informational message. An edit will need to be 
performed to correct this issue. 
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7. Now the auxiliary lane values need to be ‘hardened’. Select the lane, then and expand the 
Widening Rule. 

 
8. Correct the issues with the Information dialog. 

9. Select the approach Flare and correct the values to 

 
10. Edit the Theoretical Entrance Width to 7m. 

Note the computed entrance width value relative to the theoretical value.  This requires 
correction. 
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11. The computed value is controlled by a number of factors including the “theoretical value” edited 
in the previous step.  Select the Deflection Area and edit the offset value and front radius at the 
entrance as shown below: On completion check the deflection area to see the resulting 
achieved width compared to theoretical. 

 
12. Now duplicate the top approach to the bottom of the roundabout. 
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Lesson -6: Design Analysis and Layout Evaluation  

LESSON OBJECTIVE: 

In this lesson, the user will edit perform design analysis using the Entry Path Curvature 
command. 

EXERCISE: ADDING AN ENTRY PATH CURVATURE  

This exercise will guide you through process of adding Entry Path Curvature to an approach and analyze the 
results.  

1. In MicroStation, select Settings > Design File > Civil Formatting 

 

 
 

2. Set and review the default preferences as shown above and click OK 

3. In the Roundabouts task bar, select the Entry Path Curvature Analysis command or using the 
MicroStation menu Tools > Roundabouts > Entry Path Curvature Analysis 
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4. Set the Entry Path Curvature Analysis tool Measure Method to B-Spline 

5. When prompted to identify the approach, select the left side approach and then select the top 
approach. 

The analysis will complete but you should notice some warning’s in the display that need to be 
reviewed. Open the Civil Message Center to review the resulting warnings. 
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6. To correct the warnings, select the flare at the top approach by selecting it then right clicking and 
edit the radii to 40m to  modify the design. (alternatively this could be carried out in Element 
Information) 

 
. 

7. Select The error: “Entry Radius is too large” in the Message Centr. This indicates a fundamental 
flaw in our design.  We have made the entrances to the roundabout so flat that the entry speed 
is too high and thus dangerous because it encourages motorist to not stop.  This issue is probably 
exacerbated by the skewed approach alignment. Resolving these warnings requires adjustment 
of multiple values to attain optimum entry path and could be achieved by adjusting the entry 
lane as follows. 
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8. Select the deflection area of the left  approach and change to the following: 

 
9. These changes resolve the “Entry Radius is too large error”. They do not completely resolve all 

the errors but gets the entrance radius and exit radius to within a tolerance which may be 
acceptable. 

10. Select the Entry Path Analysis to review the results of the geometric changes. 

 
Additional Analysis can be carried out on the other approaches / exits to review speeds and 
geometry 
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Conclusion 
 

This workshop has taken you through a preliminary introduction to the following concepts in utilizing 
the Bentley Civil Roundabouts toolset: 

 

Creating and Editing a New roundabout library DGN file 

Attaching this roundabout “template” to the Civil Library Brower 

Placing the Library roundabout in the design 

Performing edits to the roundabout to correct errors in the “Rule Based” construction 

Added auxiliary lanes for right turn only movement 

Performed a general analysis of the layout and performed some minor modifications in an 
attempt to improve the design. 
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