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Lesson Objectives 

 
 

In this Lesson we will 
 

• Learn how to Merge surfaces 
 

• Learn how to Edit Surface Features 
 

• Learn how to move a surface 
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Starting InRoads 

 
 

Starting InRoads 
 

1 Double-click the Power InRoads icon. 
 

The MicroStation Manager appears. 
 

If there is no icon, then an alternate path for launching InRoads is Start > Programs > 
Bentley > Power InRoads (SELECTseries 2) > Power InRoads 

 
Open a CAD File 

 

1 Set the directory to C:\Nordic Workshops\X09-Building Surfaces Using 
InRoads\Editing\Pratice\Edit Surfaces 

 

2 Open the CAD file Edit Surfaces.dgn 
 

Opening the Preference file and the Surface files 
 

1 From the InRoads menu, select File > Open 
 

2 Set the Files of type to InRoads Files (*.rwk,*.dtm,*.alg,*.itl,*.sdb,*.xin) 
 

3 Change the Look in directory to C:\Nordic Workshops\X09-Building Surfaces Using 
InRoads \Standards\Preferences 

 

4 Select the file InRoads Training.xin 
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What is a Surface? A Review  

 

 
5 Click Open 

 

6 Change the Look in directory to C:\2007 IUTC\W05 Introduction to Surface 
Editing\Pratice\Edit Surfaces 

 

7 Select the file 20070822_ASabia_Survey.dtm 
 

8 Click Open 
 

9 Select the file 20070823_ASabia_Survey.dtm 
 

10 Open then Close 
 

The two dtm files (surface files) that where opened were generated from two daily 
raw survey file that where processed using InRoads Survey. 
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What is a Surface? A Review 

 
 

What is a Surface? 
 

A surface is an representation of the physical terrain. Surface points are connected 
together to form surface triangles. This process is known as Triangulation. 

 
The terms surface and Digital Terrain Model (DTM) can be used interchangeably. Both 
terms refer to a triangulated model representing a physical terrain such as the existing 
ground or proposed design. 

 
Current versions of InRoads software typically use the term surface instead of digital 
terrain model or DTM. However, many other software applications refer to their models as 
digital terrain models. 

 
Features 

 
Points create a surface and the points are grouped together in to features. A feature can 
represent all the points in a top of curb or an edge of pavement. 
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What is a Feature? 

 
 

What is a Surface Feature? 
 

A Surface feature is anything that is in the DTM. The data could be used to generate 
contours (triangulated together) or non-triangulated data like an underground water pipe. 
A surface feature could be anything that a survey crew might have observed and recorder 
when surveying. 

 
So a feature could be a single survey observation, like a rim elevation shot to a manhole, 
or it could be a line of observations like an edge of pavement or a top of curb. 
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Types of Features 

 
 

Random 
 

Random features, also called spot points, represent non-uniformly spaced points that have 
no direct relationship to other points. Random features are commonly found when the 
surveyed area consists of an open field or grassy area, since there are no identifiable 
terrain features. 

 
Breakline 

 
Breakline features represent a linear discontinuity in a surface such as a ridge, ditch, edge 
of pavement, center line, or curb. The breakline feature type specifies that all points in the 
feature are connected as a linear segment. When the surface is triangulated, the triangles 
are formed so that no triangle leg crosses any breakline features. This maintains the 
integrity of the slope between breakline feature points during triangulation, resulting in a 
more accurate surface. 

 
Contour 

 
Contour features are linear features that come from contour data, which is commonly 
available from mapping agencies. Contour features are triangulated in the same way as 
breakline features. Surfaces created from contour data are normally not as accurate as 
surfaces created from Breakline and Random features. 
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Let’s Take a Look  

 

 
Interior 

 
Interior features are closed shaped linear features that represent a void or hole in the 
surface. Examples include building footprints, lakes, and obscure areas. No triangles are 
formed inside the interior features. You can have unlimited interior features in a single 
surface. 

 
Exterior 

 
Exterior features are closed shaped linear features that form a boundary around the 
surface. No triangle will be formed outside the exterior feature. An exterior feature is 
commonly used to prevent triangles from being formed in areas where the survey data is 
not known. It is also used to maintain cut and fill lines on a proposed design. You can only 
have one exterior feature in a single surface. 



10/21/08 
 
Copyright © 2008 Bentley Systems, Incorporated 

Introduction to Surface Editing 

1 – 9 

Types of Features  

 

 
Let’s Take a Look 

 
 

Viewing the Surface but first the Style Lock 
 

1 Select, from the InRoads menu, Tools > Locks. 
 

2 Is there a check mark next to the word Style? 
 

3 If No, go to the next step, if there is a check mark, click on the word Style, this will 
toggle it off. 

 

Check Tools > Locks again to make sure the check mark is not next to the word 
Style. 

 
Viewing Contours 

 

1 Select Surface > View Surface > Contours. 
 

2 Click the Main tab 
 

3 Set the Surface to 20070822_ASabia_Survey 
 

4 Select the Preferences button. 
 

5 Select Existing Surface preference set name and click Load. 
 

6 Close the Preferences dialog. 
 

7 Click Apply and observe the contours that are displayed. 
 

The use the Fit View command in the CAD software to fit the graphics if needed. 
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Merge Surface  

 

 
8 Close View Contours 

 
Displaying the Surface Features 

 

1 Select Surface > View Surface > Features 
 

2 Set the Surface to 20070822_ASabia_Survey 
 

Notice that all the features that can be displayed are already selected in the dialog. 
 

3 Click Apply 
 

4 Close View Features 
 

5 Window in on the intersection and notice that the contours seem to follow the line 
work that is displayed 

 
Cleaning Up the File 

 

1 Select Surface > Update 3-D/Plan Surface Display 
 

2 Select the Surface 20070822_ASabia_Survey 
 

3 Toggle off Contours 
 

4 Toggle off Features by right-clicking on the feature list and Select None 
 
Bonus: Use a Filter to Display all E_Topo_Tree 
 

 

5 Close Update 3-D/Plan Surface Display 
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Merge Surface 

 
 

Merge Surfaces 
 

The Merge Surfaces command combines the data contained in one surface (the Original 
surface) with the data in another surface (the Design surface). The software places the 
combined data from these two surfaces into a third surface, the Destination surface. The 
two surfaces you want to merge may overlap or be adjacent to one another. In areas of 
common coverage between the two surfaces, the data from the Design surface, rather than 
from the Original surface, will be placed into the Destination surface. However, you can 
choose to also include points from the Original surface in areas of common coverage by 
using the Retain All Original Surface Points option. 

1 From the InRoads menu, select Surface > Edit Surface > Merge Surfaces. 
 

2 Set the Original Surface to 20070822_ASabia_Survey 
 

3 Set the Design Surface to 20070823_ASabia_Survey. 
 

4 Enter Surface Edit Class in the Destination Surface field. 
 

This is the name of the new combined surface that will be created. 
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Merge Surface  

 

 
5 Click to enable the Retain All Original Surface Points check box. 

 

Enabling this check box ensures all points from both the original and the design 
surfaces are copied to the new surface. If disabled, the points from the original 
surface where the original and design surfaces overlap are not copied to the new 
surface. 

6 Click to enable the Retain Features Excluded from Triangulation check box. 
 

Enabling this check box ensures all points in the surfaces that are excluded from 
triangulation are copied to the new surface. If disabled, these points would not be 
copied to the new surface. 

7 Clear the Add Design Surface Edge as Breakline check box 
 

8 In the Duplicate Names section, select Rename. 
 

This tells InRoads to rename features if a feature by the same name already exists 
in the destination feature. The feature is renamed by adding a unique number 
suffix to the existing name. 

9 Click Apply. 
 

10 Click Close to dismiss the Merge dialog box. 
 

Viewing Contours 
 

1 Select Surface > View Surface > Contours. 
 

2 Click the Main tab 
 

3 Set the Surface to Surface Edit Class 
 

4 Click Apply and observe the contours that are displayed. 
 

The use the Fit View command in the CAD software to fit the graphics if needed. 
 

5 Close View Contours 
 

Cleaning Up the File 
 

1 Select Surface > Update 3-D/Plan Surface Display 
 

2 Set the Surface to Surface Edit Class 
 

3 Toggle off Contours 
 

5 Click Apply 
 

All the graphic types selected for that surface will erase 
 

6 Close Update 3-D/Plan Surface Display 
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Display the Surface Perimeter 

 

The Surface Perimeter is the outside edge of the surface data based on the triangulated 
surface. 
1 Select Surface > View Surface > Perimeter 

 

2 Set the Surface to Surface Edit Class 
 

3 Click Apply 
 

4 Close View Perimeter. 
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Transform Surface 

 
 

Transform Surface 
 

The Transform Surface command modifies the coordinates of random, breakline, interior 
boundary, and exterior boundary points. You can use this command to convert imperial 
data to metric, and metric data to imperial. 

 
This command modifies the data in a surface called the Original Surface and places the 
results in a surface called the Destination Surface. 

 
Rotation is assumed to be clockwise from original to destination coordinates. 

 
The transformation is affected by applying a rotation, scale, delta X, and delta Y to each 
point in the data. Rotation and scale are applied relative to the original point, while delta X 
and delta Y are deduced from the coordinates of the original and destination points. 

 
This command automatically triangulates the Destination Surface. 
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Transform Surface  

 

 
Displaying a Control Point 

 

1 Select Surface > View Surface > Features 
 

2 Set the Surface to Surface Edit Class 
 

3 In the Features list, click on the Style header twice 
 

This will sort the list of features alphabetically by Style name 
 

4 Select the feature PM_MN_Monument1004. It should now be the only feature 
highlighted. 

 

This is a feature with only one point. It is a survey control point that the Surveyors 
entered the coordinate in the field. The location was enter improperly. 

5 Click Apply. 
 

6 Close View Features 
 

Transforming the Surface 
 

Notice in the design file that there is a location labeled Actual Location of Monument 
1004. This is where the surface feature should have displayed. In the next steps, a copy of 
the whole surface will be moved to the correct location. 

1 Select Surface > Edit Surface > Transform Surface 
 

2 Set the Original Surface to Surface Edit Class 
 

3 For the Destination Surface enter Corrected Class Surface. 
4 Set the Method to Custom 

 

5 Leave the Angle set to 0^00’00.0”. 
6 Horizontal Scale and Vertical Scale should be set to 1.00 
7 In the Included Features section, right click in the list of features. 

 

8 From the pop-up menu select Select All 
 

9 Activate Replace in the Duplicate Names section 
 

It should not matter here at this time since the destination surface is being created 
new. 

10 In the Original Point section, click on the Northing Easting graphic select button. 
 

11 In the view, snap to and accept the point near the arrow end of the note Entered 
Location Monument 1004 

 

12 In the Destination Point section, click on the Northing Easting graphic select 
button. 

 

13 In the view, snap to and accept the circle labeled Actual Location Monument 1004 
 

14 Click Apply 
 

15 After processing, click Close on the Transform Surface tool. 
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Transform Surface  

 

 
Displaying a Control Point 

 

1 Select Surface > View Surface > Features 
 

2 Set the Surface to Corrected Class Surface 
 

3 In the Features list, click on the Style header twice 
 

This will sort the list of features alphabetically by Style name 
 

4 Select the feature PM_MN_Monument1004. It should now be the only feature 
highlighted. 

 

This is a feature with only one point. It is a survey control point that the Surveyors 
entered the coordinate in the field. The location was enter improperly. 

5 Click Apply. 
 

There should now be a point display in the circle. (If zoomed in close, that point is 
a triangle) 

6 Close View Features 
 

Display the Surface Perimeter 
 

The Surface Perimeter is the outside edge of the surface data based on the triangulated 
surface. 
1 Select Surface > View Surface > Perimeter 

 

2 Set the Surface to Corrected Class Surface 
 

3 Click Apply 
 

4 Close View Perimeter. 
 

Cleaning Up the File 
 

1 Select Surface > Update 3-D/Plan Surface Display 
 

2 Select the Surface Corrected Class Surface 
 

3 Toggle off Perimeter 
 

4 Right click in the list of features. 
 

5 From the pop-up menu select Select None 
 
 

All the graphic types selected for that surface will erase 
 

6  Close Update 3-D/Plan Surface Display 
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Saving the Surface 

 
When working with Surfaces, it is always a good idea to save the changes that where from 
time to time. The total edits to the surface need not be complete but a when a point is 
reached that is good, then it is a good time to save. 

1 Select File > Save As 
 

2 Change the Save as type to Surfaces (*.dtm) 
 

3 Set the Save in directory to C:\Nordic Workshops\X09-Building Surfaces Using 
InRoads\Practice\Edit Surfaces 

 

4 Set Active to Corrected Class Surface 
 

5 Make sure the File name is Corrected Class Surface.dtm 
6 Click Save 

 

7 Close the Save As tool. 
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Extra Data? 

 
 

Extra Data 
 

There are times when a surface appears to have extra data or improper data in a survey. 
This could be caused by triangulation. It is not the fault of the routine, it is just the 
connection of the points across areas that there is no real data. In the next steps, you will 
learn how to clean up that problem. 

 
Display Triangles 

 

1 From the InRoads menu select Surface > View Surface > Triangles. 
 

2 Set the Surface to Corrected Class Surface 
 

3 Click Apply. 
 

4 Click Close. 
 

Notice the large triangles extending from the cross road to the next ramp taper to 
the west. These triangles should not be in the surface. One way to limit the 
formation of triangles is using the Maximum Length setting. 

 
Bulk Cleanup of Erroneous Triangles 

 

1 Select the Surface > Triangulate Surface tool. 
 

2 Make sure that the Surface is set to Corrected Class Surface 
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Extra Data?  

 

 
3 Set the Maximum Length to 100.00. 

 

The Maximum Length option defines the longest possible triangle leg. Any 
triangles that require a leg longer than this value will not be created. A value of 0 
allows any triangle length to be created. 

4 Click Apply. 
 

The surface is triangulated. 
 

5 Close the Triangulate Surface dialog box. 
 

6 Display the triangles for the surface (Hint: Surface > View Surface > Triangles). 
 

Notice the gaps in the triangles in the west side of the surface. It looks as if there is 
data missing that should be there. To solve this problem, the Maximum Length 
needs to be a little larger than 100 feet 

7 Select Surface > Triangulate Surface tool. 
 

8 Make sure that the Surface is set to Corrected Class Surface 
 

9 Set the Maximum Length to  400.00. 
10 Click Apply. 

 

11 Close the Triangulate Surface dialog box. 
 

12 Display the triangles for the surface (Hint: Surface > View Surface > Triangles). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Triangles displayed with maximum length of 400. 
 

Generally speaking the triangle model is much improved. There are no obvious 
holes or gaps in the surface. However, examination of the area to the north of the 
ramps (the area enclosed with the box) shows that there are still some extra 
triangles that should be removed. 
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Delete Triangle and Create Exterior  

 

 
Delete Triangle and Create Exterior 

 
 

Cleanup of Erroneous Triangles 
 

1 Zoom In or Window into the northern part of the intersection as shown in the 
prior illustration. 

2 Select Surface > Edit Surface > Delete Triangle. 
 

3 Verify the Surface is set to Corrected Class Surface. 
 

4 Click Apply. 
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5 When prompted to Identify triangle, click on the inside of the arc starting at a 

location where it appears the triangles should not exist. Use the illustration below 
to help locate that spot. 

 
 

 
 
 

Illustration of where the triangles are to be deleted. 

6 Move the cursor to the left. The triangles to be deleted highlight as the dynamic 
line passes over them. 

7 Position the cursor to the outside of the triangles and click. 
 

The highlighted triangles will be deleted if the operation is accepted. 
 

8 Click again to accept deleting the triangles. 
 

The triangles are deleted from the surface and the graphic display is automatically 
updated. 

9 Now it is your turn. Delete a few triangles in the intersect quadrants just to the 
north east and north west of the arc area using the illustration below as a guide. If 
a mistake is made, re-triangulate the surface and start over. 

 
 

Illustration of what the intersection should look like after the triangles are deleted. 
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Delete Triangle and Create Exterior  

 

 
Adding an Exterior Boundary to a Surface 

 
Triangles deleted from a surface will be regenerated if the surface is triangulated again. To 
permanently delete triangles around the exterior of a surface, an exterior boundary is 
required. 

 
After the triangles are removed from the outer extents of a surface, the perimeter of the 
surface is displayed into a graphics file. This produces an element around the cleaned up 
outer boundary of the surface. The graphic element can be loaded into the surface as an 
exterior boundary element. Once the exterior boundary element is defined in the surface, 
future triangulations will respect the boundary and no triangles will be formed outside of 
it. 

 
Cleaning Up the File 

 

1 Select Surface > Update 3-D/Plan Surface Display 
 

2 Set the Surface to Corrected Class Surface 
 

3 Toggle off Triangles 
 
 

All the graphic types selected for that surface will erase 
 

4 Close Update 3-D/Plan Surface Display 
 

Displaying the Perimeter 
 

1 Select the Surface > View Surface > View Perimeter. 
 

2 Set the Surface to Corrected Class Surface 
 

3 Click Apply. 
 

The perimeter of the modified surface is displayed. 
 

4 Close the dialog box. 
 

Add the Exterior Boundary 
 

1 Select File > Import > Surface. 
 

This tool is used to read graphic data and create a feature in the surface. 
 

2 Select the From Graphics tab. 
 

3 Set the Surface to Corrected Class Surface. 
 

4 Set Load From to Single Element. 
 

5 Set the Elevations to Use Element Elevations. 
 

6 Enter Exterior in the Seed Name field. 
 

This defines the name of the new feature created. 
 

7 Set the Feature Style to E_SURF_OriginalGround. 
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8 Set the Point Type to Exterior. 

 

9 Click Apply. 
 

10 When prompted to Identify element, click on the perimeter graphic. 
 

11 Click to accept it if the whole element highlights. If only part of the element 
highlights, right-click until the whole element highlights. 

 

The new exterior boundary feature is extracted from graphics and loaded into the 
surface. 

12 Close the dialog box. 
 

Triangulate and Display 
 

1 Triangulate the Corrected Class Surface making sure that the Maximum Length is 
set to  0.00. 

 

Since there is now an exterior boundary to define the outer limit of the surface, the 
Maximum Length parameter no longer needs to be defined to restrict which 
triangles get created. 

2 Display the triangles for the Corrected Class Surface 
 

Save the Surface 
 

1 Select File > Save > Surface 
 

Since the surface Corrected Class Surface is the active surface and was once 
saved in this lesson, the changes that where done to the surface are now 
incorporated to the file that was on the disk. Before saving the file, the file on the 
disk had only the updates up to the time the surface was last saved. 

 
Cleaning Up the File 

 

1 Select From the MicroStation menu Edit > Select All 
 

2 Click Delete Element 
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Review of a Feature 

 
 

There are two features in this surface that do not belong. The name of these features are 
TP_MM_ConcreteSlab1391 and TP_MM_ConcreteSlab1392. In this section, you will be 
presented with two different ways these features can be handled. One method is to exclude 
the feature from being used in triangulation, the other way is to completely delete the 
feature from the surface. 

1 Select Surface > View Surface > Features. 
 

2 Set the Surface to Corrected Class Surface 
 

3 Scroll through the list of Features and click on the feature 
TP_MM_ConcreteSlab1391 

 

4 Hold the CTRL key down on the keyboard and click on the feature 
TP_MM_ConcreteSlab1392 

 

5 Release the CTRL key 
 

6 Click Apply 
 

7 Fit the View 
 

There should be two lines displayed. 
 

8 Right click in the Feature list 
 

9 On the Pop-up menu, select Select All 
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10 Click Apply 

 

There should now be a line between the two concrete slab features. 
 

11 Dismiss the View Features tool. 
 

Reviewing a Feature 
 

There are a couple of ways to review a feature in InRoads. The Feature Properties 
tool is one way to review a feature. The Feature Properties tool can be used to 
change the Style associated with a feature, the feature type (Breakline, Random, 
etc.) and the name of the feature. The points that are the feature can also be listed 
and reported on. 

1 Select Surface > Feature > Feature Properties 
 

2 Make sure the Surface is set to Corrected Class Surface 
 

3 Click on the Graphic Select button next to the list of features 
 

4 Select the line that is located between the two Concrete Slab lines 
 

5 Accept the highlighted line 
 

This should be the feature RD_ED_ShoulderPavedEdge1295 
 

6 Click List Points 
 

7 Review the listed points and pay attention to the elevation (The Z coordinate) 

The elevation range on this feature is 1987.20 to 2001.93 

8 Close the Results dialog. 
 

Reviewing Another Feature 
 

1 Scroll through the list of Features and click on the feature 
TP_MM_ConcreteSlab1391 

 

2 Click List Points 
 

3 Review the listed points and pay attention to the elevation (The Z coordinate) 

Notice that the two points on this feature are at elevation 1982.26 and 1982.24 

4 Close the Results dialog 
 

5 Select the feature TP_MM_ConcreteSlab1392 
 

6 Click List Points 
 

7 Review the listed points and pay attention to the elevation (The Z coordinate) 

Notice that the two pints on this feature are at elevation 1982.28 and 1982.24 

8 Close the Results dialog 
 

Since a pavement shoulder is 5 or more feet above these slabs, then either the 
elevation or location is wrong for the slab. Either way, they do not need to be in 
the triangle network. 
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Exclude from Triangulation 

 
To see the results of the edits that are about to be done, the contours will be displayed. 

 

1 Leave the Feature Properties tool displayed 
 

2 Select Surface > View Surface > Contours 
 

3 Click Apply 
 

Since the surface Corrected Class Surface is the active surface, we did not have to 
worry about checking the Surface setting 

4 Notice there are contours between the two slab lines and the edge of pavement 
line that are between them 

 

5 On the Feature Properties tool, select the Feature TP_MM_ConcreteSlab1392 
 

The feature should still be selected for the passed active. 
 

6 In the Triangulation section, toggle on Exclude from Triangulation 
 

7 Click Apply on the Feature Properties tool 
 

8 Click Apply on the View Contours tool 
 

9 A Triangles are out of date warning will display. Click Yes to have the surface re- 
triangulate. 

10 Notice that the contours between the pavement edge and the lower slab line are 
now gone. 

11 Close the Feature properties tool but leave the View Contours tool displayed. 
 

Deleting a Feature 
 

The feature TP_MM_ConcreteSlab1391 will be deleted out of the surface. 
 

1 Select Surface > Edit Surface > Delete Feature 
 

2 Select the feature TP_MM_ConcreteSlab1391 
 

3 Click Apply on the Delete Feature tool 
 

4 A confirmation dialog will display, click OK 
 

5 Notice that the feature is erased from the view. 
 

6 Close Delete Feature 
 

7 Click Apply on the View Contours tool 
 

8 A Triangles are out of date warning will display. Click Yes to have the surface re- 
triangulate. 

9 Notice that the two contours above the edge of pavement line are now gone. 
 

10 Close View Contours 
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Which Method is Best? 

 
The big difference here is that by using the Delete Feature tool, the feature is not in the 
surface. That means is that if there was a reason that feature was in the surface, now there 
is no access to that feature. So which method is better to use. It all depends on why you 
need the feature in the surface and not in the triangle network. 
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Generate Longitudinal Feature 

 
 

Generate Longitudinal Feature 
 

This command creates a longitudinal feature based on existing features or graphic 
elements. This command lets you define your new feature based on horizontal offsets, 
vertical offsets, slopes, absolute elevations, and even slope projections derived from other 
elements or features. You can use this command with lines and polylines. If your existing 
data is 2D, you can use this command to help you model the actual slopes and elevations 
of the surface. This command also solves the problem of arcs being locked to one 
elevation. 

 
After you choose Apply, the command prompts you for various elements (a primary 
element, a reference element, and so on). The prompts vary depending on the settings you 
have chosen on the Controls tab. 

 
When you go to accept or reject the solution offered by the command, your cursor 

position is significant. As you move your cursor, the solution can be presented on the left 
or right side of the selected elements. Position your cursor appropriately when you accept 
the solution. 
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Locate Lock 

 
 

Locate Lock 
 

The Locate lock applies when you use a locate button to specify a position in the graphics 
file. (Locate buttons are found throughout the interface. Each button is indicated by cross 
hairs icon.) The Locate lock determines whether to snap to graphics displayed in the 
graphics file or to snap to the position occupied by a feature in the active surface. 

 
If the lock is set to graphics (the icon shows a single, red line), locate actions will seek the 
nearest displayed graphics. 

 
If the lock is set to features (the icon shows an image of a surface), locate actions will seek 
the position of the nearest feature in the active surface whether or not the feature is 
actually displayed. You can use the locate lock to locate features that are not even 
displayed. If they exist in the DTM, the locate will find them. 
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Follow Me 

 
 

Creating a Feature 
 

1 Select Tools > Locks 
 

2 If the icon next to Locate does not look like the icon below, then click Locate if it 
does then click in the view. 

 

 
Locate Lock set to Locate Features 

3 Select Surface > Design Surface > Generate Longitudinal Feature 
 

4 Click on the Main tab 
 

5 In Reference Feature section, toggle on Interval and enter  0.25 
 

The interval is how often a point will be created, in this case every .25 
feet. 

 

6 In the Longitudinal Feature section, set the Mode to New 
 

7 Toggle off Generate Graphics Only 
 

8 Enter New Slab for the Name 
9 Set E_TOPO_Foundation for the Feature Style 
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10 Set the Point Type to Breakline 

 

11 Toggle on Exclude from Triangulation 
 

The Controls tab 
 

1 Click the Controls tab 
 

2 In the Horizontal section, set the Method to Offset from Primary Feature 
 

3 Enter 1.25 for both the Start Offset and the Stop Offset 
4 In the Vertical section, set the Method to Offset/Offset 

 

5 Enter 0.00 for both the Start Offset and the Stop Offset 
 

This means that the new feature will have the same elevations as the feature that is 
being selected as the reference feature. 

6 Click Apply 
 

7 When prompted to Identify Primary Feature, select the line the represents the 
feature TP_MM_ConcreteSlab1392 

 

The prompt will now read Accept/Reject TP_MM_ConcreteSlab1392 
 

8 Click in the view to accept the feature. 
 

9 When prompted to Identify Reference Feature, click on and accept the feature 
TP_MM_ConcreteSlab1392 

 

10 When prompted Identify beginning/Reset for Entire, right click. 
 

11 When prompted to Identify location, click near the top of the view 
 

A new feature has just been added to the surface. 
 

12 Close Generate Longitudinal Feature 
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Edit Feature Point 
 

The Edit Feature Point command allows you to edit the positions of individual points 
within a feature. The simplest way to do this is to just key in the northing, easting, and 
elevation values that you want. However, the command does offer more advanced 
methods of defining new coordinates for a point. Specifically, you can define the position 
of a feature point by defining its distance, direction, or slope from either the previous or 
next point in the feature. 

 
You can also use this command to insert a point midway between two existing points by 
using the Insert button. The new point is inserted midway between the current point and 
the previous point. The current point is the one specified in the Point field on the dialog 
box and is indicated in graphics by a small box with an X in it. 

 
After using the Insert button or specifying a value in any field, you must click Apply or 

the point will not be added/edited. 
 

Editing a Point Using the Back and Ahead Parameters 
 

If the Back and Ahead parameters are not displayed on your dialog box, click the More 
button to display the full dialog box. 
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Editing the parameters in the Back and Ahead groups boxes is an indirect way of defining 
the northing, easting, and elevation of the current point. When you key in a value 
anywhere in the dialog box, the indicator for the current point moves to the newly defined 
position, indicating the proposed solution. If you want the solution, click Apply; 
otherwise, use the Close button to exit the command. 

 
At any time, the Back and Ahead parameters show the computed distance (Length), 
direction, and slope values from the current point to the back and ahead points. Changing 
a value in one of the Back parameters affects the corresponding value in the Ahead 
parameters, and vice versa. 

 
Editing a Feature Point 

 

1 Select Surface > Edit Surface > Edit Feature Point. 
 

2 Set the Feature to New Slab 
 

A box should now be displayed at the end of the feature 
 

3 Use the arrow buttons in the Point line and follow the location of the box. 
 

The box is the point location indicator. 
 

4 Using the arrows, stop at point 5 
 

Notice the Northing, Easting and Elevation of the point is listed. 
 

5 Click the Graphic Select button for the Northing and Easting only. 
 

6 Move the cursor around and notice that a temporary line will move indicating 
where the breakline and the point is located. 

7 Click in the view to set the location of the point 
 

Notice now that the location box is off the line. The box is indicating where the 
point will be moved if the Apply button is clicked 

8 Click Apply 
 

The feature is now updated in the surface and the graphic of the feature is also 
updated in the view. 

 
More 

 

1 Click the More >> button 
 

2 Notice the Back and Ahead information. This is the directions, distances and 
slopes from the active point to the points back and ahead of this point. 

 

3 Using the arrow buttons for the point, go to the end of the feature New Slab 
 

This should be point 10 
 

4 In the Back section, change the Direction to N 5.0 W and TAB. 
 

Notice that the point location box is now south of the feature 
 

5 Click Apply 
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6  Using the arrow buttons for the point, go to Point 9 

 

Notice that the Ahead direction is now S 5-"'0'00.0"E 
 

7  Close Edit Feature Point 
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Intersect Features 
 

This tool will extend two features to intersect. This intersection point will be common for 
both features. This command does not combine the two features. 

1 Select Surface > Edit Surface > Intersect Features 
 

2 In the Feature 1 section, set the Surface to Corrected Class Surface 
 

3 Using either the graphic select button or using the drop down list, set the Name to 
New Slab 

 

4 In the Feature 2 section, set the Surface to Corrected Class Surface 
 

5 Using either the graphic select button or using the drop down list, set the Name to 
TP_MM_ConcreteSlab1392 

 

6 In the Elevation section, toggle on Match at Feature 1 
 

Do Not Change intersects the features without modifying the elevation of any 
feature points. 

7 Click Apply 
 

Temporary graphics appear displaying a possibly result. If there was more then 
one possible, then as the cursor was moved in the view, the closest solution to the 
cursor will display. 
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8 Click in the view 

 

9 Close Intersect Features. 
 

Question Authority 
 

Are the two features really at the same elevation? 
 

1 Select Surface > Edit Surface > Edit Feature Point 
 

2 Using either the graphic select button or using the drop down list, set the Feature 
to New Slab 

 

Notice that there is now 11 points and not just 10. 
 

3 Use the arrow buttons and “walk” the feature until the end. 
 

Notice the direction the feature points are in. 

Note that the elevation is 1982.28 

4 Using either the graphic select button or using the drop down list, set the Feature 
to TP_MM_ConcreteSlab1392 

 

Notice that there is now 3 points and not just the 2 there before. 
 

5 Use the arrow buttons and “walk” the feature until the end. 
 

Note that the elevation is 1982.22 So the Intersect Features tool will add a point to 
the features involved. 

6 Leave the Edit Feature Point tool active. 
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Reverse Feature Direction 
 

The Reverse Feature Direction command reverses the order of the points along a feature, 
making the first point the last point. This procedure affects the order in which points in a 
feature are processed in commands such as Edit Feature Point. 

1 Select Surface > Edit Surface > Reverse Feature Direction 
 

2 When prompted Identify feature, select the feature New Slab 
 

3 When prompted Accept/Reject New Slab, left click in the view to accept 
 

4 Right click to exit the command 
 

Did it work? 
 

1 On the Edit Feature Point tool, use either the graphic select button or use the drop 
down list to set the Feature to New Slab 

2 Notice that Point 1 is now at the intersection point with the feature 
TP_MM_ConcreteSlab1392 

 

3 Use the arrow buttons and “walk” the feature until the end. 
 

Is the feature now in the reverse direction? 
 

4 Close Edit Feature Point 
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Join Features 
 

The join Features command combines two distinct features into one. The command 
prompts you to identify one feature and then another. After you identify the features, the 
command combines the points from both features and saves the resulting feature using the 
name of the first feature that you identified. The other feature (the second one that you 
identified) is deleted. The direction of the feature is based either on the direction of the 
points of the first feature selected or the general direction of both features points. 

1 Select Surface > Edit Surface > Join Features 
 

2 When prompted to Identify feature, select the feature New Slab 
 

3 When prompted to Accept/Reject New Slab, left click in the view to accept. 
 

4 When prompted to Identify feature, select the feature TP_MM_ConcreteSlab1392 
 

5 When prompted to Accept/Reject TP_MM_ConcreteSlab1392, left click in the 
view to accept 

6 Right click to exit the command. 
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Did it work? 

 

1 Select Surface > Edit Surface > Edit Feature Point 
 

2 On the Edit Feature Point tool, use either the graphic select button or use the drop 
down list to set the Feature to New Slab 

3 Notice that the first point is where the start of TP_MM_ConcreteSlab1392. 
 

4 Use the arrow buttons and “walk” the feature until the end. 
 

Notice there is now 13 points on this feature. The two common points where 
combined as one point. 

5 Close the Edit Feature Point tool 
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Changing the Feature 

 
 

So far, the feature New Slab has been excludes form triangulation. Now the feature will be 
added into the triangle network and also the features type will be changed. 

1 Select Surface > Feature > Feature Properties 
 

2 Make sure the Surface is set to Corrected Class Surface 
 

3 Use either the graphic select button or select from the list of Features the feature 
New Slab 

 

4 In the Triangulation section change the Feature Type to Interior 
 

5 Toggle off Exclude from Triangulation 
 

6 Click Apply 
 

7 Close the Feature Properties tool 
 

Displaying the Changes 
 

1 Select Surface > View Surface > Contours 
 

2 Click Apply 
 

3 A Triangles are out of date warning will display. Click Yes to have the surface re- 
triangulate. 
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4 Notice that the contours will display up to graphic of New Slab on the right, but 

why does it look as if there is a line on the left? 
 

An Interior feature type is a closed shape. If the feature being placed in the surface 
is an Interior type and is not closed, Inroads will connect the two end points. This 
is true with Exterior feature types also. 

5 Close View Contours 
 

6 Select Surface > View Surface > Features 
 

7 Click Apply 
 

8 Notice that the New Slab feature is closed. 
 

If the feature is changed back to breakline, the feature will still remain closed 
because a closing point had to be added. 

9 Close any open tools. 
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Questions 

 
 

Questions? 
 

1 When through, exit the product. 
 

2 If prompted to save any surface files, click No to All 
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