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INTRODUCTION 

There is more to Templates than simple components and end conditions. You can use parametric constraints, layered 
components, point testing and display rules. Our goal in this workshop is to collect a series of capabilities that provide 
milling, leveling, overlay, widening, curb & gutter along with retaining walls when cut/fill slopes are inadequate. All of 
these components are defined in this single template. 

Display Rules 

Establish relationships between items in the template. If conditions are true or false then components can appear or 
not be placed into the design. Experience shows this to be a powerful tool however overuse can lead to insanity. 

Parametric Constraints 

These are named variables that can be used to set new values for a defined station range. This capability extends the 
usefulness of your template libraries across a wide range of projects. 

Complex Components 

Two for the price of one makes these efficient for calculating areas based on cut/fill slopes for seeding and sodding 
quantities. 

Activities for the resurfacing and widening on 5 lane roadway 

• Review the template 
• Create wearing component 0.0508m thick 
• Define milling for new cross slope 
• Add leveling component for additional cross slope control as needed 
• Widen left and right from existing edge of pavement to 8.1m 
• Add curbing and sidewalk on both sides 
• Define cut and fill within limits 
• Seeding and mulching quantity components for side slopes 
• Retaining walls where limits are exceeded 
• Use of Parametric Constraints for design changes 

 

  

  



Workshop:   Creating Advanced Components and Templates 

© 2011 Bentley Systems, Incorporated    3 

Lesson Name: Opening a Project ( Power InRoads) 

LESSON OBJECTIVE:  

Initiate Power InRoads and load the files that you will use in this workshop. 

Video: 01_Getting_Started-InRoads.wmv 

EXERCISE: GETTING STARTED 

This exercise will guide you through the steps to get started 

1. All workshop files are in C:\2011 RBC Data\CR3WK3-Creating Advanced Components and 
Templates\Data\ 

2. Start Power InRoads and open work.dgn. 

3. Load the CR3WK3.rwk file which has the civil.xin, CR3WK3.alg, existing.dtm, InR_Resurface.ird 
and Class.itl files 

4. Open Design > Create Template.  

 

Lesson Name: Opening a Project (GEOPAK User) 

LESSON OBJECTIVE: 

Describe this lesson in one or two sentences. 

Video:01_Getting_Started-GEOPAK.wmv 

EXERCISE: GETTING STARTED 

This exercise will guide you through the steps to get started 

1. All workshop files are in C:\2011 RBC Data\CR3WK3-Creating Advanced Components and 
Templates\Data\ 

2. Start Power GEOPAK and open work.dgn. 

3. Open Applications > GEOPAK > Corridor Modeling. 

4. Select the GPK job number 001 

5. Choose File > Load from the Corridor Modeling dialog. 

6. Load the Corridor Modeler project called Resurface.rdp 

7. Select Open Create Template.  
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Lesson Name: Template Review 

LESSON OBJECTIVE: 

There is a completed template in the library that you are going to look at to familiarize yourself with the 
finished product of this workshop.  

Video:02_Template_Review.wmv 

EXERCISE: REVIEW 

This exercise provides information on the finished template 

1. Go to Templates folder and select “5 Lane CG widening” and make it active by double-clicking the 
name. 

2. Use Test to see the cut/fill and milling and overlay results.  

3. Close Test and right-click on L_Control, select Test Point Controls > Test Horizontal Point Control 
and then move the point left and right to see what happens to widening. 

4. Do the same action with R_Control. Notice that when the control reaches the curb line the 
Subbase is still visible. We will talk about that later. 
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Lesson Name: Create Template 

LESSON OBJECTIVE: 

In this set of steps you will create a template and the first component.  

Video:03_Create_Template.wmv 

EXERCISE: CREATE TEMPLATE NAME AND FIRST COMPONENT 

This exercise provides information on creating a named template and the first component. 

1. Right-click on the folder Templates. Select New > Template from menu. 

2. Similar to Windows Explorer you can enter in a new name, Class, to replace the default name of 
New Template. 

3. Right-click on the new template name to Set Active.  

4. Right-click for a menu on the drawing area. Select Add New Component > Unconstrained. 

5. Enter a name, Wearing, into the Name field. Style is Top_Asphalt from the dropdown menu. 

6. Toggle on the Dynamic Settings from the strip menu at the bottom and set Steps for XY to .1. This 
is to make it easier for you to select the 0,0 point which is the only precision placement we will 
make.  

7. Place the first point at 0,0. Place 5 more to represent the left and right edges of pavement and 
the points underneath. When down there should be 3 points for LEP, CL and REP plus points 
underneath to represent the bottom of the wearing surface layer. Right-click and select Finish 
from the menu. The Closed Shape should be toggled on. 

8. You are now going to edit the point names and set the constraints for all but CL. The first point at 
0,0 is called CL, Style=AC_P and it has no constraints. The top point to the right is REP, Style=PE-P  
and has a HC=8.1 and Slope of -2% from CL. The point to the left is LEP, Style=PE-P and has a HC=-
8.1 and Slope of 2%. The points below CL, REP and LEP will have the same name but with a 1 
added and each will have a HC=0, Style=Phantom and VC=-0.0508. 

9. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: Defining the Milling Component 

LESSON OBJECTIVE:  

Your next step is to define the milling component. You want it to plane the existing asphalt off at the slope of 
the new designed wearing surface. This requires that we place it on the bottom of the wearing component. 
You will also establish a control for left and right as null points and constrain the edges of existing to them. 

Video:04_Creating_Milling_Component.wmv 

EXERCISE: CREATE MILLING COMPONENT 

This exercise will guide you through the steps to define the milling component and test. 

1. Change the Y Step to 0.01 and exit dynamic Settings. We no longer require this dialog. 

2. Right-click on the drawing area and select Add New Component > Overlay/Stripping 

3. Name=Milling, Style=Milling, Top Option=Follow Surface, Bottom Option=Follow Component, 
Component Depth=0.0, Label=Milling, Surface=<Active>, toggle on Stripping Component. 

4. Place 1st point on CL1, wait until it turns white to show it is snapped. This automatically merges 
the points as the original name. 

5. Place your next point to the left, no need to snap to a point and do NOT snap it to LEP1. Right-
click for menu and select Finish. 

6. Right-click on the red line and from the menu, select Add Point. Add another point to the right. 
Right-click for menu and select Finish. 

7. Right-click on the component and insure the name is Milling. There might have been a suffix 
added. Close the dialog. 

8. Right-click on the left point of the milling template and Edit. Change the point name to XLEP, 
Style=Milling, Constraint Vector-Offset, CL1 to LEP1=0, HC from CL1=-5.5 

9. Select the right point of the milling template and Edit. Change the point name to XREP, 
Style=Milling, Constraint Vector-Offset, CL1 to LEP1=0, HC from CL1=5.5 

10. Now to establish 2 null points to act as point controls. Right-click on drawing surface and Add 
New Component > Null Point and place a point approximately over the XLEP and above the 
wearing component. Do the same over the XREP point. 

11. Edit the left null point, Name=L_Control, HC to XLEP=0.0, Apply. Then remove the Horizontal 
Constraint and Apply again. All we wanted to do was make the point directly over XLEP. 
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12. Edit the right null point, Name=R_Control, HC to XREP=0.0, Apply. Then remove the Horizontal 
Constraint and Apply again. All we wanted to do was make the point directly over XREP. 

13. Now change the Horizontal Constraints for XLEP and XREP to be the control points. Edit XLEP and 
change the Horizontal Constraint to be off L_Control=0.0 then Apply. Edit XREP and change the 
Horizontal Constraint to be off R_Control=0.0 then Apply. 

14. Now test the L_Control point by right-clicking on it and choosing Test Point Controls > Test 
Horizontal Point Control. As you move the point side to side you will see the XLEP point moved 
and also change the width of the milling. Do the same with the R_Control to insure it works. 
These control points will be used in conjunction with point controls and have a part in Display 
Rules later. 

15. But there is a problem with this as good as it seems. Select the L_Control point and move it left of 
the LEP point. What happens? The XLEP point is outside the roadway limits and so is the milling 
and leveling components. That is not acceptable so we need to limit the range. We will do that 
next. 

16. Create two more null points approximately over the LEP and REP points. Name one L_Max and 
the R_Max relative to their locations. Horizontally constrain them to the LEP and REP points. 

17. Edit XLEP and change the Horizontal Constraint to Horizontal Maximum.  L_Control to L_Max 
=0.00 and then Apply. Test the point and XLEP should not go farther left than the LEP location. 

18. Edit XREP and change the Horizontal Constraint to Horizontal Minimum. This time we are 
reducing the distance in the template coordinate system and going to the right so the first point 
is R_Control and then R_Max=0.000. Test the R_Control point and verify that it does not exceed 
the REP point horizontally. 

19. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: Leveling 

LESSON OBJECTIVE:  

Leveling components are the reverse of milling. You are adding material to an existing surface to correct 
slopes. Where the milling might not get all of a rut out the leveling adds material. Another use is correcting 
superelevation. 

Video:05_Leveling.wmv 

EXERCISE: MAKING A LEVELING COMPONENT 

This exercise will guide you through definition of the leveling component. 

1. Right-click on the drawing area and select Add New Component > Overlay/Stripping. 

2. Name=Leveling, Style=Leveling_Asphalt, Top option=Follow Component, Bottom option=Follow 
Lowest, Component Depth=0.0, Label=Leveling, Surface=<Active>, No Stripping Component. 

3. Place a point on XLEP, CL1 and XREP. Right-click and select Finish. 

4. Test the component with the test button. Enter a 1% Surface Slope and then with Draw move the 
surface up and down to see how the milling and leveling components react to conditions. When 
you are done testing, Close the dislog to return to the template editor.  

5. If you retest the Horizontal Control for L_Control you should see the Leveling reacting the same 
as the milling. If you do not then you might need to merge points. 

6. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: Widening the Existing Roadway 

LESSON OBJECTIVE:  

You will now define additional Base asphalt for widening outside of the existing pavement. This will be a 
component on both sides of the roadway attached to the XLEP and XREP points. 

 

EXERCISE: WIDENING COMPONENTS 

This exercise will guide you through the steps to create widening component. 

Video:06_Widening_Base.wmv 

1. Right-Click on the drawing area and select Add New Components > Simple, Style=Base_Asphalt, 
Slope=-2.0%, Thickness=0.1016, Width=(8.1-5.5). The operation in parenthesis will be evaluated 
as 2.6 giving you the distance between XREP and REP1 which is a quick way to get distances. 

2. Move your cursor into the drawing area and you are dragging the right base component. You can 
place both left and right if you right-click and select the Mirror option. Place the component on 
XREP. Both components are placed and coincident points are automatically merged. 

3. Right-click on the right base component and select Edit Component. Edit the name to be R_Base. 
Using the target button next to the name, select the left base component and change it’s name 
to L_Base. 

4. Rename the point under LEP1 to LEP2, the point under XLEP to XLEP1, the point under XREP to 
XREP1, and the point under REP1 to REP2. They have already been constrained by using the 
Simple component option. 

5. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: Creating Display Rules 

LESSON OBJECTIVE:  

Build rules to display or not display widening components. 

Video:07_Display_Rules.wmv 

EXERCISE: DISPLAY RULES 

This exercise will guide you through the steps to create display rules. 

1. Right-click on the L_Base component and select Edit. 

2. On the dialog select the Edit button for Display Rules. 

3. The Component Display Conditional Expression dialog appears. This looks imposing but it is quite 
simple. At the bottom select Add and you will create an expression. 

4. In the Display Rule dialog, Name=LtWidening, Description=Pavement Widening Rule, 
Type=Horizontal, Between=L_Control, And=LEP, >, 0.000 then select OK. This creates a rule 
where we are testing to see if the distance between the LEP and the L_Control is greater than 
zero. 

5. Now select the Lt_Widening rule and then the Selected Rule button above. This adds the rule to 
the L_Base component. Then click on the “=” button so that True appears in the next field.  Select 
OK and the dialog returns to Edit Component Properties with the Lt_Widening Rule shown. Select 
Apply and then Close. 

6. Test the rule you created by right-clicking the L_Control point and selecting Test Point Controls > 
Test Horizontal Point Control. Move the point left and right. Notice that the component 
disappears when the L_Control point is over or to the left of the LEP. 

7. Now do the same procedure on the right side of the template for the R_Base component except 
we are once again in an opposite hand to the left side so we are going to test that the condition is 
less than (<). Another twist to this is for the condition to be set to (<=). This will show the 
component if the control is on top of the REP point. We will use this in a later exercise. Test your 
work after exiting Component Properties. 

8. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: Adding Components from the Library 

LESSON OBJECTIVE:  

You can add preprepared components from the template library. This is a quick exercise to show you how to 
use the drag and drop with Mirroring to speed the process. 

Video:08_Curb_And_Sidewalk.com 

EXERCISE: COMPONENT DRAG AND DROP 

This exercise will guide you through the steps to add component to the template. 

1. Open the Misc Components folder in the template library. 

2. Select the C&G 50 Curb Hgt. component and holding down the left mouse button drag the 
component onto the drawing area without releasing the cursor button. Once on the drawing area 
depress the right mouse button to open a menu and select Mirror. Now you have two opposite 
components that will move equidistant from 0,0. Move the cursor over the REP point until the 
point turns bold white. That means you have snapped to the point and when you release the left 
mouse button the points will be merged when the components are placed. 

3. Go back to the Misc Components folder and drag Sidewalk out onto the drawing area. This 
component is already mirrored because the option is on until you change it. Hover over the top 
back of curb on the right side until you see the point become bold white and then release the 
component.  

4. These are basic components and do not have any slopes so change the sidewalk slopes to 2% 
sloping toward the roadway. 

5. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: Subbase Components 

LESSON OBJECTIVE:  

You will create another component for the gravel Subbase under the asphalt and curbing.  

Video:09_Subbase.wmv 

EXERCISE: SUBBASE COMPONENTS 

This exercise will guide you through the steps to create the Subbase. 

1. Right-click on the drawing area and select Add New Component > Unconstrained. 

2. Name=L_Subbase, Style=Subbase. 

3. Start drawing the component starting at XLEP1 go down 0.3048 to XLEP2, left to a point under 
the back of curb, up to the bottom of the sidewalk at 100% slope, over to the right bottom corner 
of the sidewalk, down to the bottom back of curb, right to the bottom of curb, up to the bottom 
left of the base asphalt then right-click to get the menu up and select finish.  Make L_Base the 
parent of L_Subbase. 

4. If you have not turned off the Mirror function, the right side is done also. Otherwise perform the 
same operations on the right. Rename the right side to R_Subbase. Adjust values as needed. 
Make R_Base the parent of R_Subbase. 

5. Now you can add constraints to the points that were not placed on another point. The point 
under the back of the curb is -0.2461 lower. The point at the bottom of the can be constrained 
with a Vertical Constraint = 0.2461. 

6. This section is left vague by design because you can find what is needed without point by point 
steps. 

7. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: End Conditions 

LESSON OBJECTIVE:  

You will place and test end conditions for cut/fill and a retaining wall. 

Video:10_Cut_And_Fill.wmv 

EXERCISE: END CONDITIONS 

This exercise will guide you through the steps to place and test end conditions. 

1. Open Tools > Options to display the Template Options dialog 

2. Toggle on Apply Affixes and delete the Suffixes and create Prefixes of L_ and R_. 

3. Close dialog 

4. Open the End Conditions folder in the template library. 

5. Select Urban Cut/Fill and drag to the back of the right sidewalk.  

6. Right-click and turn off Mirror and attach it to the sidewalk. 

7. Right-click on one of the cut slopes and select the topsoil component. This is defined as a child of 
the cut so it does not show unless the cut is successful.  The same with the Seeding and Mulching 
component. This is a suggested method for collecting quantities on areas. 

8. Do the same operation and add the cut/fill end condition to the left, using the Reflect option in 
the right-click menu. 

9. Open the Test screen and try different combinations. 

10. Exit the Test Screen and Add the Retaining Wall from End Conditions to both sides at the outside 
top edge of the sidewalk. This adds a wall if cut and fill fail. 

11. Open the Test screen and try different combinations. 

12. Save your template library with a Ctrl-S or go to File > Save. 
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Lesson Name: Using the Template 

LESSON OBJECTIVE:  

We will create a corridor with the template and review the results. We will need to create controls for the 
right and left sides 

Video:11_Roadway_Designer.wmv 

EXERCISE: ROADWAY DESIGNER 

This exercise will guide you through the steps to create a corridor in Roadway Designer 

1. Open Roadway Designer 

2. Open the Template Drops and replace the current with your new Class template. 

3. Review the design looking at the existing edge vs. the new edge of pavement. 

4. Open Tools > Parametric constraints. Make changes and review results. 

5. Create a surface and view Components to see how this template looks in the design. 

6. Thank you. 

 

Summary 

This concludes the workshop. If there is time left you may explore more areas of the Template creation or Roadway 
Designer. 
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