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Preface 
In this workshop, you will construct a roadway interchange horizontal layout utilizing the V8i 
SELECTseries 2 Horizontal Civil Geometry tools.  We have structured the contents of the 
exercises herein to allow your interaction with a broad range of available tools, however, we 
will not use every tool.  Also, it is impossible to engineer a complete interchange in the time 
frame of this workshop, but we will use the tools in their real-life context, so you can see 
how to utilize them in your own engineering projects.  

This workshop is equally applicable for MX, InRoads or GEOPAK families of products.  Each 
product contains the identical toolset and identical workflow.  The only differences between 
the three products for the tools are slight differences in the use of feature definitions and 
some differences in the back end interaction with other native toolsets such as drainage.  In 
this workshop, we will use Power InRoads V8i 08.11.07.536. 

There are more exercises in this manual than we will have time to cover today.  We will all 
complete the basic set of exercises, and for those veteran users in the group who complete 
them and still have time left in the exercise session, you are welcome to work on the 
optional.   

In order for all participants to design the same layout and to stay on course and on time, we 
request that all participants utilize the files as listed in the workshop materials.  At the 
beginning of each chapter, we will start with a fresh set of data.  This ensures that everyone 
is using the same data, plus we have added data to avoid redundant work.  For example, we 
draw some of the edges of pavement in the lab so you can understand the workflow, but 
have drawn the remainder in for expediency of time. 

Note: Prerequisite Knowledge Level: Participant should have a basic understanding of 
road design principles and be fluent in use of MicroStation and the native 
application (MX, InRoads or GEOPAK).  
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Before the Workshop Begins… 
While we are waiting to begin today’s workshop, let’s do some quick checks to be sure your 
workstation / laptop is ready to go.  We have preloaded the workshop files and settings in 
order to save set-up time.   

 Exercise:  Check Workstation / Laptop Settings 

1. Use the provided login and password to access your laptop. 
2. Your instructor will provide the path to the workshop dataset.  Using the Power 

InRoads icon on your desktop, open checkworkshop.dgn.  The Power InRoads 
projects dialog opens.  Do NOT close the dialog, just minimize it. 

3. Select Workspace > Configuration from the Power InRoads main menu bar. 
4. Scroll down and click on the variable MS_DGNLibList.   

 
5. Check to ensure the workshop path is included as one of the listings.  If it is not 

listed, please advise the instructor and complete the following steps to add the files.  
Do NOT complete these steps if your configuration is already correct. 

6. Click Select.    
7. Chose the design standards and the XIN features file from our project directory.  

(Both can be done at the same time and have dgnlib extensions). 
8. Click Add. 
9. Click Close to exit the dialog.  
10. Click OK to close the Configuration dialog.  When prompted to save the 

configuration, click Yes. 
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11. Next we’ll check our cell library is attached.  Select Element > Cells from the Power 
InRoads main menu bar.  Stds2.cel (containing one cell) should be attached.  If not, 
select File > Select File from the Cell Library dialog.  Select stds2.cel from your 
project directory.  Close the Cell Library dialog. 

12. Close the MicroStation file.  



Overview 
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Chapter 1: Introduction to Horizontal 
Geometry Tools 

OVERVIEW 
Civil Geometry is a dynamic, interactive, rules based approach to geometry that provides an 
unprecedented level of associativity by preserving design intent, snaps and Civil Accudraw 
input.  The results of the tools are intelligent graphic elements which can be dynamically 
edited and associations between elements are automatically updated. 

The results of the tools are graphical geometry elements stored as MicroStation elements.  
There is no external geometry file.  The geometry elements are MicroStation elements with 
additional intelligence applied to store the rules and associations.    

The Civil Geometry tools are installed as a part of GEOPAK, InRoads and MXROAD products.  
In order to be consumed by processes within GEOPAK, InRoads and MXROAD, the civil 
geometry must be written to the native application coordinate geometry file (alg, gpk or fil).  
This is handled automatically.  Elements are written to and updated in native application 
based on properties of feature definitions. 

PROJECT DESCRIPTION  
In this workshop we will construct a mainline alignment, a cross-road alignment and 
interchange including ramps, loops and access roads.  Note the view is rotated so the 
mainline is displayed in a west-east orientation.  

 
Alignments created with horizontal geometry tools 
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The table below is the dimensions we’ll use throughout the project. 

DESCRIPTION VALUE 

Lane Width 3.6m 

Ramp Width 5.0m 

Median Width 3.5m centerline, 3.0 loop/ramp 

Entrance Taper 1:50 

Exit Taper 1:15 

Stationing Format 1+234 

 

GETTING STARTED 
In this first section, we will review some of the tools and settings we’ll be using throughout 
the workshop.  For easy accessibility, we will dock the tools within the MicroStation view.   

 Exercise: Open Design File and Tools 

Lesson Objective:    

1. Open file Start_ch1.dgn.    

 
The data is in a reference file (ExistingMap2.dgn) and is the background for our new geometric layout. 

2. From the Power InRoads main menu bar, select Tools > Civil Geometry > Design 
Standards to open the design standards toggle bar. 

  
3. From the Power InRoads main menu bar, select Tools > Civil Geometry > Features 

Toggle Bar to open the Feature Toggle ToolBar.   Don’t select any feature for now. 
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4. From the Power InRoads main menu bar, select Tools > Civil Geometry > Civil 
Message Center.  This is for feedback on our Design Standards and geometry tools.   

 
5. Dock and pin the message center, design standards and feature definitions bars at 

the bottom. 
6. From the Power InRoads main menu bar, select File > Item Browser, which opens 

two dialogs, Items and Details. These are for reviewing Design Standards and 
Feature Definitions.  Dock and pin the Items dialog on the right side and the Details 
on the bottom. 

Hint:      The Items Browser can also be found on the Primary toolbar but is hidden by 
default. Right click on the toolbar and select Items to enable access from the 
toolbar. 
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NAVIGATING THE TASK BARS 
The Civil Geometry tools are located on the task navigation in group named “Civil 
Geometry”.  To open the toolset, click Expand Group.  Click the same icon to Collapse the 
group. 

 
There are several ways the navigation group can be displayed.  For this workshop, we’ll use 
the Panel Layout Mode, which is the default.   
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If you prefer listings rather than icons, you may prefer the List Layout Mode. 

 
Your preference may be to not use the navigation task bar.  Other options include: 

• Select any tool from Tools > Civil Geometry > Tools or Horizontal Geometry from the 
Power InRoads main menu bar. 

• Select <F2> from your keyboard which opens the main navigation menu.  Select Civil 
Geometry.  After selecting Civil Geometry, you can use Q, W, E, R, T,or A 
(corresponding to the letters to the left of the group).  For example, selection of Q 
opens the Main Geometry pop-up menu. 

 
To use the classic toolbox for any sub-group, right click on the line and select Select 
“Toolset”  as Toolbox.   

 
You can also customize which tools are displayed.  Other customizing options can be found 
by right-clicking on the navigation groups.  Customization of task navigation is outside the 
scope of this workshop, but you may want to experiment in your spare time or after the 
workshop is concluded.  

Hint:      If the Task panel disappears or you accidentally close it, select Tools > Tasks 
from the Power InRoads main menu bar to bring it back! 
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FEATURES AND FEATURE DEFINITIONS 
In our initial set-up, we opened the Features Toggle ToolBar.  There is no icon in task 
navigation, it must be opened from the Power InRoads main menu bar (Tools > Civil 
Geometry > Features Toggle Bar ).   

 
Feature definitions are used to define options when creating features.  These are the items 
which are created in advance, usually used across multiple projects and define symbology, 
annotation and quantities. The feature definition is assigned (usually) in the plan model and 
profile/3D feature definitions follow from there. 

A Feature is anything that can be seen or located and is a physical part of your design, 
representing a real world thing.  A feature’s definition is one of its properties.  At any given 
time in the design process, the feature will have a Horizontal Geometry, a Vertical 
Geometry, a 3D Geometry or a combination to define its location. 

Most commands have entry fields for feature on their dialog.   

• If Use Feature is not checked, then active MicroStation symbology is used and no 
feature is defined. No naming is used. 

• If Use Feature is checked, but no feature is selected, then active MicroStation 
symbology is used and no feature is defined, but you can define a name prefix. 

• If Use Feature is checked, then a feature is assigned, a naming prefix is applied and 
the symbology, attributes, and annotation defined in the feature definition are 
applied to the element. 

Note: It is often useful to set the command to “Active Feature” and then control the 
active feature to be used in the Features Toggle Bar. Alternatively you can 
choose a specific feature directly in the command dialog and ignore the toggle 
bar. 

IMPORTING DATA 
To begin any project, you will need some type of existing data.  It may be CAD files from 
prior projects, survey information, or even historical paper plans.  You can mix and match 
the type of data you have for your project. If you have no data, you can even start with a 
blank file! 

In our project, we will use some historical data to create one of our crossing road centerline.  
For another alignment, we will import our mainline alignment from another project.  We will 
then modify the alignment to adhere to our Design Standards.   
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 Exercise: Import the Existing Centerline  

Objective:  Import the mainline alignment and display in our file.   

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Import Geometry 

 

Procedure: 

1. Open file Start_ch1.dgn. 
2. Select the Saved View “Existing Mainline.” In order to see the alignment we are 

importing, the saved view has turned off the display of the reference file. 

Hint:      The Saved Views can be accessed in the View Setup section at the bottom of 
the View Attributes dialog.  

 

3. Select the Import Geometry command (top row, left icon). 
4. Select mainline.alg (in your project folder) and click Open.   

 
5. Navigate the tree and toggle on MAINLINE.  Note the upper part of the hierarchy is 

toggled on also.  Do NOT toggle on Default. 
6. Click Import.  
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7. Fit the view to see the mainline alignment.  Note our view is rotated so it will display 
in a west to east direction. Since we did not select a feature definition, the level 
Default was used.  

 
Imported existing mainline alignment 

USING HISTORICAL DATA 
We will use some historical survey points to create the centerline for the intersecting 
highway.  This stretch of roadway is a tangent section, so it’s easy to create.  We could just 
use the line between points command, but we want to maintain the location of the 
historical points.  So, we’ll place the points first, then draw a civil element (line) between 
them.  

 Exercise: Create Cross-Road from Historical Data 

Objective:  

Create two historical points which will be displayed as triangles.  Then connect them with a 
civil geometry line.  Note this alignment will be in a north-south direction and drawn in red.  

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  Point 

  Line Between Points 

Procedure: 

1. Continue in the file Start_ch1.dgn. 
2. Select the Saved View “Cross Highway.” 
3. Select Utilities > Keyin from the Power InRoads main menu bar.  We’ll use this for 

the coordinate data input.   

 
4. Select the Civil Geometry Point command. 
5. In the Point dialog, toggle on Use Feature and set the Feature Definition to 

Historical Points (using the pick list). 
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6. Now we’ll follow the heads-up prompt attached to the cursor to draw our points: 

HEADS-UP PROMPT USER ACTION 

Enter Data Point In the Key-in dialog opened in step 3, carefully type in: (do not space before or after 
the equal sign and include the comma) 
xy=767641.50,179118.90   <enter> 

Enter Data Point In the Key-in dialog opened in step 3, carefully type in: (do not space before or after 
the equal sign and include the comma) 
xy=767283.123,179478.032<enter> 

7. Two red cells are drawn into the file.  They are actually our triangle cell.   

 
8. Close the Key-in dialog. 
9. Select the Line Between Points command.   
10. In the dialog, toggle on Use Feature and select the Feature Definition HA Roadway 

from the pick list.  Notice the list is different than when we defined the Historical 
Points.  The pick list differentiates between linear and point feature definitions.   

Note: When no feature is used, the elements are drawn with the active MicroStation 
symbology. 

11. Now we’ll follow the heads-up prompt attached to the cursor to draw our 
alignment. 

HEADS-UP PROMPT USER ACTION 

Enter Start Point Select the southern point you just placed.  You can zoom in and out to reach the 
point. 

Enter End Point Select the northern point you just placed. 
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12. We now have the existing cross road alignment drawn in red.  If yours is black, you 
didn’t set the Feature Definition correctly.  Simply undo the element and place 
again.  

 
Two existing alignments are now displayed 

STATIONING AND STATION EQUATIONS 
When creating an alignment, the stationing is set to zero, by default.  However, you may 
want to station your alignments or add station equations.  In order to add stationing, we 
need to specify the station value and define the point where the station should be applied.  
For this workshop, we will station our crossing alignment.  Note station equations are 
outside the scope of the workshop.   

 Optional Exercise:  Adding Stationing to Cross Road Alignment 

Objective:  

Add initial stationing of 10+000 to our cross road alignment.  

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Start Station 

 

Procedure: 

1. Continue in the file Start_ch1.dgn. 
2. Select the Start Station command.  As we are not drawing any elements, this dialog 

does not have a feature definition.  
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3. Now we’ll follow the heads-up prompt attached to the cursor to draw our 
alignment. 

HEADS-UP PROMPT USER ACTION 

Locate Element Select the cross road alignment near the southern end. 

Start Station Position / Start 
Distance  

Type 0 <enter>.  Then data point on screen to move to the next 
prompt. 

Enter Starting Station / Start 
Station 

Type 10+000 <enter>.  Then data point on the screen to complete the 
command.   

4. Just above the Civil Geometry group task, click on Element Selection.  Then select 
the alignment.  The edit manipulators and station are now displayed. 

Hint:      The size and colours of the manipulators can be user defined in the 
Workspace > Preferences > View Options – Civil. 

 
The Element Selection icon is used to select civil geometry elements and display edit manipulators 

 

CHAPTER SUMMARY 
In this chapter, we have learned how to import horizontal geometry from an existing ALG 
file (created in Power InRoads), and also how to manually enter points from historical data.  
We created a single line alignment and added stationing. 
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Chapter 2: Alignments and Standards 
USING DESIGN STANDARDS 

Design standards can be used to maintain required curvature and other alignment checks 
when performing geometric layouts. They work at two levels: 

• Provide values for the element creation tools (for example, minimum radius and 
transition lengths) 

• Check the suitability of complex elements (for example, check for kinks in the 
alignment) 

DESIGN STANDARDS FEEDBACK 
When a design standard is violated feedback is provided in two ways: 

• An icon in the graphics, on the element that has the problem. Hover over the icon to 
reveal a tool tip report of the error. 

• In the Civil .Message Center. 

DESIGN STANDARD TOOLBAR 
On the menu select Tools > Civil Geometry > Design Standards to open the design standards 
toggle bar. 

 

This toolbar allows you to set an active design standard used by all commands. 

Procedure: 

1. Select the desired standard. 
2. Click the button on the left to toggle the standard on or off. When on, all commands 

will make use of the values contained in the standard. When off, the selected 
standard is ignored. 

 Exercise: Create the New Centerline Based on Standards 

Objective: We will utilize the design standards and feature definitions to modify the 
centerline for our mainline roadway. We’ll use the eastern and western 
tangents, then rebuild the center section with arcs and tangents.  The goal is 
to shift the roadway to lessen the skew between mainline and the 
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intersecting highway.  This will help in the design of a full cloverleaf 
interchange. 

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  Line Between Points 

  
Arc From Element 

  
Line Between Arcs 

  Complex By Elements 

 

Procedure: 

Hint:      Remember if you don’t like what is drawn, use the “Undo” command <ctrl> - 
Z on your keyboard or Edit > Undo on the Power InRoads main menu bar!  

1. Open Start_ch2.dgn.   
2. Select the 70 KPH standard from the Design Standard Toolbar.  (This was docked at 

the bottom of your view in an earlier exercise.) 

 
3. Toggle on Active Design Standard toggle to the left of the Toolbar, so it appears 

orange.  Any subsequently created geometry elements will use the selected 
standard.  

4. Double check the active symbology is set to Level - Working Elements, Weight 2, and 
color other than red. (Green is used for illustrations.) 

5. Select the Line Between Points command.  
6. In the dialog, toggle off Use Feature.  We’ll build all our working elements, then 

we’ll select a Feature Definition when we connect them together.  

Note: When no feature is used, the elements are drawn with the active MicroStation 
symbology. 

7. Now we’ll follow the heads-up prompt attached to the cursor to draw our western 
tangent. 

HEADS-UP PROMPT USER ACTION 

Enter Start Point Select the western point of the mainline alignment.   

Enter End Point Snap to the other end of the same tangent section.   

8. We now have the western tangent drawn in green. 
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9. Repeat the same process for a tangent at the eastern end. 

 
10. Turn off the Default Level, as we no longer need to see the existing (black) 

alignment. This is the section we are going to redesign. 
11. Now we’ll draw a curve to 70KPH standards on the west end going northward, and 

another on the east end going southward.  
12. Starting with the west end, select the Arc from Element command.   

HEADS-UP PROMPT USER ACTION 

Locate Element Select the western tangent.   

Enter Offset Type 0 <enter>.  Data point on the screen to move to the next prompt. 

Enter Start Point Select the right end of our tangent.   

Thru Point or Radius The radius is set to 510, from our standards.  We’ll use this value.  
Note the <=> at the right of the Radius value.  This indicates 
additional options. Select the right arrow on your keyboard. 

Back Transition Length This is also from our standards.  If you select the right arrow on your 
keyboard again, you’ll see the Radius of 510.  Data point to confirm 
the entries.   
Move the cursor towards the top of the screen to see the arc 
dynamically displayed.  As you move the cursor, the Arc Length is 
changing.  Data point when the length is approximately 300m.  

Trim / Extend Select Back (using the down arrow on your keyboard to toggle 
through the options) and data point to complete the command.  

13. On the east end, we want to start the arc at a different location than the end of the 
tangent.  Select the Saved View “East Tangent” so we the existing roadway edges 
are displayed. 

14. Select the Arc from Element command and follow the Heads-up prompts.   

HEADS-UP PROMPT USER ACTION 

Locate Element Select the eastern tangent.   

Enter Offset Type 0 <enter>.  Data point on the screen to move to the next prompt. 

Enter Start Point Now we want to data point at the curb return as shown. 

   
Thru Point or Radius The radius is set to 510, from our standards.  We’ll use this value.  Note the <=> 

at the right of the Radius value.  This indicates additional options. Select the right 
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arrow on your keyboard. 

Back Transition Length This is also from our standards.  If you select the right arrow on your keyboard 
again, you’ll see the Radius of 510.  Data point to confirm the entries.   
Move the cursor towards the bottom of the screen to see the arc dynamically 
displayed.  As you move the cursor, the Arc Length is changing.  Data point 
when the length is approximately 250m.  

Trim / Extend Select Back (using the down arrow on your keyboard to toggle through the 
options) and data point to complete the command.  

 

 
15. Now we need to draw the tangent to connect the curves.  Select the Line Between 

Arcs command (W row, fourth icon). 
16. Follow the heads-up prompts to draw the line.  Note we will be creating our 

alignment from west to east, so draw the line in that direction. 

HEADS-UP PROMPT USER ACTION 

Locate First Element Select the western arc.   

Start Offset Set to 0 and data point to accept.  

Locate Second Element Select the eastern arc. 

Second Offset Set to 0 and data point to accept. 

Solution Actually, there are four solutions.  Click <Alt> on your keyboard to see each 
solution.  When the desired solution is displayed, data point to accept. 

Trim / Extend Use the down arrow on the keyboard for the Both option, then data point to 
complete the command. 

 

 
Tangent is drawn between two arcs, completing our last working element. 
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Now we are going to connect all the working elements together in one alignment.  At the 
same time, we’ll use a feature definition, so we get the correct symbology, correct naming, 
and persist back to the ALG file. 

17. Select the Saved View  “Complex Elements.” 
18. Select the Complex By Elements command to create the alignment (from left to 

right on the screen).   
19. In the dialog, set the Method to Manual, as we have quite a few trimmed elements.  

Set the Maximum Gap to 0.03.  We also want to toggle on Use Feature and set our 
Feature Definition to HA Roadway. 

 

Note: The name prefix functions like an auto numbering process.  In this example, the 
first element would be named CL, the next would be CL1, CL2, and so on.  But it 
can also be used for absolute naming which is especially useful for alignments.  
So, for example, I could have entered a name prefix here of “BOB RD” and since 
there is no other element with that name, the alignment would be named 
“BOB RD”. In other words, no suffix. The alignment will be annotated based on 
the settings of the native feature table (XIN).  The active drawing scale must 
match a scale stored in the native feature table. (Settings > Drawing Scale)   i.e., 
Metric plan scale = 500. 

20. When prompted to Locate the First Element, select the western tangent on the 
western end, being mindful of the arrows.  If the arrow is going the wrong direction, 
move the cursor until you get the correct direction.  Continue selecting the 
elements in order, ignoring the Max Gap warnings.  This is because we are using 
trimmed elements.   

21. When all elements have been selected, data point a final time to accept the 
alignment.  The alignment is chained together and the symbology is changed to 
match the feature definition. 
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SETTING FEATURES AFTER - THE - FACT 
Did your alignment not change to red after creating complex from elements?  Perhaps you 
forget to set (or incorrect set) the Feature Definition?    

No problem, there’s a tool to set a Feature Definition after elements are drawn.   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Set Feature Definition 

 

Procedure: 

1. Select the Set Feature Definition command. 

 
2. Select the Feature Definition from the pick list (linear options only). 
3. Select the elements to apply the Feature Definition.  Multiple elements may be 

selected without reselecting the command. 

SETTING DESIGN STANDARDS FEATURES AFTER - THE - FACT 
Did you forget to set (or incorrectly set) the Design Standard?  Or would you like to check an 
existing alignment?   

No problem, there’s a tool to set a Design Standard after elements are drawn.   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Set Element Design Standard 

 

Procedure: 

1. In the Design Standard Toolbar, select the desired Design Standard from the pick 
list. 

 
2. Select the Set Element Design Standard command. 
3. Select the elements to apply the Design Standard.  Multiple elements may be 

selected without reselecting the command. 
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CREATING NON-ALIGNMENT ELEMENTS 
The horizontal geometry tools are used for more than just centerline alignments.  In this 
session, we will utilize more of the horizontal tools in conjunction with feature definitions to 
construct the edges of pavement and shoulders for the mainline roadway.  We need these 
in place before we develop the loop and ramp alignments.  

In addition, we’ll see a new look to the one of our icons.  Look closely at the Single Offset 
Entire Element and see the small black triangle in the lower right corner.   

 
This indicates that there are multiple commands in this grouping.  

 
The Reverse Curves (icon directly to the right of Offsets and Tapers) also has multiple 
commands. 
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 Exercise: Construct the Edges of Pavement and Shoulders 

Objective: Construct edges of pavement and shoulders for both sides of the mainline 
alignment. We’ll also use the Feature Toggle Toolbar to set the feature 
definition. 

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Single Offset Entire Element 

 

Procedure: 

1. Continue in start_ch2.dgn. 
2. Set the Feature Toggle Toolbar to Features.xin > Linear > SHLD Prop.  

Hint:      The Features Toolbar should be docked on the bottom of the screen from an 
earlier exercise.  If it’s not docked, select Tools > Civil Geometry > Features 
Tool Bar from the Power InRoads main menu bar and dock at this time. 

3. Select the Single Offset Entire Element command.    
4. On the command dialog, toggle on Use Feature.   Set the Feature Definition to Use 

Active Feature. 
5. Now we’ll follow the heads-up prompt attached to the cursor to draw our elements: 

HEADS-UP PROMPT USER ACTION 

Locate Element Select the mainline centerline. 

Offset Key in 3.3 <enter>.  Note the lock symbol to the right of the offset value.  
Move cursor to the right side of the centerline and data point to accept the 
construction and create the offset element. 

Offset Key in 3.3 <enter>.  Note the lock symbol to the right of the offset value.  
Move cursor to the right side of the centerline and data point to accept the 
construction and create the offset element.  You do not have to reselect the mainline 
centerline.  

 

Now we’ll repeat the steps to draw the edges of pavement.   

6. Set the Feature Toggle Toolbar to Features.xin > Linear > EP Prop. 
7. Select the Single Offset Entire Element command.    
8. On the command dialog, set the feature to active feature. (It should be set from the 

previous command.) 
9. Now we’ll follow the heads-up prompt attached to the cursor to draw our elements: 

HEADS-UP PROMPT USER ACTION 

Locate Element Select the mainline centerline. 

Offset Key in 17.4 <enter>.  Note the lock symbol to the right of the offset value.  
Move cursor to the north side of the centerline and data point to accept the 
construction and create the offset element. 

Offset Key in 17.4 <enter>.  Note the lock symbol to the right of the offset value.  
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Move cursor to the south side of the centerline and data point to accept the 
construction and create the offset element.  You do not have to reselect the mainline 
centerline.  

 Optional Exercise:  Drawing Partial Element for Southern Loops 

Objective: Now we’ll draw another parallel element to use for our southern loops, this 
time just in the area of the interchange.   
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Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Single Offset Partial Element  (Note you need to select the small black 
triangle to get the command from the pulldown menu.) 

 

Procedure: 

1. Continue in Start_ch2.dgn.   
2. Set the Feature Toggle Toolbar to Features.xin > Linear > HA Ramp. 
3. Select the Single Offset Partial Element command.    
4. On the command dialog, set the feature to active feature. (It should be set from the 

previous command.) 
5. Now we’ll follow the heads-up prompt attached to the cursor to draw our elements: 

HEADS-UP PROMPT USER ACTION 

Locate Element Select the mainline centerline. 

Offset Key in 22.3 <enter>.  Note the lock symbol to the right of the offset value. Note the 
<> to the right of the edit field.  This indicates additional prompts.  Press the<right 
arrow> on your keyboard.  

Start Distance This is measured from the beginning of the alignment.  Key in 200 <enter>. Move the 
cursor to the south side of centerline and data point.  

End Distance This is also measured from the beginning of the alignment.  Key in 650 <enter>. 
Move the cursor to the south side of centerline and data point to complete the 
construction. 

 

 

 
Non-alignment elements drawn with offset commands 

 

EDITS AND MANIPULATION OF ELEMENTS 
One advantage of placing civil elements is the ability to dynamically edit them.  By selecting 
the element, edit manipulators are displayed.  Edit fields are supported for many properties, 
along with graphic handlers for dynamic movement.  The edit fields and handlers are based 
on the type of element selected and the command used to place them.  
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 Exercise: Edit the Pavement Edges 

Objective: In this lesson we will correct an error in the pavement edge calculations.  
Our section is 3 lanes in each direction (3.6m per lane) plus a (3.5m) median 
each side of centerline.  So the outside edge should have been set at 14.3m 
not 17.4m. 

Geometry Tools Used:   

None. 

Procedure: 

1. Continue in Start_ch2.dgn.   
2. Select one of the outside edges of pavement. Note the width drag handle at the 

midpoint. 

 
3. We could drag this to set the width dynamically, but a more precise entry is needed. 
4. Zoom in to the roadway (at mid-point or either end) until you also see a text 

manipulator for the width. Click on the text to allow changing of the value. Change 
the offset to 14.3m. 

 
4. Repeat on left side with a value of 14.3m. 

Hint:      If you get it wrong just undo with <CTRL> Z. 

CHAPTER SUMMARY 
In this chapter, we have utilized Design Standards to develop new alignments and learned 
how Feature Definitions affect the horizontal geometry elements.  We have used the tools 
to develop non-alignment elements, and then manipulated them. 
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Chapter 3: Developing Loops 
OVERVIEW 

In this chapter, we will construct the inside loops.  We can use the Arc Between Elements 
command to construct the entire loop or ramp in one operation.  In addition to spiral 
transitions, the tool can create arc transitions as well, which allows you to create 2-center 
and 3-center curves.  By using the Design Standards tool, we can draw the elements to the 
desired design speed.  We’ll use our mainline and cross road alignments, and use offsets to 
define the starting and ending points.  In that way, if we adjust the alignments, we can also 
update the loops or ramps. 

The Complex Arcs icon has the small black triangle in the lower right corner.  It’s the fourth 
icon in the “E” row of tools.  This indicates that there are multiple commands in this 
grouping.  

 

ELEMENT SELECTION FOR COMPLEX TOOLS 
Now that we are starting to build more complex elements, we need to understand the 
relationship between the various input fields.  In this chapter, we need two alignments to fit 
the loop or ramp.  While we can select the elements in any order, each selection has 
associated transition and taper options.  For example, if we select our mainline alignment as 
our first element, the Back Taper and Transition are based on that alignment.  The second 
selected element relates to the Ahead Transition and Taper options.  

The loops have some severe constraints that will reduce the design speed of the ramps.  We 
will develop the inside edge as the alignment, then offset for the outside edge of the loop.   
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 Exercise: Construct The Northeast Loop Alignment 

Objective: Construct the inside ramp centerline.   

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Arc Between Elements 

 

Procedure: 

Hint:      Remember if you don’t like what is drawn, use the “Undo” command <ctrl> - 
Z on your keyboard or Edit > Undo on the Power InRoads main menu bar!  

1. Open Start_ch3.dgn.   
2. Select the 50 KPH standard from the Design Standard Toolbar.  (This was docked at 

the bottom of your view in an earlier exercise.)  Ensure the icon to the left of 50 KPH 
is toggled on (indicated by the orange color). 

 
3. Set the Feature Toggle Toolbar to Features.xin > Linear > HA Ramp.  This will draw 

on the same level as our other alignments, but in a deeper red color. 
4. Select the Arc Between Elements command.  (You may have to select the small 

black triangle to expand the command selection list to see it.) 
5. At the bottom of the command dialog, toggle on Use Feature and set the Feature 

Definition to Active Feature. (It should be set from the previous command.) 
6. Now we’ll carefully follow the heads-up prompts attached to the cursor to draw our 

loop: 

HEADS-UP PROMPT USER ACTION 

Locate First Element Select the cross road centerline. 

Enter Start Offset We can graphically select the existing edge of pavement. 

 
Move cursor to the right side of the centerline and data point to accept the element. 

Locate Second Element Select the mainline centerline. 

Second Offset In this case, we have 14.3m to the shoulder, then we’ll need 3m for the ramp median 
/ gore plus 5m for the actual ramp for a total offset of 22.3m. Use the key-in prompt 
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and data point to accept.  

Select Construction 
Sector / Radius 

Return to the dialog for a moment. Notice our offsets are populated with our 
selections.  The Radius is populated from the Design Standards, along with 
Transition data.  Toggle on Loop and return to the screen.  Do NOT data point yet!  If 
the arc is the wrong hand, use the <ALT> key to change to the alternate hand. 
If you are zoomed out quite a distance, you’ll see a huge red loop, based on our 
standards.  Since we cannot consume that big of a footprint, change the Design 
Standard to One Step Below Desired Minimum at 50 KPH. (Click the + to the left of 
50 KPH to display this option.  Note the red loop is substantially smaller and the 
radius value in the dialog is now set to 127.  Data point to complete the construction.  

 

 
Completed Northeast Loop 

 Exercise: Construct The Northwest Loop Alignment 

This loop has a smaller footprint than the northeast loop we just completed.  Therefore, we 
will need to drop our standard one more step.  Another option would be to lower the design 
speed.  We will develop the inside edge as the alignment, then later we can offset for the 
outside edge of the loop.   

Objective: Construct the inside ramp centerline.   

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Arc Between Elements  

 

Procedure: 

Hint:      Remember if you don’t like what is drawn, use the “Undo” command <ctrl> Z 
on your keyboard or Edit > Undo on the Power InRoads main menu bar!  

1. Continue in start_ch3.dgn. 
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2. Select the 50 KPH\Two Steps below Desirable Minimum at 50 KPH standard from 
the Design Standard Toolbar.  (This was docked at the bottom of your view in an 
earlier exercise.)  Ensure the icon to the left of 50 KPH is toggled on (indicated by 
the orange color). 

 
3. Verify the Feature Toggle Toolbar is still set to Features.xin > Linear > HA Ramp. 
4. Select the Arc Between Elements command. 
5. At the bottom of the command dialog, toggle on Use Feature and set the Feature 

Definition to Active Feature. (It should be set from the previous command.) 
6. In the dialog, change the Start Offset to 15m.  Note the radius value have also 

changed since we changed our Design Standard. 
7. Now we’ll carefully follow the heads-up prompts attached to the cursor to draw our 

loop: 

HEADS-UP PROMPT USER ACTION 

Locate First Element Select the cross road centerline. 

Enter Start Offset Since we changed the value to 15m in the dialog, we can just move the cursor to the 
left side of the centerline data point to accept.  

 
However, we could have selected it graphically also.  

Locate Second Element Select the mainline centerline. 

Second Offset In this case, it’s the same as the previous loop, 22.3m.  

Select Construction 
Sector / Radius 

Move the cursor to see the northwest loop.  It should be a smaller footprint than our 
northwest loop.  Data point to accept.  
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Completed Northeast and Northwest Loops 

EDITS AND MANIPULATION OF ELEMENTS 
As we saw in the last session, an advantage of placing civil elements is the ability to 
dynamically edit them.  This is also true of complex elements, such as the loops we just 
developed.    

 Exercise: Edit the Northeast Loop 

Objective: We will review the edit manipulators and handlers for the loop. 

Geometry Tools Used:   

None. 

Procedure: 

1. Zoom into the northeast loop so it fills the screen. 
2. Select the loop (using the element selector).  

 
3. We can edit the offsets, radii, or transition lengths.  Experiment by changing the 

values and see the dynamic updating. 
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DEVELOPING THE SOUTHWEST LOOP 
For this alignment, we will once again use the Design Standards.  However, we will combine 
it with the Spiral Curve Spiral command.  In this case, the command does not have the 
option for offsets, so we need to select the actual elements.  

 Optional Exercise:  Develop the Southwest Loop 

Objective: Construct the inside ramp centerline.   

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Spiral Curve Spiral 

Procedure: 

1. Continue using the 50 KPH\Two Steps below Desirable Minimum at 50 KPH 
standard from the Design Standard Toolbar.  Ensure the icon to the left of 50 KPH is 
toggled on (indicated by the orange color). 

 
2. Verify the Feature Toggle Toolbar is still set to Features.xin > Linear > HA Ramp. 
3. Select the Spiral Curve Spiral command. 
4. At the top of the dialog, toggle on Loop.  Note the Radius and Transition fields are 

populated with our Design Standard. 
5. At the bottom of the command dialog, toggle on Use Feature and set the Feature 

Definition to Active Feature. (It should be set from the previous command.) 
6. Now we’ll carefully follow the heads-up prompts attached to the cursor to draw our 

loop using the illustration as a selection guide: 

 
 

HEADS-UP PROMPT USER ACTION 

Locate First Element Select the east-west element.  

Locate Second Element Select the edge of the cross road.  

Select Construction 
Sector / Radius 

Move the cursor to see the southwest loop. The Radius is displayed.  However, we 
don’t have to use Radius as our input.  In the heads-up prompt, type d55 <enter>.  
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The Radius field in the dialog changes to the degree input and the loop changes 
dynamically.  Data point to accept. 

Trim / Extend Option Set to Back and data point to accept the construction.  

 
Completed Southwest Loop 

DEVELOPING THE SOUTHEAST LOOP 
For this alignment, we will once again use the Design Standards.  However, we will combine 
it with the 3 Center Curve command.  In this case, the command does not have the option 
for offsets, so we need to select the actual elements.  

 Optional Exercise:  Develop the Southeast Loop 

Objective: Construct the inside ramp centerline.   

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
3 Center Curve 

 

1. Use the 50 KPH\One Step below Desirable Minimum at 50 KPH standard from the 
Design Standard Toolbar.  Ensure the icon to the left of 50 KPH is toggled on 
(indicated by the orange color). 

 
2. Verify the Feature Toggle Toolbar is still set to Features.xin > Linear > HA Ramp. 
3. Select the 3 Center Curve command. 
4. At the top of the dialog, toggle on Loop.  Note the Radius and Transition fields are 

populated with our Design Standard. 
5. At the bottom of the command dialog, toggle on Use Feature and set the Feature 

Definition to Active Feature. 
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6. Now we’ll carefully follow the heads-up prompts attached to the cursor to draw our 
loop using the illustration as a selection guide: 

 
 

HEADS-UP PROMPT USER ACTION 

Locate First Element Select the east-west element.  

Locate Second Element Select the edge of the cross road.  

Select Construction Sector / 
Radius 

Move the cursor to see the southeast loop.  Use the Radius and <>.   

Select Construction Sector / Back 
and Ahead Transition Lengths 

Set the Back and Ahead Transition Lengths to 100.   

Trim / Extend Option Set to Back and data point to accept the construction.  

 

 
Completed Southeast Loop 
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CHAPTER SUMMARY 
In this chapter, we have utilized the Complex Arcs tool in conjunction with Design Standards 
to develop new loop alignments.  We used a new Feature Definitions to distinguish the loop 
alignments from the mainline.  We also reviewed the element manipulator and edit fields. 

 
Four completed loops 
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Chapter 4: Developing Ramps 
OVERVIEW 

Now that we have completed the loops, we can begin work on the ramps.  There are a 
variety of ways to develop the ramps, and numerous different ways (and tools) to 
accomplish it.   Keep in mind that we are demonstrating the tool usage,  as we can’t design 
the entire interchange in one short workshop.    

 

CONSTRUCT THE NORTHEAST RAMP 

 Construct the Northeast Ramp 

Objective: Construct the inside ramp centerline.   

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Arc Between Elements 

  Complex By Elements 

  
Single Offset Partial Element  

Procedure: 

1. Continue in Start_ch4.dgn.   
2. Use the 50 KPH standard from the Design Standard Toolbar.  Ensure the icon to the 

left of 50 KPH is toggled on (indicated by the orange color). 

 
3. Set the Feature Toggle Toolbar to No Feature.  We’ll build the elements and when 

we connect them, we’ll assign a feature definition at that time.    
4. Select the Arc Between Elements command. 
5. At the top of the dialog, toggle off Loop.  Note the Radius and Transition fields are 

populated with our Design Standard. 
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6. Now let’s enter some of our taper information into the dialog.   

FIELD VALUE 

Back Taper  section  

     Method Ratio-Offset 

     Offset 5 

     Ratio  1:15 

Back Transition section  

     Geometry Spiral 

     Method Length 

     Length 70.254   (set by standard) 

Ahead Taper section  

     Method None 

Ahead Transition section  

     Geometry None 

7. Now we’ll carefully follow the heads-up prompts attached to the cursor. 

HEADS-UP PROMPT USER ACTION 

Locate First Element Select the mainline element.  

Enter Start Offset 17.9m.  Data point to accept.  

Locate Second Element Select the loop alignment. 

Offset 17.6m (existing edge of exit lane, appears outside the loop).  Data point to accept.  

Select Construction 
Sector / Radius 

Move the cursor to see the ramp. The Radius is displayed from our standard.  Data 
point to accept. 

  

Now we’ll repeat the process to get the section of the alignment between the cross highway and the ramp.  

8. Select the Arc Between Elements command again. 
9. We need to change a few entries in the dialog.   

FIELD VALUE 

Back Taper  section  

     Method Ratio-Offset 

     Offset 5 

     Ratio  1:50 
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10. Now we’ll carefully follow the heads-up prompts attached to the cursor. 

HEADS-UP PROMPT USER ACTION 

Locate First Element Select the cross highway element.  

Enter Start Offset 17.6m.  Data point to accept.  

Locate Second Element Select the loop alignment. 

Offset Also 17.6m.  Data point to accept.  

Select Construction 
Sector / Radius 

Move the cursor to see the ramp. The Radius is displayed from our standard.  Data 
point to accept. 

 

 
Two segments of the northeast ramp 

11. Select the Single Offset Partial Element command. 
12. Now we’ll carefully follow the heads-up prompts attached to the cursor, based on 

the illustration below. 

 
 

HEADS-UP PROMPT USER ACTION 

Locate Element Select the northeast loop centerline.  

Start Parameters Offset Snap to the end of the working element we just drew that is connected to the cross 
highway.  

End Distance Snap to the end of the working element we created connecting to the mainline 
alignment.  
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13. Select the Complex By Elements command to create the alignment (from the cross 
highway  end to the mainline alignment.  

14. In the dialog, set the Method to Automatic.  Set the Maximum Gap to 0.03.  We 
also want to toggle on Use Feature and set our Feature Definition to HA Ramp and 
use the default Name Prefix. 

15. Follow the heads-up prompts, using the green working elements we just created. 

HEADS-UP PROMPT USER ACTION 

Locate Element Select the northeast ramp beginning near the cross highway.  Watch that the arrow 
is pointing in the correct direction.  Data point to accept. 

 

Accept Complex Of the entire ramp has changed color, data point to accept.  

 

 
Completed Northeast quadrant – loop and ramp 

CREATE THE NORTHWEST RAMP 
In order to fit the ramp in between the loop and a nearby frontage road, we are 
going to develop the alignment using the curve points of intersection (P.I.) along 
with our Design Standards.   Then we can dynamically modify to fit our design.   

 Create the Northwest Ramp 

In this exercise, we’ll use 5 points to create our alignment.  Since we are using Design 
Standards, the curve and transition data will be populated by default.  
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Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Complex by PI 

 
Procedure: 

1. Continue in start_ch4.dgn. 
2. Set the Feature Toggle ToolBar to HA Ramp. 
3. Set the Design Standard to 50 kph\Two Steps below Desirable Minimum at 50 kph. 
4. Select the Complex by PI command. 
5. Follow the heads-up prompts, using the illustration as guidance:  

 
Five points used as P.I. for northwest ramp. 

HEADS-UP 
PROMPT 

USER ACTION 

Enter First P.I.  Place the point on the edge of the existing cross highway.  Note we could also have built a 
taper first and used that as our starting point, as the P.I. tool does not have offset options.   

Enter Next P.I. / 
Radius 

Place the point, still on the edge of the existing cross highway. The Radius should be set 
to 90m, based on our Design Standard. 

Enter Next P.I. / 
Radius 

Place the third data point.  

Enter Next P.I. / 
Radius 

Place the fourth and fifth points on the edge of the mainline pavement (or taper if you to pl 
aced one).   Replace when all five points have been placed (to complete the command.) 

6. If you don’t like the placement, select the element, and dynamically adjust or 
change the edit fields.  

CREATE THE SOUTHWEST RAMP 
We are going to use a variety of tools for this area.  First, we need to realign the 
southern access so it is perpendicular to the mainline.  Then we’ll modify the 
roadway from 2 way to one way to provide an entrance to the cross highway.  This 
will set us up to realign the access road on the north side of mainline.  
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 Optional Exercise: Create the Southwest Ramp 

Objective: First, we’re going to realign the road to the west of the southwest loop.  
We’ll use this for both the southwest loop, and as a new intersection for the 
access road to the north.  We want to be sure it’s perpendicular to the 
mainline alignment. We’ll use the Line to Element tool, but we could also 
use the Line by Points in conjunction with a Perpendicular snap. 

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Line To Element 

  
Reverse Curve by Angle 

Procedure: 

1. Continue in the file start_ch4.dgn. 
2. We won’t use any feature definitions for the first steps, so set the Feature ToolBar 

to No Feature.   Use the MicroStation Working Elements level. 
3. Select the Line To Element command. 
4. Follow the heads-up prompts, using the illustration as guidance:  

 

HEADS-UP 
PROMPT 

USER ACTION 

End Point  We’ll place a point on the north side of mainline, as we will use the alignment for both 
the southwest ramp and the north frontage road.  When dropping a perpendicular line, 
we want to be inside the project limits, as indicated by the mainline alignment.   

Locate Element Select the mainline alignment. 

Offset Use 175m so it intersects the existing alignment and we have some line length to work 
with later.   Data point to accept. 

Skew Use 90.  (No need to type the minutes and seconds.)  Data point to accept. 

Start Distance 0 

Trim None.  

5. Select the Reverse Curve by Angle command.   
6. Set the Feature Definition to HA Ramp. 
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7. Set the Design Standard to 50 kph/Two Steps below Desirable Minimum and toggle 
on the standard. 

8. Follow the heads-up prompts, using the illustration as guidance:  

 
 

HEADS-UP PROMPT USER ACTION 

Locate Element Select the working line we just created 

Enter Start Point Snap to the bottom of the working line.  

Locate Second Element Select the outside edge of pavement on the cross highway. 

Define Radius Both the Back and Ahead Radius should be set to 90, based on our Design 
Standard.  If not set them, then data point to accept.  

Start Point Move the cursor near the original start point until the reverse curves fit, without 
overlapping the southwest loop.  Moving the cursor to the right – left changes the 
shape of the curves.  Data point when you’re satisfied with the layout.  

Trim / Extend Back 

9. We could use the Complex By Elements tool to connect the working element with 
the reverse curves.  However, we want to use that same element on the north side, 
so we’ll wait to finish up connecting the loop alignment at that time.  

CREATE THE SOUTHEAST RAMP 
We are going to use the Taper Curve Taper command for this ramp.  However, the 
command does not support offsets, so we have offset the southeast loop for the 
minimum distance between the two roadways and the mainline to account for the 
exit ramp.   The Offset Partial Element tool was used to create these working 
elements.  

 Optional Exercise: Create the Southeast Ramp 

Objective:  

Create the two segments of the southeast ramp that will be combined with an offset 
loop segment to create the entire ramp alignment. 
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Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Taper Curve Taper 

Procedure: 

1. Continue in the file start_ch4.dgn. 
2. We won’t use any feature definitions, so set the Feature ToolBar to No Feature.   

Use the MicroStation Working Elements level. 
3. Set the Design Speed to 50 kph.  
4. Select the Taper Curve Taper command. 
5. In the dialog, set the following: 

FIELD VALUE 

Ahead Taper Method Ratio-offset 

 Offset 5  (width of the ramp) 

Ratio 1:15 (to fit within our project limits) 

 
6. Follow the heads-up prompts. 

HEADS-UP PROMPT USER ACTION 

Locate First Element  Select the working element offset from the loop. 

Locate Second Element Select the working element offset from the mainline alignment. 

Select Construction Sector / 
Radius  

The Radius should  be set to 255 kph from our Design Standard.  Do NOT 
data point yet!  View the curve and ensure the taper is within project limits, 
then data point to accept.  

Trim / Extend Both.   

 

 
Completed Segment of Southeast ramp. 

Now we’ll use the same command and process to add the segment from the cross highway 
to the loop.  

7. As we have limited project limits on cross highway, set the Design Speed to 50 kph\ 
Two Steps below Desirable Minimum at 50 kph.  

8. Select the Taper Curve Taper command. 
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9. In the dialog, set the following: 

FIELD VALUE 

Back Taper Method Ratio-offset 

 Offset 5  (width of the ramp) 

Ratio 1:15 

 
10. Follow the heads-up prompts. 

HEADS-UP PROMPT USER ACTION 

Locate First Element  Select the working element offset from cross highway 

Locate Second Element Select the working element offset from the loop. 

Select Construction Sector / 
Radius  

The Radius should  be set to 90m from our Design Standard.  Do NOT data 
point yet!  View the curve and ensure the taper is within project limits, then 
data point to accept.  

Trim / Extend Both.   
 

 
Completed Segments of Southeast ramp. 

11. We could use the Complex By Elements command to connect the working elements 
with the taper curve taper elements.  
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Chapter 5: Final Clean-up 
OVERVIEW 

Now that we have to mainline, loops, and ramp alignments complete, there’s still lots of 
work to be done.  We can add more edges of pavement and shoulders with the Offset 
commands.  We can add tapers and gore areas to complete the plan drawings.  Many of 
these are done using the same tools we have already been working with in previous 
chapters. 

Before we tackle those tasks, we have a few access roads to redesign, and a few more tools 
to try using!   

 Exercise:  Readjust Northeastern Side Road 

Objective: 

We’ll start by using a separate turnout lane (3.6m).  This has already been drawn using the 
Single Offset Partial command.  Next we’ll establish the centerline for the existing roadway.  
Then we’ll add the fillets and tapers.    

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Single Offset Partial Element 

  Line Between Points 

  
Line To Element 

  
Simple Arc 

   
Variable Offset Taper 

Procedure: 

1. Open the file start_ch5.dgn. 

2. We won’t use any feature definitions for these first few steps, so set the 
Feature ToolBar to No Feature.  
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3. Select the Line Between Points command.  We’re going to use it twice to 
establish two points on the existing centerline.   

HEADS-
UP 
PROMPT 

USER ACTION 

Select Start 
Point  

Set the MicroStation Snap to Perpendicular.  Select the left edge of existing roadway.   
Since we selected perpendicular moving the cursor dynamically displays the 
perpendicular element.    
 

 
Start 
Parameters 
Offset 

Snap to the end of the working element we just drew that is connected to the cross 
highway.  

End 
Distance 

Snap to the end of the working element we created connecting to the mainline 
alignment.  

4. Select the element you just drew, which displays the edit manipulators.  
One edit field is the length of the line (which is also the width of the 
roadway since we used the perpendicular snap during placement.  Change 
the edit field so it is half the value (be sure to enter on the keyboard).  The 
line is now half as long so its endpoint is the center of the existing roadway.  
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5. Repeat the process again so we have two centerline points of reference. 
 

 
 

6. Select the Line To Element command.  
7. Set the Feature Definition for HA Roadway. 
8. Follow the heads-up prompts.  

 

HEADS-UP PROMPT USER ACTION 

Enter End Point  Snap to the green working element (labeled point 1) at the north end of the roadway .  

Locate Element Select the mainline alignment.  

Offset 0 

Skew Snap to the other working element (labeled point 2) we created.  

Start Distance 0, then data point to accept. 

Trim None. 
 

9. Select the Simple Arc command.  
10. Set the Feature Definition for EP Prop. 
11. Follow the heads-up prompts.  

 

HEADS-UP PROMPT USER ACTION 

Locate First Element  Select the existing edge of pavement. 

Locate Second Element Select the mainline edge of pavement. 

Enter Through Point / 
Radius 

25 

Trim Set to Both, as it will not trim the existing pavement (as it’s in a reference file). 



Overview 

 

X03- Using the New Geometry Tools in Production   Copyright © 2011 Bentley Systems, Inc.  
 52 11/28/2011 

12. Repeat for other radius. 

 
Completed side road. 

13. To add the tape to the turnout, select the Variable Offset Taper command.  
14. Set the Feature Definition for EP Prop. 
15. Follow the heads-up prompts.  

 
 

HEADS-UP PROMPT USER ACTION 

Locate Element  Select the mainline alignment. 

Start Offset Snap to the end of the side road radius. 

End Offset Snap to the edge of the mainline at the end of the project. 

16. Final clean-up, striping, etc. can be done at the user’s discretion. 
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REROUTE THE NORTHWEST ACCESS / FRONTAGE ROAD 
The expanded interchange, and in particular the northwest ramp, have cut off access from 
the northwest community.  A safety issue is the number of accesses onto the main highway, 
so it is desirable to minimize the number, and make them normal to the mainline highway.  
Therefore, the original northwest access will be closed, and the road re-routed to the new 
intersection slightly to the west of the old location.  Finally, it’s combined into an 
intersection with the southwest ramp.  

 Exercise:  Rework the Northwest Access / Frontage Road 

Objective:  Create the two segments of the southeast ramp that will be combined with 
an offset loop segment to create the entire ramp alignment. 

 

Geometry Tools Used:   

CIVIL GEOMETRY PANEL ICON TOOL 

  
Reverse Transition 

 

Procedure: 

1. Continue in the file start_ch5.dgn. 
2. Set the Feature Toolbar to HA Roadway. 
3. Toggle off the Design Speed Standard.  
4. Select the Reverse Transition command. 
5. In the dialog, set the Ahead Offset and Back Offset to 0.  Set the Ahead Radius and 

Back Radius to 50.  Lock all four values, by toggling on the box to the left of each 
field.  

6. Follow the heads-up prompts, using the illustration below for guidance. 

 
 

 



Reroute the Northwest Access / Frontage Road 

 

X03- Using the New Geometry Tools in Production   Copyright © 2011 Bentley Systems, Inc.  
 54 11/28/2011 

HEADS-UP PROMPT USER ACTION 

Locate First Element  Select the existing inplace frontage road. 

Offset 0 

Locate Second Element Select the mainline edge of pavement. 

Offset 0; then move the cursor until you have a reasonable set of reverse curves and do no 
encroach upon the mainline pavement.  Note you will have the opportunity in the 
next step to slide it upwards on the inplace frontage road alignment. 

Define Length Dynamically set, but it try around 90m. 

Enter Start Point This slides the curves along the inplace frontage road.  Data point as shown.  

Trim / Extend Both  
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Appendix A:  Feature Definitions  
OVERVIEW OF FEATURE DEFINITIONS 

In this manual we used a prepared DGNLIB file which contained our feature definitions.  This 
lesson shows how to create the DGNLIB using your preexisting DDB, XIN or PSS file.  This 
example uses a GEOPAK D&C Manager (ddb) file for feature definitions but user can 
alternatively utilize an InRoads (XIN) file or an MXROAD (PSS) file. 

 Exercise: Create a DGNLIB that contains our feature definitions 

So that we can easily control symbology, annotation and quantities, we will create a feature 
definition table.  The Civil Geometry tools make use of your existing DDB, XIN or PSS feature 
definition table so that you do not have to recreate everything from scratch. 

1. Open XINfeatures.DGNLIB file.  
2. Use the Design Explorer and load the desired XIN file. 

Note: This is the only time we will use any GEOPAK or InRoads commands in this 
exercise. 

3. Now, open the Items browser > Content Management panel and note that no 
feature definitions exist in this file. 
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4. Right click on the Content Management Model line and choose Import Feature Style  

 
The features are now populated in the file. 

 
5. Close Microstation and copy this file (Features.dgnlib) to a location defined by the 

configuration variable MS_DGNLIBLIST. 
6. The Content Management tools now provide some added functionality which is not 

necessarily available when using the features in their native applications.  These are 
the ability to automatically persist the elements back into the external coordinate 
geometry database and to auto annotate the elements as they are created. 

7. Open any dgn file and select the feature named HA Roadway. 

 
8. Now look in the Details panel of the Items Browser. 

 
9. For each feature definition you will have these settings: 
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• Native Style – This is the name of the style in the PSS, XIN, DDB file which is 
represented by this Content Management Feature definition. 

• Auto Annotate – True or False.  If true then as soon as an element is created with 
this feature then it will be annotated. 

Note: Users must verify that the DGN model scale matches a scale defined in the XIN 
file. 

• Name Prefix – As elements are created they are given a name.  This is the default 
prefix presented to user.   

Note: Users must be careful to observe any naming restrictions in MX, InRoads or 
GEOPAK. 

• Auto persist – True or False. If true, then the elements are immediately created in 
the MX, InRoads or GEOPAK coordinate geometry database as soon as the civil 
elements are created in graphics. This eases the workflow when you need to 
continue the vertical design in one of these applications.    

Note: By default, auto persist is set to True for Power InRoads users. 
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Appendix B:  Design Standards  
OVERVIEW OF DESIGN STANDARDS 

In this appendix, we will review the design standards appropriate to this project and will go 
through the process of creating a new design standard. 

 Exercise: Investigate the DGNLIB that contains our design standards 

Design Standards allow you to set up your organization’s desired standards to control 
alignment configurations based on design speed and other considerations.  For this release 
the standards are very much oriented towards alignments and control maximum/minimum 
radius and tangent lengths and also define required transition lengths.   

1. Open a blank DGNLIB (or one which contains other standards that you use)    
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1. Now, open the Items browser > Design Standards panel and note that the design 
standards which already exist. 

 
2. Select the standard in 4 Lane group labeled 8% Super-70MPH 
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3. Open the details panel to review the settings. 

 
4. The properties for each standard are: 

• Speed – this is the design speed for the standard.  This is for user information and 
also used in equations. 

• Default Radius – this is the radius used to populate commands when they start. 
(Note: Degree of curve input to the design standards settings are not supported at 
this time) 

• Minimum Radius – this is the minimum radius for the corresponding design speed.  
Utilizing values lower than this radius will cause a warning to be displayed. 

• Transition Type – can be by Table or Equation (Note: For this release, the transition 
length equation is a hard coded equation as found in the AASHTO Manual 2004.  
This is the same formula used in the United Kingdom (perhaps elsewhere) 

• Table – If transition type is table then this is used to populate the table. (See below) 
• Insure Tangency Arc – if True then the standard checks all arcs to insure against 

kinks. 
• Include Transitions to Arcs – If true then transitions are applied to arc commands. 
• Maximum Arc Length 
• Minimum Arc Length 
• Insure Tangency Tangent – If true then tangents are checked for kinks. 
• Include transitions – If true then line commands will have transitions added. 
• Maximum Tangent Length 
• Minimum Tangent Length 
• Maximum Deflection – Where two tangents join without a curve, what is the 

maximum angle between the lines. 

5. Transition Tables – This is a radius table which lists default and minimum transition 
lengths corresponding to each radius.  If the actual used radius is not specifically 
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found in the list then the transition length for the radius which is closest to but not 
longer than the specific radius is used. 

 
6. You can create a new standard by right click > New.  Or by copy/paste of an existing 

standard 

 
7. Once your standards file is complete, copy it to a location defined in 

MS_DGNLIBLIST and it will be available in all projects. 
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Appendix C:  Civil Geometry Settings  
OVERVIEW OF CIVIL GEOMETRY SETTINGS: 

In this appendix, we will review the settings which control the Civil Geometry operation.  
Civil Geometry utilizes settings from 2 different places; DGN settings and WorkSpace 
Preferences. 

 Exercise: Investigate the DGN Settings 

1. Angle formats used by Civil tools follow Angle Format Settings.  These are same 
settings used by the rest of MicroStation. 

 
2. Format: DD MM SS, DD.DDDD, DD MM, Gradians, Radians are all supported. 
3. Direction Mode: Bearing and all formats of Azimuth are supported. 

CIVIL FORMATTING  
When Civil Geometry is loaded then there is a new Civil Formatting panel of settings. 
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1. All the settings at top are related to settings required by the Roundabouts Entry 

Path Curvature Analysis tool. 

• First Turn Color, Second Turn Color, Third Turn Color – These are colors used when 
drawing the vehicle paths. 

• Measurement Method – Either Spline or Arc.  Type of element to create when using 
the Entry Path Curvature tool. 

• Entry and Exit Distance – Distance measured along the entry or exit approaches to 
begin/end the vehicle path. 

• Entry and Exit offset – horizontal offset held off the entry and exit flares for the 
vehicle path. 

• Offset from center island – horizontal offset held off the central island in the traffic 
circle. 

• Vehicle Width – width of vehicle path. 
• Max Approach Radius -  
• Side Friction Factor – used to compute actual speed thru the roundabout. 
• Design Speed Units – MPH or KPH. 
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2. Scroll the settings down to see the remainder of settings. 

 

• Coordinate Format: X,Y or N,E 
• Coordinate Precision: Number of decimal places shown on coordinates. 
• Ratio Settings Format: 1:D form or D:1 form. 
• Ratio Precision: Number of decimal places used on ratios. 
• Station Settings Format: No delimiter, 2 digits after delimiter, 3 digits after delimiter 
• Station Format Delimiter: Usually a plus sign 
• Station precision: number of decimal places on delimiter 
• Station Equation Type: By Name (InRoads compatible) or By Region (GEOPAK 

compatible) 
• Radius Settings Degree of Curve: By Chord or By Arc 
• Degree of Curve Length:  Length of chord or arc used to define a 1° curve. 
• Radius Toggle: the keystroke used to define degree of curve instead of radius in 

commands. 
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WORKING UNITS 
Working Units are used by Civil Geometry to determine units and the precision is used for 
distances. 
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WORKSPACE PREFERENCES 
When Civil Geometry is loaded there is also an additional panel added to WorkSpace > 
Preferences. 

 
1. Cursor Prompt Dialog – Settings to control the heads up prompt.  These are used for 

commands and Civil Accudraw. 

• Dialog Opacity – Set the opacity/transparency of the heads up prompt 
• Dialog Color – The color of the heads up prompt window. 
• Text Color – The text color used in the heads up prompt. 

2. Manipulator Settings 

• Manipulator size – the size of manipulators.  10 is default.  Smaller numbers 
translate to smaller manipulator size. 

• Normal Color – The default color of manipulators. 
• Selected in Property Pane – If use element information of a selected element then 

the manipulator corresponding to the property with focus is temporarily shown in 
this color. 

• Selected color – When you hover over or click on a manipulator it temporarily 
changes to this color. 

• Manipulator Font – The font used for text manipulators. 
• Transparency – The transparency applied to manipulators.  
• Use Shading – True uses a shaded pattern on the manipulators. 
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Appendix D: Use of the Property Pane 
(Element Information) 

OVERVIEW OF ELEMENT INFORMATION 
1. In this manual we have used the on screen prompts and on screen manipulators 

almost exclusively.  The user may also find Element Information Property pane to be 
a useful tools for making edits. 

2. Indeed for some of the more complex constructions the property panel contains 
some entries which are not available for editing anywhere else. 

3. Let’s use a Spiral-Curve-Spiral created with the Arc Between Elements command as 
an example of the sort of edits that are available in the Property Pane. 

4. Select a SCS curve and open Element Information. Now we can see some familiar 
and some new things.  The General and Geometry Tabs are the same information as 
would be expected for any selected element. 

5. For civil elements the Raw Data and 
Extended tabs are hidden to limit confusion. 

6. At the top, in the tree, we see that this is a 
Fillet. It is indeed a Microstation complex 
but instead of the generic “complex” , the 
label is replaced with “Fillet” 

7. Underneath, in the highlited portion of the 
tree then we see that the fillet consists of 
two spiral and an arc.  Selecting either of 
these branches of the tree (see below) 
would allow direct editing and additional 
information about these pieces of the 
construction. 

8. The branch of tree titles “depends on” can 
be expanded to show the two lines which 
were used as the tangents for this fillet.  
(see below) In so doing these lines can be 
edited in the property pane without going 
back out and selecting them. 

9. Geometry Points will list any points that are 
part of the civil construction.  In this case 
there is only a thru point and it exists of a 
simple DP.  But if this point had been 
constructed with a snap or Civil Accudraw 
input then the relevant information for the 
input from these sources would be reflected 
here. 
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10. Back Transition and Ahead Transition Tabs – allows editing of the spirals.  OR, you 
could change the spirals to arc transitions. 

11. Ahead taper and Back Taper tabs – allows editing of the tapers which are part of the 
construction.  There are none in this case but they could be added. 

12. Fillet rule – Allows editing of the main rule which for fillet includes the central 
radius, offset from the tangent elements and the trim options, all of which can be 
edited here. 
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1. By selecting one of the components of the construction in the tree then you can 
isolate the parameters for that particular piece of the construction.   

In this case, selecting the spiral shows some additional editable 
parameters and also notice that the Geometry Tab lists all the 

information you could ever wish to know about a spiral. 

1. Note that this spiral data is read-only and 
not exposed for plans production 
purposes at this time, except for 
copy/paste into forms and etc. 

2. And finally, in the image below, notice 
that by expanding the “depends on” 
branch of the tree then I can edit the lines 
which were used to construct the fillet in 
context with the rest of the construction. 

 

1.  
2.  
3.  
4.  
5.  
6.  
7.  
8.  
9.  
10.  
11.  
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Appendix E: Customizing Commands 
OVERVIEW OF CUSTOMIZING COMMANDS 

All the civil commands can be customized to allow you to define workflows which make your 
users more productive. 

Naturally, you can use the tools as delivered in the installation which is what we have done 
in this class.  But if you are so inclined then you can customize workflows into DGN Libraries 
for use by all your users across a range of projects.  

 Customizing the Arc Between Elements Command 

1. Select the Arc Between Elements command. 

 
2. This is probably the largest of all the Civil dialogs because it has so many options.  
3. For this exercise, let’s assume you never need spirals and you always use zero for 

the offsets. 
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4. Right click on the dialog and then click Customize. 
5. Enter zero for the offset values. 
6. On the far right, click the button and set the offset prompts as Hidden. 

 
7. Scroll down to the Taper settings, set them to none and also make them hidden. 

 
8. Once you have made the edits, then you can click SAVE to change how the tool is 

displayed by default or SAVE AS and you will be prompted for a DGNLIB file into 
which you can save the customization. 



Overview of Customizing Commands 

 

Copyright © 2011 Bentley Systems, Inc.  X03- Using the New Geometry Tools in Production 
11/28/2011 75 

9. Now you have a much simpler dialog showing only the fields which are relevant to 
your needs. 
 

 

Note: When using the Save As option, you need to have a DGNLIB file prepared in 
advance.   

You can then save multiple variations of multiple tools to create true workflows.  For 
example, you could create a task navigation group titled “Cul-De-Sac” and contained two 
customized tools: 

• Arc By Points locked at a 50 ft radius to build the bulb of the cul-de-sac. 
• The other might be a Fillet customized similar to above with a locked radius of 75 to 

build the shoulder radii. 
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Appendix F:  Features 
OVERVIEW OF FEATURES 

The new civil tools utilize the feature tables from the native products to control symbology 
and annotation.  The tools were developed with the express intent to allow users to 
continue to use their current feature tables with minimal modification so as to preserve 
your investment in these tables.  But, since the three product’s feature tables are quite 
different this leads to some small differences in the user experience depending on which 
type feature table is used. 

1. the feature table must be imported into the active DGN or into a configured DGNLIB 
as described in Appendix A. 

2. The InRoads feature table is an XIN file.  In order to use the XIN features properly, 
the user needs to have the same XIN loaded in InRoads as is defined in the Items 
Browser.   

3. In the InRoads explorer go to File > Open and choose the proper XIN file. 

  
 



Appearance of Features in the Items Browser 
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APPEARANCE OF FEATURES IN THE ITEMS BROWSER 
The InRoads XIN file is a flat database with no folders or directories.  Therefore it will appear 
the same in the Items Browser.  However, there will be a linear category and a point 
category when viewed in Items Browser.  This is because an XIN feature can define all sorts 
of settings in a single feature.  But, in the Civil tools, a feature can be either linear in nature 
or point in nature but not both.  So if a feature is found which defines both linear and point 
settings, the linear settings are linked to the Content Management linear category and a 
feature named xxx-PNT is created to hold the link to point settings. 
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