
What's New or Changed in Bentley InRoads 
Group V8i (SELECTseries 1) 

V08.11.07 Refresh 

New 

General 

� AutoCAD 2010 was added as a supported CAD platform.   

General - Applies to MicroStation only 

� Right clicking on a graphic that was displayed with an InRoads Group style populates the 
right click menu with Edit Style.   

File 

� Project Defaults> Access was added to enable project access control.  
� Text Import Wizard> Display and Annotate toggle.  For horizontal alignments and cogo 

points, obeys the Geometry> View Geometry> Options settings.  
� Import> Survey Data.  The ability to import CAiCE *.kcm and *.kcp files was added.  
� Translators> DC Report was added so that information from multiple cross sections could be 

appended within the same *.dc file.  
� Translators> Export Topcon TN3 was added.  
� Translators> P-10 - P-40 Translator was added.  

   
Surface 

� Update 3D\Plan Surface Display is more dynamic now.  Turning on a toggle or selecting a 
feature automatically displays the corresponding graphics.  Turning off a toggle or 
deselecting a feature automatically turns off the corresponding graphics.  

Geometry 

� Horizontal Element> Add Fixed Horizontal Element was enhanced.  
� Horizontal and Vertical Elements> Check Integrity.  The Move Back and Move Forward 

buttons were implemented again.  
� Horizontal Regression> Network Solution was added.  

   
Drainage 

� Drainage> Layout> Inlets by Spread places network inlets along a roadway at a spacing 
determined by the allowable spread into the roadway.  

Survey 

� Add Mining Observations was added.  



� Network> Import from ASCII.  The ability to import Star*Net files was incorporated.  

Evaluation 

� Create Cross Sections, Annotate Cross Section, Update Cross Section, End Area Volumes, 
and Mass Haul Diagram were combined into a single Cross Sections command.  

Modeler 

� Create Template> Test Point Controls allows the user to test point controls without having to 
delete any controls first.  

� Create Template> Active Template.  The ability to select multiple points and edit was added.  
� Roadway Designer> Tools> Template Library displays the Create Template dialog directly 

from the Roadway Designer.  
� Roadway Designer.  The ability to show top surface features in the plan view was added.  
� Roadway Designer> Superelevation> Create Superelevation Wizard> Add Superelevation 

Points.  The ability to select from all backbone points was added.  
� Roadway Designer.  The ability to add temporary dimension lines was added.  
� Roadway Designer> Superelevation> Create Single Control Line> Table was added to allow 

the user to enter superelevation information in a grid format.  
� Roadway Designer> Corridor> Create Surface.  When creating a single corridor surface, the 

corridor name is no longer appended to the surface features.  
� Roadway Designer> Overlay Tools.  A maximum limit was added to the minimum milling.  

   
Drafting Tools 

� Plan & Profile Generator> Profile Controls tab.  The ability to annotate the Super Control 
Lines and Existing was added based on the settings in Annotate Profile.  

� Plan & Profile Generator> Symbols and Details tab.  The ability to specify the scale, location, 
and level onto which to place the ProjectWise Title Block was added.  

Tools 

� View XML Reports > LandXML was added to validate data.  
� Variable Manager> Command Behavior> File - Enable History Logging was added for 

logging file modifications for *.alg, *.dtm, *.sdb, *.itl, and *.ird files.  
� Run Macro> AlignmentFromASCII.dll was added to replace classic horizontal and vertical 

alignment import from the Text Import Wizard. 

Fixes  

General 

� Alt+Tab from MicroStation to another Windows application and back was causing the focus 
to be lost from MicroStation so that no menus, tasks, etc could be selected.  

� DGNLIBs delivered with the product were causing various levels to be created in all new 
DGN files.  

� InRoads Group would not load when running the msgeo workspace on a 64 bit machine.  

File 

� Import> Survey Data> Trimble DC now supports the multiple prism constant (77NM).  



Surface  

� View Surface> Two Point Slope was not stopping the graphic group on MicroStation 
graphics placed after the last two point slope was placed.  Therefore, if the last two point 
slope was deleted, the MicroStation graphics placed after it would be deleted.  

Geometry 

� Horizontal Curve Set> Add Horizontal PI was recomputing the start station, with the original 
start station.  This was incorrect, if the user was adding to the start of the alignment.  The 
software should have been back computing the new start station from the original start 
station.  

� Utilities> Multicenter Curve could not have a smaller radius in Radius 1  
   
Drainage 

� Time of Concentration was using old equations for the SCS method.  
� Edit\Review> Pipe> Storm Flow> 'Sum of Upstream Areas'.  Areas from upstream channels 

was not included.  

Survey 

� Create Legend was causing AutoCAD to error out when Dynamic Input was toggled on.  
� Fieldbook Data.  The XY, Z, and XYZ buttons were producing incorrect values.  

Evaluation 

� Cross Section> Cross Sections> Layout> Sheet Generator.  When generating a set of cross 
section sheets in separate models, cells were all displaying only in the last model generated.  

� Profiles> Create Profile> Source> Network> Existing. Channels were being placed in the 
incorrect position.  

Modeler 

� Roadway Designer> Cross Section View.  Elevations above 8000 feet would not display.    

Tools 

� Drainage> Queries> Reports.  Receiving 'There is no format for the selected type' error 
message when running a report with a particular workflow.  

  

   

V08.11.07 

New 

General - Applies to MicroStation only 

� Addition of InRoads Group functionality in the user interface of MicroStation (see user 
interface below). 



� MicroStation > File > Item Browser and ECX attributes were added. 
� Civil Geometry - new and more simple geometry tools. 
� Data Acquisition - new tool to compile diverse data. 
� Bentley Map was added to the InRoads Suite, Bentley Rail Track Suite, InRoads, and Bentley 

Rail Track products. 

User Interface - Applies to MicroStation only 

� InRoads Group products now have a DGN library installed to the <InRoads Installation 
Directory>\data\dgnlib folder called InRoads_Task_Menus.dgnlib for Task and Context 
Menus. 

� InRoads Group products now have MicroStation Task menus for common civil engineering 
workflows. 

� InRoads Group products now have MicroStation right-click context menus for common 
InRoads Group commands (e.g. tracking, styles, and options). 

� The new Applications menu in the MicroStation menu for the InRoads Group products has 
options to activate products and display product menus. 

� InRoads Group now provides a new command to show or hide the InRoads Explorer. 
� MicroStation > File > Item Browser will display information about graphic elements that 

have ECX attributes written by the InRoads Group. 
� InRoads Group toolbars are also accessible under MicroStation > Tools > Tool Boxes. 

File 

� File> Open> GEOPAK Surfaces (*.tin) was added to open GEOPAK tin files without having 
to translate.  

� File > Project Options was moved and renamed from Tools > Options.  
� File > Import > Surface was enhanced to import a mesh element into a surface.  This option is 

only available in MicroStation.  
� File> Translators> LandXML Translator.  LandXML files are now Schema 1.2 compliant.  
� File > Translators > Export to Carlson TIN was added.  

Surface 

� Edit Surface > Delete Triangles By Filter was enhanced to automatically generate an exterior 
boundary.  

� Edit Surface > Change Triangle Edge.  This command allows you to select the common edge 
of a triangle pair and change the triangles so that the common edge runs along the other 
diagonal.  

� Utilities > Resolve Crossing Segments was enhanced with new functionality.  

Geometry 

� Geometry > Vertical Curve Set > Vertical Table Editor has been enhanced to solve for 
unknowns and use K values.  

� Geometry > Utilities > Metes and Bounds and Traverse Adjustments were added.  

Drainage 

� View > Annotate Structures.  If the shape is circular, only one (height or width) size attribute 
is annotated.  

� View > Annotate Structures.  Offsets now read the Left and Right Offset abbreviations from 
File > Project Options.  



� Layout > Pipe was enhanced to layout the pipe elevations based on the centerline of the pipe.  
� Edit\Review Utility was enhanced to edit the utility centerline similar to the Surface > Edit 

Surface > Edit Feature Point command.  

Modeler 

� Roadway Designer > Overlay Tools were added to aid in the design of overlay projects where 
you want to adjust the vertical alignment to minimize volumes of overlay and milling.  

� Roadway Designer > Tools > Approximate Component Quantities were added.  
� Variable formulas for constraints were added.  

   
 Site Modeler 

� The Site Modeler commands enable fast, dynamic development of site models and easy 
management of changes that occur on site projects. The commands capture design intent and 
provide immediate visual feedback. The software allows you to perform engineering 
modeling without merging or extracting graphics. Many traditionally cumbersome processes 
are reduced to one step: for example, you can dynamically move a building pad in a single 
drag and drop step—without measurement, clipping, merging, and placement steps.  These 
commands are only available when running MicroStation as the CAD Platform.  

  

   

V08.11.05 

New 

General Enhancements  

� Added MicroStation V8i (Version 08.11.05) to the list of supported CAD platforms including 
AutoCAD 2008 and AutoCAD 2009.  

� Added support for ProjectWise V8i (Version 08.11.05) when used with MicroStation V8i.  
� Memory allocation for surface features and triangles was greatly improved.  
� The Import LDD project command translates a Land Desktop project into a LandXML file 

that can be imported into the InRoads Group.  The executable can be accessed from the 
\bin\ldd folder of the product installation.  

� InRoads Group now takes advantage of the 3GB option.  
  

Civil Enhancements  

� Roundabouts was added to the InRoads Group install.  Activate the roundabout functionality 
by clicking a command such as the Civil Library Browser under MicroStation > Tasks > Civil 
> Roundabouts.  

� Civil AccuDraw is new functionality similar to MicroStation AccuDraw with added civil 
engineering functionality.  Access Civil AccuDraw through the MicroStation Tools menu.  

� Civil Global Positioning System adds civil engineering functionality to the MicroStation > 
Tools > Geographic > Global Positioning System (GPS) command.  

File 

� Import > Surface > From Graphics & Import > Surface Advanced performance was greatly 



improved.  
� Import > Survey Data > Trimble DC.  Codes B6, 69CC, 69TM, 90, 91, and 92 are now 

supported.  
� Import > Survey Data > Trimble DC.  The ability to specify the sequence of the 

Northing/Easting sequence was provided.  
� Import > LAS Data was added to Site and Site Suite.  
� Import > LAS Data was added when running AutoCAD.  
� Export > Surface.  The ability to export an InRoads Group surface to a GEOPAK Dat file was 

added to the Point Type dropdown of this command.  
� Translators > LandXML Translator.  When potential geometric integrity issues exist, alerts 

are now issued.  
� Translators > Upload Trimble.  An error message was added to the message center when 

applying the Upload Trimble command without having Trimble Link Engine installed.  
� Translators > SDMS Translator has been improved.  

Surface 

� View Surface > Annotate Feature > Points tab.  The ability to annotate at an interval relative 
to an alignment was added.  

� Design Surface > Drape Surface.  A 'Copy to Destination Surface' toggle was added to copy 
features into a destination surface with the elevations of that destination surface.  

� Edit Surface > Copy Portion of Surface.  The ability to clip features by a fence or selected 
shape was added.  

� Edit Surface > Merge Surfaces.  The Merge Selected Areas from Original toggle was added 
to merge the original surface features within selected shapes into the destination surface.  

� Edit Surface > Delete Triangles by Filter was added to delete triangles based on certain 
properties.  

� Edit Surface > Transform Surface.  Vertical scale now accepts a value of a negative one, 
specifically for bathymetry.  

� Feature > Feature Properties.  An Edit Style button was added.  
� Feature > Feature Properties.  The surface feature list now remains near its previous position 

when making edits to surface features.  Previously, the list would revert to the top feature in 
the list after an edit.  

Geometry 

� The following commands were converted to tree view format:  View Closed Areas, 
Stationing, Station Offset Annotation, Curve Set Annotation, Vertical Change in Plan, and 
Switch Height Plan.  

� View Geometry > Horizontal Annotation.  The PI was added to horizontal annotation tabling. 
� View Geometry > Horizontal Annotation.  The software now displays the radials from the PC 

to the CC and the other one from the PT to the CC.  This allows a single justification to work 
for both radials.  

� View Geometry > Horizontal Annotation > Styles tab.  Orient with Element was added to 
place the annotation relative to the alignment.  

� View Geometry > Horizontal Annotation > Styles tab.  The Display Alignment Points Similar 
to Cogo Points check box allows the user to use the each alignment points style rather than 
the styles defined in the Point group box.  This check box and Alignments Style Overrides 
Points Style are mutually exclusive.  If one is set the other will be unset.  

� View Geometry > Vertical Annotation.  The Override Points Symbology with Points Style 
checkbox allows the user to use an event points style to replace the Symbology defined under 
Event Point.  This change does not affect the event points text.  Also for this to work correctly 
the user must define a Profile Symbology for each style in the Style Manager.  

� View Geometry > Stationing > Cardinals leaf.  A checkbox was added to prevent the PI from 



being annotated at the POB and POE when no curves are defined.  
� View Geometry > Stationing > Regular Stations leaf.  The ability to annotate major, 

submajor, and minor text and ticks was added.  
� Horizontal Curve Set > Define Curve.  In prior versions of the software, compound curve 

type curve-sets (SCSCS) were only editable from the Define Curve command.  Now, the user 
can create a curve-set with the Define Curve command and then edit that geometry with any 
command within the Curve Set toolbar.  Commands include: 

� Horizontal Curve Set > Insert PI  
� Horizontal Curve Set > Move PI  
� Horizontal Curve Set > Delete PI  
� Horizontal Curve Set > Define Curve Set  
� Horizontal Element > Edit  
� Horizontal Element > Move  

� Curve Set > Table Editor.  Right click> Reporting was added.  
� Vertical Curve Set > Add, Insert, and Move VPI.  A line is now displayed along the 

horizontal alignment when Tools > Variable Manager > Tools - Simultaneous Tracking is 
toggled.  

� Vertical Curve Set > Events.  The ability to assign a style to a vertical event was added..  
� Horizontal Element > Edit Horizontal Element.  The Maintain Element Connectivity with 

Minimum Movement allows the user to change the geometry a line or a circular arc and have 
the adjacent elements also update.  The option utilizes the component technique of fix, float 
and free to re-compute the geometry.  

� Element > Check Integrity.  The columns are now configurable.  Also, an optional column for 
spiral constant was added.  

� Vertical Element > Add Floating Curve.  Point and Grade mode was added for parabolic 
vertical alignments.  

� Regression > Edit/Review Regression Points.  The Select button is now called Select Only. 
 This button will only select points for regression.  The user can still do <Ctrl> + Select to 
include points in the analysis.  The user can still <Shift> + Select to include points in a fence 
in the analysis.  Also, the Regress button is now called Select & Regress.  This button will 
allow the user to select the regression points and automatically perform the regression.  The 
software will stay in this heads-up mode to select and regress multiple elements, until the user 
rejects.  These changes apply to both the Edit / Review Horizontal Regression and Edit / 
Review Vertical Regression commands.  

� Regression > Edit/Review Regression Points.  The columns are now configurable.  
� Regression > View Regression Points and Evaluation > Profile > Annotate Profile > 

Horizontal and Vertical Slew leafs.  The ability to display the slew values in millimeters was 
added.  

� Regression points are now removed from the buffer when the corresponding cogo point is 
deleted.  

� Review Geometry Points.  The Duplicates button allows the user to create a hard-coded 
report of all cogo points whose northing and easting coordinates are the same.  The Similar 
button allows the user to create a hard-coded report of all cogo points whose names are 
similar.    

� Cogo Points > Edit/Review Extended Descriptions was added to assign long descriptions and 
files to a geometry point.  

� Traverse.  Informational prompts detailing the selected point name and other information 
were added when using the pick buttons.  

� Delete Geometry.  The ability to delete an alignment or turnout by selecting the graphics was 
added.  Hold down the Control key, select the Delete Geometry command, and then follow 
the prompts.  

� Utilities> Traverse Edit.  The ability to maintain angles was added.  
� Performance of the software when loading cells through MS_CELLLIST has been improved.  
� Utilities > Traverse Edit.  The Maintain Angles checkbox has been added.  



� Utilities > Transform Geometry.  If cogo points are transformed, then the alignment defined 
by those cogo points is now transformed with those points.  

� Utilities > Inverse Direction.  The Display and Annotate check box allows the user to display 
lines and annotation of the respective Inverse commands.  If checked on then the software 
will display and annotate in the design file and based upon the defined Style.  If checked off 
then software will not display and annotate graphics into the design file.  

� Utilities > Design Checks > General Roads tab has the option to use Single Classification or 
Multiple Classifications.  The later requires that the start and stop stations, classification, 
terrain and design speed be saved to a simple text file.  The classification file has been 
enhanced to include multiple alignments with varying classifications.  The processing of 
Multiple Classifications will execute all alignments and all classification ranges as defined in 
the Classification File.  

� Utilities > Design Checks > General Roads tab.  The software has also been modified to 
include information for all elements not just warnings.  

� Chain Points is a new command that chains a series of cogo points together to form a 
horizontal alignment in a geometry project and/or a feature in a surface.  

� Tools > Options > Geometry defines that transitions are defined by length or constant.  This 
has been removed on the following commands: 

� Horizontal Curve Set>Define Curve  
� Horizontal Elements>Add Fixed Curve  
� Horizontal Elements>Add Floating Curve  
� Horizontal Elements>Add Free Curve  

Rail - Pertains only to Bentley Rail Track and Bentley Rail Track Suite 

� Translators > Import EM-SAT was added to import data from a Plasser & Theurer survey 
machine.  

� View Geometry > Stationing.  The ability to display cant annotation at a user defined interval 
was added.  

� Superelevation > Cant Editor.  The columns are now configurable.  
� Geometric element freedoms are now maintained with the data for the life of the data.  The 

following commands are affected: 
� Geometry > Horizontal Regression > Multiple Horizontal Element Regression Analysis 
� Geometry > Vertical Regression > Multiple Vertical Element Regression Analysis  
� Geometry > Turnouts > Turnout Connection Editor  
� Geometry > Turnouts > Create Connection  

� Horizontal Regression > Multiple Horizontal Element Regression Analysis.  Editable Applied 
Cant fields were added for the Beginning and Ending Elements and an Applied Cant column 
was added in the Connecting Element list.  

� Horizontal Regression > Multiple Horizontal Element Regression Analysis.  If the Beginning 
Element is the first element in an alignment then the user will be able to edit a linears 
tangential direction or a circular arcs radius.  In a similar manner, if the Ending Element is the 
last element in an alignment then the user will be able to edit a linears tangential direction or 
a circular arcs radius.  

� Horizontal Regression > Edit/Review Horizontal Regression Points.  Quick Regression was 
added.  

� Transition spirals.  The cubic parabola spiral implementation has been enhanced for Czech 
Railways.  The primary difference is the Czech cubic parabola is defined by the length along 
the spirals tangent rather than the length along the centerline.    

� Transition spirals.  The cubic parabola spiral implementation has been enhanced for New 
South Wales, Australia.    

� Transition spirals.  The software has been enhanced to also include the America Railway 
Engineering and Maintenance Associations cubic spiral.  The AREMA transition is based 
upon degree of curvature defined as chord definition.  



� Turnouts.  Combined turnouts and the Switch & Crossing (S&C) style of turnouts into a 
single set of functionality.  Within the Create Turnouts and Create Connection commands, the 
classical style of turnouts now has all of the applicable options that S&C has.  

� Turnouts.  The software now attempts to re-establish orphaned turnouts.  
� Turnouts > Display Turnouts.  The ability to display the station at the beginning of a turnout 

was added.  
� Turnouts > Display Turnouts and Display Turnouts in Profile have been converted to grid 

views.  
� Turnouts > Create Connection was added.  
� Create Vertical through Turnouts.  The computations were simplified to always copy & 

transform elements to the non-controlling vertical.  
� Drafting > Network Rail Extensions was added to display turnouts using Network Rail 

methodology.  
� Light Rail Manufacturing > Annotate Rail Offsets has been enhanced.  
� Utilities > Design Checks > Dutch Rail tab was added.  

Bridge 

� Reports > Screed tab.  The ability to report on event points from the girder alignment was 
added.  

Drainage 

� View > Drainage As Solids display has been improved.  
� Layout > Pipe.  Locate buttons to pick elevations graphically were added for Invert In and 

Invert Out.  
� Edit/Review > Styles tab.  Read only fields were added to note the assigned style.  
� Edit/Review > Inlets.  Target buttons were added for slopes and inverts for pipes and 

elevations for inlets.  
� Edit/Review.  When scrolling through a network with the Edit Up and Edit Down buttons, the 

current ID, Upstream ID, and Downstream ID displays in the message center.  
� Network > Design.  Clear ALL existing design tables was added.  

Survey 

� View Survey Data > Write Survey Data to Graphics.  Tags written to graphics now make use 
of the DNT tag in the inciv_ftr tag set.  

� Survey graphics now honor the Surface > View Surface > Options > Scale setting when the 
variable 'Survey - Honor Vertical Scale' is set.  

� A new code, SPC (Single Point Arc), was added.  This code computes a curve using a 
through point when there is no PC or PT shot in the field.  

� Fieldbook > Add/Edit Station and Add/Edit Observation.  A pick button to select only the 
Northing and Easting and a pick button to select only the Elevation were added.  

� Survey Style Filter.  The ability to filter on Point Range was added.  
� Survey Data to Surface.  Points that are not part of a chain can now be placed as individual 

features in the surface.  See Tools > Style Manager > Edit Style > Survey Feature > Random 
Point Form Separate Features for more details.  

� Survey Data to Geometry.  Extended Description was added.  
� Survey Data to Geometry.  Multi-coded points that are in multiple chains can now be sent to 

the geometry project creating only one point for all chains and using said point in all chains.  

Evaluation 



� Profile > Annotate Profile.  The ability to annotate the template being applied along the 
alignment was added.  

� Profile > Annotate Feature in Profile.  The ability to annotate the northing and easting points 
of a feature was added.  

� Cross Section > Create Cross Section > Layout > Sheet Generator was added to place cross 
section sheets in separate models.  

� Cross Section > Place Cell/Block.  The ability to annotate cant was added to this command.  
� Cross Section > Update Cross Section > General leaf.  Display Feature and Structure Bands 

was added to prevent the display of bands when this command is run and the bands were 
previously not displayed.  

� Cross Section > Update Cross Section > Storm and Sanitary leaf.  The All or None buttons 
were replaced with right click options in the list view.  

� Volumes > Triangle Volume.  The surface description attribute is now written to the XML 
file.  

� Tunnel Surface > Flatten Surface Transformation.  Start and Stop Sections are now populated 
when the units are imperial.  

� Sight Visibility > Roadway Visibility.  The ability to produce an XML report instead of a 
TXT report was added.  

� Sight Visibility > Roadway Visibility > General leaf.  A pick button was added for the 
Horizontal Alignment.  

Modeler 

� Create Template > Active Template tab.  The Components folder was enhanced with new 
graphics depicting whether the item is a component or end condition.  Child components are 
displayed beneath parents.  

� Create Template > Active Template tab.  The Parametric Constraints and Alternate Surface 
folders were added.  Selecting an item highlights the corresponding points in the template 
view.  Right click on an item to Edit, Delete, or Rename.  

� Create Template > Active Template tab.  The points in the Points folder now display with the 
correct colors.  

� Create Template > Point Properties.  The ability to specify 'Active' for the Project to Surface 
constraint was added.  

� Create Template > Display Template now obeys the display rules and Display All 
Components check box.  

� Roadway Designer > Corridor > Corridor Management.  The ability to select None for the 
Vertical Alignment was added.  

� Roadway Designer > Corridor > Point Controls.  Points now highlight in the cross section 
view when scrolling through the point controls.  Graphics in plan, profile, and superelevation 
views will also highlight if applicable.  

� Roadway Designer > Corridor > Create Surface.  The ability to select existing surface names 
for the name of the surface to be created was added.  

� Roadway Designer > Tools > Parametric Constraints.  The ability to import and export 
parametric constraints was added.  

� Roadway Designer > Tools > Parametric Constraints.  If a parametric constraint is assigned 
that no longer exists, it is highlighted red.  

� Roadway Designer > Corridor > Create Surface.  When creating one surface from multiple 
corridors, the corridor name is now appended on the components like the features.  

� Roadway Designer.  When the active surface is changed, the corridor station is no longer set 
to the beginning station; it remains and the currently active station.  

� Roadway Designer.  Transition performance was improved.  
� Roadway Designer > Corridor > Point Controls.  If the point assigned to a point control no 

longer exists, it is highlighted red.  
� Roadway Designer > Superelevation > Create Superelevation Wizard.  An option was added 



to calculate the crown removed and reverse crown so there is a constant grade change for the 
outside EOP.  

� Roadway Designer > Superelevation.  The ability was added to modify non-linear curve 
lengths for individual superelevation points.  

� Roadway Designer > Superelevation > Rollover.  The ability to lock the high side at 0% and 
leave the low side unchanged has been added.  

� Roadway Designer > Corridor > Template Drops.  Transitions no longer reset when 
synchronizing templates.  

� Roadway Designer > Corridor > Template Drops.  The ability to enable or disable transitions 
within this dialog was added.  

� Roadway Designer > Corridor > Template Drops.  If stations are red because the 
corresponding alignment has been edited, the user can now select the station and click the 
Change button to make the template drop valid again.  

� Roadway Designer > Corridor > End Condition Exceptions.  The ability to add a description 
was added.  

� Roadway Designer.  Project to Surface constraint is now honored as Target Aliasing.    
� Roadway Designer.  The ability to right click in plan view to add or delete a transition was 

added.  
� Roadway Designer.  The ability to right click in plan view and set a corridor active was 

added.  
� Roadway Designer > Edit Transition > Edit Transition Midpoint.  A message was added to 

inform the user that constraints need to be removed from points that need to transition.  
� Express Modeler.  Station limits were added.  

Drafting Tools 

� Place Note.  The ability to specify different slope formats for different notes was added.  
� Place Plan Note and Place Alignment Intersection Note.  The ability to display vertical 

alignment elevations was added.  
� Place Coordinate Grid.  The user interface has been enhanced.  
� Update Note.  The ability to update notes that contain drainage structure information was 

added.  
� Update Alignment Intersection Note was added to update notes previously placed with the 

Place Alignment Intersection Note command.  
� Draw Slope Direction Pattern was added to annotate the slope direction pattern between two 

graphics.  

Tools 

� XML Reports > Stakeout.  The elevation of the vertical alignment at the station is now 
referenced.  

� XML Reports >  Stakeout > Horizontal Alignments leaf.  Station limits were added.  
� XML Reports.  The precision exported to XML was increased to seven digits.  
� View XML Reports > Data Collection.  TrimbleAlignmentDC.xsl and 

TrimbleStationOffsetDC.xsl were created so that multiple alignments could be sent to a 
single file.  

� View XML Reports > Evaluation.  When using End Area Volumes, 
VolumesWithReplacedAddedToNormaFill.xsl was added to report normal fill plus replaced 
material when unsuitable material is used.  

� View XML Reports > LegalDescription.  HorizontalAlignmentReviewStationOffset.xsl was 
added to report alignment station, baseline offset, offset, northing, and easting information in 
a single report.  

� View XML Reports > Turnouts.  TurnoutBranch.xsl was added to report on branch alignment 
name and speed.  



� View XML Reports > Survey.  LeastSquaresAdjusted.xsl was added to show 'Adjusted 
Bearings' and 'Horizontal Ground Distances'.  

� View XML Reports > Survey.  ErrorEllipse.xsl now reports on relative point pairs.  
� View XML Reports.  The user no longer has to log into ProjectWise when accessing this 

command if InRoads Group is integrated with ProjectWise.  
� Variable Manager.  A variable was added to remove the commas that separate attributes in 

the description when sending survey data to surface or geometry.  
� Locks > Cogo Audit Trail was added to record all coordinate geometry results to a single text 

file.  
� Options > Geometry tab.  Vertical Alignment Healing was added.  The software retains the 

northing and easting coordinates of all points of the vertical. As a vertical alignment is 
created the software attempts to compute the coordinates. When a vertical is edited again the 
software attempts to re-compute the coordinates of extents. If the software is unable to 
compute the coordinates it skips updating the coordinates. The software is not able to 
compute the coordinates when you create a vertical alignment that is beyond the horizontal 
alignments extents.  

� Drainage > Reports.  The ability to report on the station and offset of pipe, channel, and 
culvert entrance and exits was added.  

� Survey Options > General tab.  The Automatic Update of Surface toggle was added to 
automatically update the surface created by the Survey Data to Surface command after an edit 
to the Fieldbook.  

� Preference Manager.  Sub menu indicators were added.  

Explorer 

� Survey tab.  The ability to right click on a fieldbook and select Empty was added.  
� Geometry tab.  The Explorer's right click menu now includes Hilite functionality for 

horizontal alignments, vertical alignments and turnouts.  The highlight is removed by clicking 
the Selection Set command within MicroStation.  Note:  This is MicroStation functionality 
only.  

SDK 

� The SDK has been greatly enhanced.  
  

   

Fixes 

General Fixes  

� Additional issues were resolved when the machine's decimal separator is set to a comma.  
� Hovering over a graphic in MicroStation with InRoads loaded was causing a crash with a 

particular dataset.  
� In Cogo Classic, the transform command was not scaling points as noted.  
� In AutoCAD, some commands were writing graphics as 3D polylines when they should not 

be.  
� INI To XIN Translator.  StyleScale in the View Stationing preference was being set to a large 

number which caused the software to crash when the preference was loaded.  
� Approximately 250 defects from previous versions have been fixed.  

Civil Enhancements  



� Roundabouts.  The MicroStation DI key-in was not working properly.  
� Roundabouts.  Some of the MicroStation > Edit commands such as DDE Links, Insert Object, 

Update Links, and Links were missing.  
� Roundabouts.  MicroStation Fence > Clip > Delete was not working.  

File 

� Open > Geometry Project was crashing with an ALG that contained multiple superelevations 
saved in V8.5.  

� ProjectWise > File > Open.  If Document Name did not have an extension of FWD, the FWD 
would not open properly.  

� Save As > ICS was causing a crash with a particular FWD.  
� Project Defaults.  With ProjectWise Managed Workspaces, a variable with 'Variable type:' = 

'ProjectWise Folder' did not work.  
� Import > Surface > From Graphics was crashing with a particular dataset that had graphics 

with tags.  
� Import > Geometry > From Graphics > Horizontal and Vertical.  With 'Resolve Gaps and 

Nontangencies' on, all vertical PIs were being given an elevation of zero.  
� Import > Geometry > ICS.  Graphics were not displaying correctly when importing a 

particular ICS file.  
� Import > Survey Data > Trimble DC was not reading the 69AV line in the raw *.dc file of the 

Trimble Controller.  
� Import > Survey Data > Trimble DC.  An issue was resolved in which the units were 

changing from DMS to Degress.  
� Import > Survey Data.  If an attribute had more than 30 characters, it would not import.  
� Import > Survey Data.  When importing an ASC file with more than four digits for the point 

name, the point code was getting appended to the point name.  
� Import > Survey Data > SDMS.  The second PD (point description) and CM (comment) lines 

were not being imported.  
� Import > Survey Data > ODOT GSI.  ST start codes were not being created for any lines 

outside of templates.  
� Import > Survey Data > Projections.  When using the Text Import Wizard to create a TIW, 

the software was locking up when picking LL84 input coordinates.  
� Import > Survey Data > Text Import Wizard was importing data into the wrong point name 

for a particular dataset.  
� Translators > LandXML Translator.  Importing a vertical alignment that was exported with 

discontinuities was corrupting the vertical alignment.  

Surface 

� Design Surface > Drape Surface.  Random points would not drape unless the 'Drape Vertices 
Only' toggle was on.  

� Design Surface > Generate Longitudinal Feature was creating near zero length segments in a 
feature from a particular dataset.  

Geometry 

� View> Horizontal.  Display the horizontal alignment with a corresponding vertical alignment, 
create an XML report with the Tools> XML Reports> Geometry command, close the report, 
and then redisplay the horizontal alignment.  The linear elements were being raised to the 
elevations of the vertical alignment.  

� View Geometry > Horizontal.  With 'Alignment's Style Overrides Point's Style' toggled on, 
the point symbology was not displaying correctly in a particular dataset.  



� View Geometry > Vertical Annotation was recognizing a profile that is not in the active 
model.  

� Curve Set > Move PI dynamic graphics was slow when MS_CELL is pointing to a network 
drive.  

� Horizontal Curve Set > Move PI.  The horizontal alignment dynamic graphic was 
disappearing when moving the first PI in the alignment.  This was specific to a horizontal 
alignment with no curves defined.  The graphic would redisplay once the PI was placed.  

� Horizontal Curve Set > Define Curve.  When editing a radius of a single curve created by the 
Multicenter Curve command, an error message was being displayed that should not be 
displayed.    

� Vertical Curve Set > Vertical Design Calculator.  At a particular station and speed, the length 
of a curve was not being calculated correctly.  

� Vertical Curve Set > Add Vertical PI.  The PI was getting placed at an incorrect station when 
using the DG= key-in.  

� Horizontal Element > Add Free Curve.  Placing a curve that worked in previous versions was 
no longer working.  

� Review Vertical was running very slowly on a long vertical alignment with profiles created 
with the Plan & Profile Generator.  

� Rename Geometry was causing stationing and line annotation to disappear.  
� Utilities > Parallel Horizontal Alignment.  The MicroStation prompts were incorrect.  

Rail - Pertains only to Bentley Rail Track and Bentley Rail Track Suite 

� Turnouts > Create Turnout.  When using a German Turnout Library, a turnout placed in a 
clothoid was crossing itself.  

Drainage 

� View > Drainage As Solids was not properly handling utilities that were draped on a surface.  
� Structure > Move in Profile.  The manhole bottom was not moving down when moving a pipe 

down.  
� Structure > Move in Profile.  Annotation placed on a manhole or inlet with the Annotate 

Drainage Profile command and the bottoms of the manholes/inlets were not moving properly 
when using this command.  

� Network > Design.  The software was producing a C++ runtime error when designing a 
particular network.  

� Network > Design.  A 'Pipe Too Large...' message was being received for a pipe that is much 
smaller than the maximum pipe size noted in the structures.dat file.  

� Network > Design.  The software was crashing when running this command with a particular 
dataset.  

� Network > Design.  A crash was fixed in when attempting to bypass flow to a structure 
outside of the current network.  

� Network > Design.  The grate inlet capacity calculation was using the wrong Eo for 
composite/depressed sections.  

� Network > Design.  HGL was not computed correctly for a channel in a particular dataset.  
� Network > Design.  The software was applying the clogging percentage to the length 

dimension when it should have been applying it to the width of the grate inlet.  
� Flows > Compute Flow.  The software was not recognizing the change of the empirical 

constant to a user value.  

Survey 

� View Survey Data.  Temporary graphics were changing spacing when zooming in and out.  



� View Survey Data > Write Survey Data to Graphics.  In AutoCAD, the option for ByLayer 
color for the survey Plan Line Symbology was not creating the line with ByLayer color.  

� Survey Style Filter.  With Properties set to Numeric Code, the field was not allowing wild 
cards.  

� Network > Least Squares (2D).  A report could not be generated if there were over 3500 
observations in the network.  

� Fieldbook Data.  The software was storing attributes from a code after the point's code has 
been changed.  

� Survey Data to Geometry.  Replace was renaming the features instead of replacing them.  

Evaluation 

� Profile > Create Profile.  Profile sets were not being recognized when the profile was created 
with the Geometry > Vertical Curve Set > Define Vertical Curve dialog opened.  

� Profile > Create Profile.  Direction Right to Left was not honoring the Bottom Offset for 
Major Label.  

� Profile > Create Profile.  With a particular dataset, the software was crashing when trying to 
place a profile.  

� Profile > Create Profile.  The software was crashing when placing a drainage profile.  The 
software now displays a warning of the problem.  

� Profile > Annotate Profile.  When a spiral was split between two plan and profile sheets, the 
data lines were being drawn incorrectly.  

� Profile > Annotate Profile.  With Cardinals selected, the Rail Elevations were not being 
annotated.  

� Profile > Annotate Profile.  Leader lines were not displaying for the Horizontal Cardinal 
annotation.  

� Profile > Annotate Profile > Superelevation.  The software was crashing with a specific 
dataset.  

� Profile > Annotate Drainage Profile.  Order was not working correctly when 'Annotate All 
Inverts at Structures' was toggled on.  

� Profile > Alignments to Profile & Points to Profile.  The same alignment projected from two 
different geometry projects was projecting to different elevations.  

� Profile > Alignments to Profile was not projecting an alignment to the profile.  
� Cross Section > Create Cross Section > Layout > Sheet Range leaf.  Start to Stop Station was 

being annotated twice in a particular dataset.  
� Cross Section > Create Cross Section was showing additional points than accounted for in the 

triangles with a particular dataset.  
� Cross Section > Create Cross Section was not stacking custom cross sections correctly in a 

particular dataset.  
� Cross Section > Create Cross Section was not displaying crossing features when the direction 

was set to Top to Bottom.  
� Cross Section > Create Cross Section > Custom.  Save As XSC was not honoring the File > 

Project Defaults > ProjectWise Directory setting.  
� Cross Section > Create/Update Cross Section.  Two components would not display in a 

particular dataset.  
� Cross Section > Layout > Sheet Annotation.  Annotation is now placed on levels of the enter 

data fields.  
� Cross Section > Annotate Cross Section.  The currently selected surfaces on the General leaf 

and features on the Annotate leaf no longer become deselected when loading a preference.  
� Cross Section > Add Surface to Cross Section.  With the mode set to Graphics, a 'Status Not 

Changed' message was displaying when the status should have been changed on a particular 
dataset.  

� Cross Section > Update Cross Section > Storm and Sanitary leaf.  Sorting the ID column was 
not ordering numeric names correctly.  



� Cross Section > Update Cross Section.  A problem in which orphaned component were being 
produced has been resolved.  

� Cross Section > Cross Section Report was not yielding slope, slope length, or delta z 
information for selected features in a particular dataset.  

Modeler 

� Create Template > Add > End Condition.  When creating a new end condition with 'Do Not 
Construct' toggled on and 'Mirror' enabled, the mirrored side was created with 'Do Not 
Construct' toggled off.  

� Create Template.  When placing an end condition as a bench with a vertical constraint of 
zero, the component was not being drawn.  The code was modified to ignore the benching 
flag when the segment is flat.  

� Create Template.  The Project to Design constraint was stopping at the Do Not Construct 
segment.  

� Roadway Designer > File > Save.  A problem existed in which the IRD file was erased when 
attempting to save without having the corresponding horizontal alignment opened.  

� Use of a secondary alignment was causing point controls to not be honored.  
� Create Template.  End conditions with 'Do Not Construct' points were not solving correctly 

when using benching.  
� Create Template.  Invalid end condition components in a particular dataset was causing the 

software to crash.  The software was fixed to prevent the crash.  
� Create Template.  When entering a new name for the target surface of an end condition and 

then clicking Apply, the name was reverting to Active.  
� Roadway Designer > Corridor > Point Controls.  Adding a horizontal and vertical point 

control with no vertical defined was crashing the software.  
� Roadway Designer > Corridor > Template Drops.  The template drops were being misordered 

when changing the start station of a template drop to a smaller station than the previous 
template drop.  

� Roadway Designer > Corridor > Point Controls.  An issue was resolved in which the corridor 
name and loaded surfaces could not have the same name when point controls were used.  

� Roadway Designer > Corridor > Point Controls.  The software crashed when selecting this 
command after deleting horizontal and vertical alignments assigned to a point control.  

� Roadway Designer.  The Style constraint was not working when a Project to Surface 
constraint was being used.  

� Roadway Designer > Superelevation.  A unnecessary recursive error was being displayed 
when creating super control lines.  

� Roadway Designer > Superelevation.  Creating superelevation with an ASCII table, there was 
a problem calculating the placement of the superelevation transition relative to the PC/PT 
when the normal crown was a positive value (i.e. for a ramp).  

� Roadway Designer > Corridor > Display References.  An issue was resolved with a particular 
dataset in which it was taking a long time to display the dialog.  

� Roadway Designer.  Templates were not transitioning correctly for one shoulder segment 
with the end conditions of a particular dataset.  

� Roadway Designer > Tools > Parametric Constraints.  If none of the other template drops had 
the same constraint value entered, then the end condition override constraint value would not 
be available in the list of constraints.  

� Roadway Designer.  Templates were being placed at stations other than what was defined in a 
particular dataset.  

� Roadway Designer > Tools > Target Aliasing.  The target corridor was not displaying fully 
until Create Surface is run on that corridor.  

� Roadway Designer.  A particular dataset was not working properly when using Feature Name 
Overrides.  



Drafting Tools 

� Place Plan Note.  Station and Offset values were incorrect when a reference file with different 
working units was attached.  

� Place Plan Note.  The software was not referencing a resource file from MicroStation.  
� Place Plan Note.  Absolute angle was not being honored in a rotated view.  
� Place Cross Section Note.  Station format was being ignored for stations placed on drainage 

elements.  
� Place Cross Section Note.  The note was not being placed when identifying the sides or 

bottom of an inlet.  
� Plan & Profile Generator.  The last sheet was not being created when two sheets are stacked 

and the alignment ends on the first plan view of the last sheet.  
� Plan & Profile Generator.  Changing the profile preference was changing the active 

preference on the Profile Controls tab.  
� Plan & Profile Generator > Match Lines tab.  Profile match lines and text was not honoring 

profiles that were created from right to left.  
� Plan & Profile Generator.  Setting different levels for Clipping Boundary and Symbols & 

Details was placing the graphics on the same level.  
� Plan & Profile Generator was not replacing tags for 2D seed files.  
� Plan & Profile Generator.  The north arrow was getting displayed in the sheet when 

regenerating profile only sheets.  
� Plan & Profile Generator was producing the following error message:  'Required Field Has 

No Value' when creating new sheets into a folder with environment with required attributes.  

Tools 

� XML Reports > Station Base.  Specifying an offset was not specifying the correct results in 
the XML report.  

� View XML Reports.  Some feature elevations were not reporting when running the XML 
Reports > Station Base command.  

� View XML Reports > Evaluation.  EndAreaVolume.xsl and EndAreaVolumePageTotals.xsl 
were not showing the grand total for large XML files.  

� View XML Reports The names of the GDOTDuplicateCOGOPoints.xsl and 
GDOTGenerateCOGOPointNumbers.xsl style sheets were reversed.  

� Copy Preferences.  A crash was occurring in a particular dataset when copying preferences.  
� Named Symbology Manager.  Gaps in the names were preventing feature styles from being 

annotated.  
� Named Symbology Tools > Global Named Symbology Edit.  Text styles with more than 31 

characters in the name was causing MicroStation to abort.  
� Named Symbology Tools > Import Named Symbology from CSV crashed when the CSV was 

exported with Verbose Mode toggled on the Export Named Symbology to CSV command.  
� Style Manager > Edit Style > Survey Feature > Symbology > Plan Point Symbology.  No 

temporary graphics were obtained when using the 'circle' option within the symbol display 
area.  

� Variable Manager.  When using the 'Survey - Exclude Generated Points from the Cogo 
Buffer' variable, points removed from cogo buffer still existed within alignments created.  

� Survey Options > Symbology > Edit View.  None of the temporary objects were honoring the 
Text Scale Factor on the General tab of Survey Options.  

� Survey Options > General tab.  Graphics were not automatically updating when certain 
changes were made to the Survey Options dialog and the Automatic Refresh toggle was on.  

� Tracking > Tracking was displaying binary values with a particular dataset.  

Explorer 



� Drainage tab.  Newly created drainage structures were not appearing on this tab.  

SDK 

� The XS of a compound cubic parabola was not reporting the correct value.  It should have 
incorporated the entire transition rather than the portion occupied by the cubic parabola.  The 
following was added to the SDK to resolve this problem: 
 scadSDK_cogoCubicParabolasExtendedInfo.  
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