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Preface  
In this workshop, you will construct horizontal alignments utilizing the V8i SELECTseries 2 Horizontal 
Element tools. We have structured the contents of the exercises herein to allow your interaction with 
a broad range of available tools, however, we will not use every tool. Also, it is impossible to engineer 
a complete interchange in the time frame of this workshop, but we will use the tools in their real-life 
context, so you can see how to utilize them in your own engineering projects.  

This workshop is applicable for InRoads family of products. In this workshop, we will use Power 
InRoads V8i 08.11.07.566 

There are more exercises in this manual than we will have time to cover today. We will all complete 
the basic set of exercises, and for those veteran users in the group who complete them and still have 
time left in the exercise session, you are welcome to work on the optional exercises.  

In order for all participants to design the same layout and to stay on course and on time, we request 
that all participants utilize the files as listed in the workshop materials. At the beginning of each 
chapter, we will start with a fresh set of data. This ensures that everyone is using the same data.  

The workshop guide is yours to take with you. If you don’t finish all the exercises, or just want to 
work with the dataset upon return to your office, the datasets (both initial and completed files) are 
provided on the Conference DVD. Many workshops will also have videos of all exercises on the DVD.  

Note Prerequisite Knowledge Level: Participant should have a basic understanding of 
road design principles and be fluent in use of MicroStation and the native 
application (InRoads) or of the Power product.  
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Chapter 1: Fitting a Curve into an 
Existing Geometry 

CHAPTER OBJECTIVE: 
In this scenario, there has been an error in construction which will be corrected by laying out new 
geometry, holding portions of the alignment constant while changing a defined portion of the 
alignment.  There is a non-collinear tangent element that is causing a discontinuity in the alignment.  
It is necessary to place another curve in the alignment between the first and last curve.  Requirement 
is to maintain the PC and PT of the entire curve set. 

STARTING POWER INROADS 
1. Double-click the Power InRoads icon. 

Note The MicroStation Manager appears. 

2. An alternate path for launching Power InRoads is Start > All Programs > Bentley > Bentley 
Power InRoads (SELECTseries 2) > Bentley Power InRoads (SELECTseries 2). 

OPEN A CAD FILE 
1.  Set the directory to C:\2012_BT_Civil\BC2WK2 - Advanced Geometrical 

Layout\Data\BC2WK2 Advanced Geometrical Layout 
2. Open the CAD file horiz_elem.dgn 

OPEN FILES IN POWER INROADS 
1. Select File > Power InRoads File > Open. 
2. Go to the following directory:  C:\2012_BT_Civil\BC2WK2 - Advanced Geometrical 

Layout\Data\BC2WK2 Advanced Geometrical Layout 
3. Open the following files:  alignments.xin and HorizElem.alg 

TURN ON THE PRIMARY TOOLBAR 

1. Select Tools > Primary  

OPEN MODEL 

1. Select Models  
2. Verify that Model 1.Fit Curve is active 
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3. Close Models  

IMPORT ALIGNMENT 
1. Select File > Power InRoads Import > Geometry > ICS 

 
2. Browse to the following directory:  C:\2012_BT_Civil\BC2WK2 - Advanced Geometrical 

Layout \Data\BC2WK2 Advanced Geometrical Layout \Fit Curve 
a. Select Survey300.ics > Open 
b. Apply 
c. Close 
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APPLICATION ADD-IN 
1. Select Power InRoads Tools > Application Add-ins 
a. Select Horizontal And Vertical Elements Add-in and Multiple Horizontal Element 

Regression Analysis Add-in 

 
b. Apply 
c. Close 

EDIT ALIGNMENT 
1. Select Geometry > Horizontal Element > Check Integrity 

a. Review the alignment and note that the linear element causes non-collinear issues in 
the alignment 

b. Close 
2. Select Geometry > Horizontal Element > Add Free Curve 

a. Set the radius to be 1^15’00” (d1.25) > Tab 
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b. Check on Delete Existing Elements Between First and Last 

 
c. Apply 
d. Select the first element 

 
First Element 

e. Select the second element 
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Second Element 

f. Data point to Accept the solution 
g. Reset and Close to exit the Add Free Horizontal Curve command 

3. Select Geometry > View Geometry > Horizontal Annotation 
a. Load Preference:  Fit Curve 

i. Select Display:  Elements, Radials, and Subtangents 
b. Include the 300 horizontal alignment 

i. Place cursor in the Include field for Horizontal Alignments 
ii. Select Filter 

iii. Select 300 under Available 
iv. Select Add 

 
v. OK 
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c. Apply 
d. Observe the 3 center curve in the plan view 
e. Close 

4. Select Geometry > Horizontal Element > Check Integrity 
a. Review the alignment and note that the curve resolves the issue 
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Chapter 2:  Best Fit from Survey 
Centerline 

CHAPTER OBJECTIVE: 
In this unusual situation, x,y coordinates of a centerline have been given.  However, only 24 points 
have been provided for a 4 mile stretch of roadway.  It is required to create a best fit alignment with 
the points provided using the Geometry commands in Power InRoads.  This is not a typical Regression 
workflow, but Regression tools will be used to solve for some of the Geometry.  

OPEN MODEL 

1. Click Models  
2. Double-click on 2.Best Fit to activate that model 

 

3. Close Models  

CREATE A NEW ALIGNMENT 
1. Select File > Power InRoads File > New > Geometry 

a. Set Type to Horizontal Alignment 
b. Key in Best Fit for the alignment name  
c. Apply 
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d. Close 

IMPORT HORIZONTAL REGRESSION POINTS 
1. Select File > Text Import Wizard 

a. Select Data Type to be Horizontal Regression Points 
b. Navigate to the directory C:\2012_BT_Civil\BC2WK2 - Advanced Geometrical Layout 

\Data\BC2WK2 Advanced Geometrical Layout \Best Fit  

 
c. Select the NE.txt file and click Open 
d. OK 

2. Text Import Wizard – Step 1 of 4   
a. Keep the default settings in this first step (It will import lines 1 through the end of file) 
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b. Next 

3.  Text Import Wizard – Step 2 of 4  
a. Again, keep the default settings in the second step.  It will import all the lines to the 

file 

  
b. Next 

4.  Text Import Wizard – Step 3 of 4 
a. Select the Tab option as the delimiter for this specific file 
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b. Next 

5. Text Import Wizard – Step 4 of 4 
a. Define the columns as Northing / Easting as shown in the picture below 

Note Right-click on the column header and select the correct value 

 
b. Finish 

6. Select Yes to the dialog with the following message:  “Changes have not been saved to the XIN 
file.  Continue?” 
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7. Select OK on the dialog that states the 21 points have been imported successfully 

 

Note Importing regression points by this method assumes that points are in order 
and that all points are valid.  The typical regression sorting and ordering is not 
used in this context. 

VIEW THE HORIZONTAL REGRESSION POINTS 
1. Select Geometry > Horizontal Regression > View Regression Points 

a. Load Preference Best Fit 
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b. Apply 
c. Close 

2. Fit View  

REPORT LOCK 
1. Ensure Report Lock is turned on 

a. Select Tools > Locks > Report  

Note Regress the 3 curves only to get their radii.  Then delete the curve elements 
and add the curves back in after tangents have been defined. 

WORKING WITH REGRESS POINTS 
1. Select Geometry > Horizontal Regression > Edit/Review Regression Points 

a. Select the Select & Regress button 
b. Select the group of four points for the first curve starting from the left (See Screenshot) 
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First group of selected points for first curve 

c. For each Results dialog, write down the radius for each curve 
d. Repeat for each curve as illustrated in the screenshots below 

 
Second group of selected points for second curve 
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Third group of selected points for third curve 

2. Select Geometry > Horizontal Element > Delete Element 
a. Use Selected Element Only 
b. Apply 
c. Delete the elements that were just created with the regression tool 
d. Data point to Accept the solution 
e. Reset and Close to exit the Delete Element command 

3. Select Geometry > Horizontal Regression > Edit/Review Regression Points 
a. Select the Select & Regress button 
b. Select the group of three points for the first tangent from the left. (See Screenshot) 

 
First group of selected points for first tangent 

c. For each Results dialog, make note of the offsets used during Regression to verify that 
the elements are valid. 

d. Repeat for each tangent as illustrated in screenshots below 
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Second group of selected points for second tangent 

 
Third group of selected points for third tangent 

Note Note the large offset of points.  Delete this element and recreate with two 
points. 

4. Delete any element that is not valid 
a. Select Geometry > Horizontal Element > Delete Element 
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Select tangent to delete 

5. Recreate the third tangent by selecting two points instead of three 
a. Select Geometry > Horizontal Regression > Edit/Review Regression Points 

 
Group of selected points for third tangent 

 

6. Continue with the last tangent 
a. Select Geometry > Horizontal Regression > Edit/Review Regression Points 
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Forth group of selected points for forth tangent 

7. Select Geometry > Horizontal Elements > Add Free Curve 
a. Use the radii from previous workflow above to add in curves (Left curves will require 

a negative sign) 

 
i. Apply 

ii. Add first curve by selecting first and second tangents 
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First Tangent 

  
Second Tangent 

b. Reset to bring up the dialog to change the radius 
c. Repeat for next two curves 
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Second Tangent 

  
Third Tangent 
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Third Tangent 

 
Forth Tangent 

8. Select Geometry > Horizontal Regression > Slew Diagram 
a. Load Best Fit preference 
b. Apply 
c. Data point to select a location in the design file to place the slew diagram 
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Slew Diagram 

d. To view slew information in an XML report, click Report 

Note The maximum offset from the surveyed points to the alignment is about 1.3 
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Chapter 2 Alternate: Horizontal 
Regression from Survey 
Centerline 

CHAPTER OBJECTIVES 
Many times a user is provided a survey consisting of coordinates that represent the centerline of an 
existing road or rail.  The user is required to quickly create a curvilinear alignment consisting of lines, 
circular arcs and transition spirals.  In this chapter we will discuss functionality that will aid the user in 
creating the curvilinear geometry. 

PROCEDURE 
1. Create a new .dgn 
1. Open the file shortened.alg 
2. Open the file regression.xin 
3. Go to Horizontal Regression > View Regression Points and click Apply 
4. Fit the view and let’s look at the data 

 
It appears that we have four circular arcs and two maybe three tangents.  The leftmost circular arcs 
can be readily picked out from the data, the third is a bit more difficult and the fourth circular arc is 
detectable.  But, does the data indicate whether or not there are any transition spirals?  Or can the 
user determine if there is any questionable data?  When the answer is obviously, no!  You can’t 
detect transition spirals or bad data.  And if you really thought about it, you would have difficulty 
detecting the start and end of circular arcs.  Let’s see what can be done to resolve this. 

5. Go to Horizontal Regression > Horizontal Curvature Diagram and click Apply 
6. At the prompt Identify Location, data point slightly above the points. 
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What does this diagram tell use?  The curvature diagram allows the user to display 1 / R in the y-axis 
and the length along in the x-axis.  The following: 

• If the point data runs close to the x-axis then those points will represent a line. 

• If the point data runs nearly parallel but offset from the x-axis then those points will be 
represent a circular arc 

• If the point data is neither of the above then those points will be a transition spiral. 

What else can be seen from the diagram?  If you see a spike in the curvature line then that point may 
be a bad point and you may wish to ignore it.  In our case all of the points are reasonable. 

 

Let’s discuss the workflow to regress these points.  We will do the following: 

• From the diagram, we will work from left to right and select and regression the obvious lines 
and circular arcs.  We will use Horizontal Regression > Edit Review Regression Points 

• In fill transition spirals between the lines and circular arcs.  We will use Horizontal Element > 
Define Spiral 
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But first a discussion on selecting points for the individual lines and circular arcs.  It should be clear that at a 
minimum, we need two points for a line and three points for a circular arc.  And when we select points, we 
only want to select points that are within the extents of the line or circular arc.  You may ask, should I try to 
include the points that represent the exact start or end of an element?  No, you should not!  Why not?  Well 
in doing so, you may actually be selecting points that are within the extents of another element.  So when 
we regress the points, we may artificially skew the results.  So it is best practice to not attempt to include 
the start and end points of an element. 

7. Go to Horizontal Regression > Edit Review Regression Points and click Select & Regress 

 
8. For each line and circular arc, we will repeat the following steps 

• Identify first point 
• Identify second point 
• Accept / reject 

Note We will be using the curvature diagram to select the lines and circular arcs.  
Also, if you check on Tools > Locks > Report, you will get textual data, which 
will provide details on the results of the regression analysis. 
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When you have completed this step you should have the following: 

 
With the above results, how close are we to our original guesses?  We did not detect the first line between 
the first two circular arcs.  The two short arc circulars we detected, but it would have been difficult to find 
them without the curvature diagram. 

 

Also, if you had checked on report lock, you would have the following: 
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9. Okay, now let’s add the transition spirals.  Go to Horizontal Elements > Define Spiral.  
Check on Replace and Fill All Gaps and click Apply 

 
• At the Identify first element, select the leftmost circular arc 
• At the Identify last element, select the rightmost line 
• Accept / reject the solution 

10. We now have an alignment with regressed lines and circular arcs and in filled transition 
spiral.  Go to Horizontal Elements > Check Integrity to review the results 

 

Note If you want to control the content of the Check Integrity list-view, right click in 
the header and select / de-select what you want to see.  You can also resize the 
columns and dialog so that it does not consume the entire monitor! 
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11. Go to Horizontal Regression > Edit Review Regression Points and click Select Only and 
place a rectangular around all of the points.  This will include all points in the analysis. 

 
12. Go to Horizontal Regression > Multi-element Regression Analysis and lets fine tune the 

results 

 
Select each element in the Connecting Elements list-view and for each transition spiral, round its 
length up or down to the nearest 5 meter interval. 

Also, set each linear element’s length as free 

Also, set each circular arcs element’s length as free 

As well as the Beginning Element and Ending Element 
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13. Check on Use Regression Analysis 
14. Click Apply 
15. Now edit each circular arc’s radius so that it is rounded to the nearest 1 meter. 
16. Once again click Apply 
17. To review the results, click Report… 
18. Go to Horizontal Regression > Slew Diagram 

 
We want the green line as close as possible to the x-axis.  Obviously, real world data will never hit flat 
on the axis, so some amount of offset is acceptable. 
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What is the secret to getting a reasonable display?  It has to do with the settings for the Left Axes.  
The Major Spacing should be something like 0.1 meters.  And the Elevation Label Precision should be 
something like 0.123 

 

CHAPTER SUMMARY 
We have used Regression Analysis on survey points and have created a curvilinear alignment 
consisting of lines, circular arcs and transition spirals. 

 

Chapter 3:  Compound Curves  
CHAPTER OBJECTIVE: 

In this lesson, the radius of the centerline does not fall between the existing edges of pavement.  The 
alignment appears to need a flatter curve at the top of the arc while having a tighter curve at the 
lower end of the arc.  This alignment requires a compound curve instead of the one single curve that 
was initially created with the PI tools. 

OPEN MODEL 

1. Click Models  
2. Double-click on 3.Compound-Reverse to activate that model 
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3. Close Models  

VIEW AND REVIEW HORIZONTAL ALIGNMENT 
1. Set Mainline alignment active 

a. Right click on Mainline in InRoads and select Set Active 

 
2. Select Geometry > View Geometry > Active Horizontal 
3. Select Geometry > Review Horizontal 

a. Set mode to Element 
b. Select “Next” to view first curve 
c. Make note of the radius of the alignment’s first curve 

EDIT ALIGNMENT 
1. Select Geometry > Horizontal Element > Delete Element 

a. Select option Selected Element Only 
b. Apply 
c. Select the first curve of the alignment 
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Delete Element 

d. Reset and Close to exit the Delete Element command 
2. Select Geometry > Horizontal Element > Add Floating Curve 

a. Set the radius to 700 

 
b. Apply 
c. Select second tangent and float the curve out so that it is between the two edges of 

pavement  (See Screenshot) 
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Float Curve out to center of EOPs 

d. Data point to Accept the solution 
e. Reset and Close to exit the Add Floating Horizontal Curve command 

3. Select Geometry Horizontal Element > Add Free Curve 
a. Set the radius to 350 

 
b. Apply 
c. Select first tangent and then first curve 
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Select Tangent 

  
Select Curve 

d. Data point to Accept the solution 
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e. Reset and Close to exit the Add Free Horizontal Curve command. 

REVIEW ALIGNMENT 
1. Select Geometry > View Geometry > Horizontal Annotation 

a. Load Preference Compound Curve 
b. Include the Mainline horizontal alignment 

i. Place cursor in the Include field for Horizontal Alignments 
ii. Select Filter 

iii. Select Mainline under Available and select Add 

 
iv. OK 
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c. Apply 
d. Close 
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Outcome of Horizontal Annotation 

2. Select Geometry > Review Horizontal  
3. Select Geometry > Horizontal Element > Check Integrity 
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Chapter 4:  Solve for an Unknown 
Geometry 

CHAPTER OBJECTIVE: 
Similar to the best fit issue in Lesson 2, in this lesson we will be using point data to create an 
alignment.  The given data are three points and a radius for an unknown geometry.  Use the 
Horizontal Element tools to construct the geometry for the data given. 

OPEN MODEL 

1. Click Models  
2. Double-click on 4.Solving Geometry to activate that model. 

 

3. Close Models  

CREATE A NEW ALIGNMENT 
1. Select File > Power InRoads File > New > Geometry 

a. Select Type to be Horizontal Alignment 
b. Key in Solving Geometry for the alignment name  
c. Apply 
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d. Close 

VIEW COGO POINTS 
1. Select Geometry > View Geometry > Horizontal Annotation 

a. Load preference Solving Geometry 
b. Remove Mainline from the Horizontal Alignments 

i. Place cursor in the Include field for Horizontal Alignments 
ii. Select Filter 

iii. Select Mainline under Selected 
iv. Remove 

c.  Include Cogo points 65, 66, and 69 
i. Place cursor in the Include field for Cogo Points 

ii. Select Filter  
iii. Select cogo points 65, 66, and 69 under Available and select Add 

 
iv. OK 

d. Apply the Horizontal Annotation command (This will display the cogo points 
selected in the design file.) 
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CREATE ALIGNMENT 
1. Select Geometry > Horizontal Element > Add Fixed Line 

a. The two points used are known (65 and 66) 

 
b. Apply 
c. Data point to Accept the solution 
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d. Reset and Close to exit the Add Fixed Horizontal Line command 
2. Select Geometry > Horizontal Element > Add Floating Curve 

a. Key in the known radius 

 
b. Select the first tangent that was just created 
c. Float the curve out so that it is between the edges of pavements (See Screenshot) 

 
Float Curve between EOPs 

d. Data point to Accept the solution 
e. Close 
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3. Select Geometry > Horizontal Element > Add Floating Line 

 
a. Apply 
b. Select the floating curve that was just placed 

 
Select Curve 

c. Tentative snap to the cogo point 69 
d. Data point to Accept the solution 
e. Reset and Close to exit the Add Floating Horizontal Line command 
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Optional Chapter:  Continuation of 
Solving Geometry 

CHAPTER OBJECTIVE: 
This section is optional if time is allotted.  The Solve for an Unknown Geometry (Chapter 4) can be 
continued with the following workflow.  In the following steps, the Floating Line and Curve 
commands will be used to place a centerline along the remainder of the roadway. 

EDIT ALIGNMENT 
1. Select Geometry > Horizontal Element > Add Floating Curve 

a. Key  in a radius of 480 

 
b. Apply 
c. Select the floating tangent placed in the last section 
d. Float curve out through the intersection 
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Float Curve 

e. Data point to Accept the solution 
f. Reset and Close to exit the Add Floating Horizontal Curve command 

2. Select Geometry > Horizontal Element > Add Floating Line 

 
a. Apply 
b. Select floating curve just created 
c. Float tangent out to the PC of the next curve 
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Float Tangent 

d. Data point to Accept the solution 
e. Reset and Close to exit the Add Floating Horizontal Line command 
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Chapter 5:  Create a Continuous 
Tangential Alignment 

CHAPTER OBJECTIVE: 
Displayed in the CAD drawing are elements representing a driveway component. However, these 
elements are non-tangential.  The goal is to recreate the curve while maintaining the tangency of the 
linear elements.  

OPEN MODEL 

1. Click Models  
2. Double-click on 5.Tangential to activate that model 

 

3. Close Models  

MEASURE RADIUS 

1. Select the Measure Radius tool in the Drawing tools.   
2. Select the curve in plan view 
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3. Read and record the radius given in the Measure Radius dialog 

 

CREATE A NEW ALIGNMENT 
1. Select File > Power InRoads File > New > Geometry 

a. Select Type to be Horizontal Alignment 
b. Key in Tangential for the alignment name  
c. Apply 
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d. Close 

EDIT ALIGNMENT 
1. Select Geometry > Horizontal Element > Add Fixed Line 

a. Select Point 1 to be at the bottom of the first tangent line 
i. Use the target button to tentative snap to Point 1 

b. Select Point 2 to be at the beginning of the arc 
i. Use the target button to tentative snap to Point 2 

 

 
c. Apply 
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d. Data point to Accept the solution 
e. Reset to return to the Add Fixed Horizontal Line command 

2. While working in the Add Fixed Line command, define the second tangent 
a. Select Point 1 to be at the end of the arc 

i. Use the target button to Tentative snap to Point 1 
b. Select Point 2 to be at the end of the second tangent element 

i. Use the target button to Tentative snap to Point 2 

 
c. Apply  
d. Data point to Accept the solution 
e. Reset and Close to exit the Add Fixed Horizontal Line command 

3. Select Geometry > Horizontal Element > Add Free Curve 
a. Key in a radius of 43 
b. Apply 

 
c. Select the first tangent 
d. Select the second tangent 



 

 

56                                                                             Workshop:  Workshop – X13 - Advanced Geometrical Layout for Compound and 
Reversed Curves 
  Copyright © 2012 Bentley Systems, Inc. 

 
Curve placed between tangents 

e. Data point to Accept the solution 
f. Reset and Close to exit the Add Free Horizontal Curve command 

REVIEW ALIGNMENT 
1. Select Geometry > Horizontal Element > Check Integrity 

EDIT ALIGNMENT 
1. Adjust radius of curve to “flatten” it 

a. Select Geometry > Horizontal Element > Edit Element 
i. Select Next to step through the alignment to the curve element 

ii. Key in a radius of 50 
iii. Select Maintain Element Connectivity 
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iv. Apply 

Note  Notice the edits made to the alignment 

 
Connectivity shown here 

v. Select Undo 
vi. Select Maintain Element Connectivity with Minimum Movement 
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vii. Select Apply 

Note Notice the edits made to the alignment 

 
Minimum movement shown here 
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