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Preface

In this workshop, you will start by creating a roadway design using the Roadway Designer and display
the 3D Components of that design in MicroStation. Then, you will use Bentley’s civil design software
to display the 3D graphics that represent the design of roadway drainage pipes and inlets. There is a
conflict between the pipes and the roadway subgrade. You will use MicroStation’s Clash Detection
functionality to review the clashes. You will then publish an i-model and use Bentley Navigator to
comment and markup locations of the clashes.

The workshop guide is yours to take with you. If you don’t finish all the exercises, or just want to
work with the dataset upon return to your office, the datasets (both initial and completed files) are
provided on the Conference DVD. Many workshops will also have videos of all exercises on the DVD.

Note Prerequisite Knowledge Level: Participant should have a basic understanding of
road design principles and in the use of MicroStation and the native application
(InRoads or GEOPAK) or one of the Power products.
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Chapter 1: Model the Corridor and
Drainage

GETTING STARTED

In this lesson, we will open the MicroStation Design file and open an InRoads Project file.

Exercise: Open the MicroStation File
Lesson Objective:

This exercise will guide you through the steps to start InRoads.

Procedure:

1. From the computer desktop double-click on the Power InRoads V8i icon.
2. When the MicroStation Open dialog appears navigate to the following directory.

C:\2012_BT_Civil\BC2WKS3 - Civil Design Review-3D Modeling and Clash Detection\DATA

3. Highlight the file Corporate Drive.dgn and click Open.

Exercise: Open the InRoads Project File
Lesson Objective:

This exercise will guide you through the steps to open a Project file.

Procedure:

1. From the InRoads menus, select File > Open.

2. Select the Project file named Corporate Drive.rwk from the C:\2012_BT_Civil\BC2WK3 -

Civil Design Review-3D Modeling and Clash Detection\DATA folder.
3. Click Open, and then Cancel.

This will open the following files:

Preference file: Bentley Training.xin

Geometry Project: Corporate Drive.alg

Workshop: Workshop — X7 - Civil Design Review: 3D Modeling and Clash Detection
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Model the Corridor and Drainage

Existing Ground Surface:  Corporate Drive.dtm

Roadway Design: Corporate Drive.ird
Drainage Database: Corporate Drive.sdb
Template Library: Template Standards.itl

Exercise: Setup the Project Defaults

Lesson Objective:

This exercise will guide you through the steps to setup the Project Defaults.

Procedure:

1. From the InRoads menus, select File > Project Defaults.
2. Click the New button on the Project Defaults dialog.

B Set Project Defaults
Cortiguration Name: e - fop
Defaut Preferences [ e |
Copy.
Rename.
Delste
import
Egport
Help
Defaut Directary Paths
Defaut Gid Factor Expot Prefemed Preference
Gid Eactor: 100 Active Orly  Name: Dofauk -] Defaut

3. Key in Corporate Drive for the Name and click OK.

Put your cursor Drainage Structures (*.dat) and click the Browse button.

5. Select InRoads Training Structures.dat from the C:\2012_BT_Civil\BC2WK3 - Civil Design

Review-3D Modeling and Clash Detection\Data\ folder location and click Open.
Click Apply on the Project Defaults dialog.

7. Close the Project Defaults dialog.

Exercise: Displaying 3D Drainage Graphics

Lesson Objective:

In this lesson, we will display 3D Drainage graphics using InRoads.

6
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Chapter 1.: Model the Corridor

and Drainage

Procedure:

1. Select Tools > Application Add-ins from the InRoads menus.

2. Enable the View Drainage as Solids Add-in and click OK.

| )
Available:
[ Translate Leica DBX Add-n .
[ | Traverse Edit Add-in Cancsl
[ Tunnel Surface Commands Add-in
[ Tumouts Addan bich
[ ]Update Design Add-n
: Upload Trimble Add-In
[ Varisble Manager Add-in
[ view Bathymetric Elevation Add-in
Z\ﬁew Drainage as Solids Add-In -

Description
The Tumouts Add-in provides commands for the creation and editing of tumouts and
connecting geometry.

Command

m »

Geometry>View Geometry>All Tumouts
Geometry>Tumouts >Create Tumot.
Geometry>Tumouts>Create Diamond Crossing...
Geometry>Tumouts >Create Connection..
Geometry>Tumouts>Connection Editor... -
4 i b

3. Select Tools > Locks > Style Lock from the InRoads menus.
4. Select Drainage > View > Drainage as Solids.

Exercise: Displaying Roadway Components

Lesson Objective:

In this lesson, we will display 3D Roadway Component graphics using InRoads.

Procedure:

Select Tools > Locks > Style Lock from the InRoads menus.
Select Modeler > Roadway Designer.

Review the roadway design using the Roadway Designer.

vk W

dialog.

Key in Finished as the Name of the Surface.
Click Apply and then click Close.

Select File > Save As.

© ® N o

. Change the Save as type to Surfaces (*.dtm).
10. Change the Active to Finished.
11. Click the Save button.

Select Corridor > Create Surface from the Roadway Designer dialog.

Enable the Components option in the Display in Plan View portion of the Create Surface

Workshop: Workshop — X7 - Civil Design Review: 3D Modeling and Clash Detection
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Savein: Data - 03 E
I Name ’ Date modified Type
&y GEOPAK 5/2/2011 9:57 PM File folder
Recent Places | ¢4 morate Drive.dtm 3/25/2011 316 PM DTM File
Desktop
Libraries
LY
Computer
‘i-; < m n
Moty e Firished dim -
Saveastpe: [Sufaces (dim) <] [ Cancel |
Help
Active: .] [ QOptors... ]
12. Click Cancel.
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Clash Detection

Chapter 2: Clash Detection

CLASH DETECTION WORKFLOW IN MICROSTATION

In this lesson, we will detect clashes between the drainage pipes and asphalt road surface. We will

also find pipes that are closer than 3 feet to the asphalt surface.

Exercise: Create a Clash Detection Job

Lesson Objective:

This exercise will guide you through the steps to create a Class Detection Job.

Procedure:

1. Select File > Open from the MicroStation menus.

2. Select Corporate Drive Clash Detection.dgn from the C:\2012_BT_Civil\BC2WK3 - Civil
Design Review-3D Modeling and Clash Detection\Data\ folder location and click Open.

3. Select Tools > Clash Detection > Clash Detection from the MicroStation menus.

Select Jobs > New from the Clash Detection dialog.
5. Key in 3 FT Pipe Clearance in the Name field.

1% Clash Detection - Untitled Job - ' - I
——
Job  Results
\‘j [=] ;LE.‘ B3 Citeria | Rules | Results| I
- = Level ~ Set A -
L 13 FT Pipe Clearance || ami u
‘,‘3 none) _| Soft Clearance:  0.0000 US Survey Fest
[7] Self Check
I =
Zn
= Default "
 Drainage
2 Drainage Areas
= E_CNTR_SurveyContrel M setsn -
 E_COGO_PropertyCorner Soft Clearance:  0.0000  US Survey Feet
= E_COGO_PropertyLine 7] Self Check
= E_DRAIN_Area
=i E_DRAIN_Culvert o
1) References
@ Named Groups -
[ [ oo |

Exercise: Define Clash Detection Criteria

Lesson Objective:

This exercise will guide you through the steps to define Class Detection Criteria.

Procedure:

1. Select the level named P_DRAIN_StormSewer from the Levels list in the Criteria tab.
2. Dragand drop the level named P_DRAIN_StormSewer to the Set A field.

3. Review the CAD graphics.

Workshop: Workshop — X7 - Civil Design Review: 3D Modeling and Clash Detection
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Clash Detection

4. Key in 3.00 for the Soft Clearance in Set A.
5. Select the level named P_ROAD_Asphalt from the Levels list in the Criteria tab.
6. Dragand drop the level named P_ROAD_Asphalt to the Set B field.

Job  Results

N E 22X [ o= | Rules | Resuits|

%2 3 FT Pipe Clearance

= Levels A M seta -~
‘;. (none) | SofiClearance: 30000 US Survey Feet

[T %k Chack:
= P_Profile -

= P_DRAIN_StormSewer
= P_ROAD_AggregateTyped

= P_ROAD_AggregateTypel
= P_ROAD_Asphalt
= P_ROAD_Breakline

=% P_ROAD_ClearZone W setn >
= P_ROAD_ConcreteCurb Soft Clesrance: 0.0000  US Survey Fet
= P_ROAD_ConcreteMedianBarrier [C] Self Check

2 P_ROAD_Curb-Back
= P_ROAD_Curb-Face

= P_ROAD_Asphalt

1] References v

@ Named Groups v

B Pocess || Close

7. Review the CAD graphics.

Exercise: Define Clash Detection Rules

Lesson Objective:

This exercise will guide you through the steps to define Class Detection Rules.

Procedure:

1. Select the Rules tab from the Clash Detection dialog.

2. Disable the Suppress clashes between elements that are touching option.

Job  Results

[ 2 fea | Fules
0.6 % 22X e
2 3 FT Pipe Cl Touching Elefhents
Tolerance: 0.0033  US Survey Fest
[C]iSuppress ciashes befween elements that are fouching
Suppression Rules
' New " Duplicate % Delete Up & Down
Check nules to activate (applied in the order shown)
[ Suppress clashes within the same level
‘ i v
Rule description (Click the underlined values to edit)
4 Process || Close
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Chapter 2: Clash Detection

Exercise: Process and Review the Clash Detections
Lesson Objective:
This exercise will guide you through the steps to process and review the Class Detections.
Procedure:

1. Select Results > Display Settings > Animate Transitions from the Clash Detection dialog
(this should be checked On).
Click the Process button.

This should result in 5 clashes.

s O ¥ ] Feuts
) @ 0| X, | (Gl e
B 3 FT g Cloarws {{ﬂ 24 | -1"}
| Meme  Sa Ty Oeaan fesgred To  Found By  FoundOn  Acoepted By AcceptedOn  Assgn

[ Cwh]
Qssh2
Gashd
Cinshd

Piew
Plrwr
Bl
Hew

Clash

1 Clement Info -

Pointntity2d a Component ~ -

P - HNams H_Mapitalt
18,0000
180000
Circudar
906

e —

P Frocess Close

4. Click the Show Background button.

5. Click the Next Clash button. ﬁ

Review the graphics.
7. Click the Show Element B button. té

Click the Next Clash button. ﬁ

Right-click on the Clash3 and select Add To Selection Set.
10. Review the graphics.
11. Close the Clash Detection dialog.
12. This will bring up an Alert dialog.

@R Cesing the dialog will discard unsaved changes. Do you wish to save
‘\_ . now?

[ Yes |[ No MNJI Cancel

13. Click No on the Alert dialog.

Workshop: Workshop — X7 - Civil Design Review: 3D Modeling and Clash Detection
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CLASH DETECTION WORKFLOW IN BENTLEY NAVIGATOR

In this lesson, we will use Bentley Navigator to markup clash detections.

Exercise: Publish an i-model
Lesson Objective:

This exercise will guide you through the steps to publish an i-model.

Procedure:
1. Select File > Publish i-model from the MicroStation menus.
2. Enable the Create a Package option.
3. Click OK on the Publish i-model dialog.
all files
Package: | Comorate Drive Clash Detectio | idan Q
Protection: |Everyone =
Rights: View V| Export
Edit V| Prirt
Expires: M~ YYYY/MM/DD
| oK L\J | Cancel
4. Exit MicroStation.
Exercise: Start Bentley Navigator

Lesson Objective:

This exercise will guide you through the steps to start Bentley Navigator.

Procedure:

1.

From the computer desktop double-click on the Bentley Navigator V8i (SELECTseries 4)
icon.

2. When the Bentley Navigator Open dialog appears navigate to the following directory:
C:\2012_BT_Civil\BC2WKS3 - Civil Design Review-3D Modeling and Clash Detection\DATA

3. Highlight the file Corporate Drive Clash Detection.i.dgn and click Open.

4. Select the Fit View icon at the top of the Bentley Navigator interface. &l

12
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Chapter 2: Clash Detection

Exercise: Create a Clash Detection Job
Lesson Objective:

This exercise will guide you through the steps to create a Class Detection Job in Bentley
Navigator.

Procedure:

Select Tools > Clash Detection > Clash Detection from the Bentley Navigator menus.

2. Select Jobs > New from the Clash Detection dialog.
3. Key in Pipe Clashes in the Name field.
4. Highlight the Job named Pipe Clashes.
Lk Clash Detection - Pipe Clashes o] = =
Job  Results
1 H By |22 P% Crtena | Rules | Resuts|
% A tobs = Levels A JE Seta -~
= P Soft Clearance:  0.0000 US Survey Fee'
] = [ Self Check
= Default
= Drainage Drag items froim et
= Drainage Areas
= E_CNTR_SurveyControl
= E_COGO_PropertyCorner J setn L
2 £ COGO. Propertyline Soft Clearance: 0.0000 US Survey Fee
Z E_DRAIN_Avea .| || [ Self Check
1) References v o
“ Item Sets/Named Groups v
] Clos:
Exercise: Define Clash Detection Criteria

Lesson Objective:

This exercise will guide you through the steps to define Class Detection Criteria.

Procedure:

1. Select the level named P_DRAIN_StormSewer from the Levels list in the Criteria tab.
Drag and drop the level named P_DRAIN_StormSewer to the Set A field.

Review the CAD graphics.

Select the level named P_ROAD_Asphalt from the Levels list in the Criteria tab.

Drag and drop the level named P_ROAD_Asphalt to the Set B field.

ik W
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Chapter 2: Clash Detection

£ Clash Detection - Pipe Clashes ol = =]
Job  Results
h @ :ha E x Criteria |Ru\e5 IResuhsl

= Levels
% Al Jobs
I’iCII = P_ROAD_AggregateTypeB - Soft Clearance:  0.0000 US Survey Fee

= P_ROAD_Asphal: [ Self Check

»

W seta ~

= P RDAD_Breakline =% P_DRAIN_StormSewer

= P_ROAD _ClearZone

= P_ROAD_ConcreteCurb

= P_ROAD_CencreteMedianBarrier

- il ~
Z P_ROAD_Curb-Back [0 MEsets

Soft Clearance:  0.0000 S Survey Fee
[] Self Check

= P_ROAD_Curb-Face

= P_ROAD_CutLine 8

= P_ROAD_fsphalt

1) References v

@ Jtem Sets/Named Groups L4

¥ Process ] [ Close

6. Review the CAD graphics.

Exercise: Process and Review the Clash Detections
Lesson Objective:

This exercise will guide you through the steps to process and review the Class
Detections.

Procedure:

Select Results > Display Settings from the Clash Detection dialog.

2. Enable the Animate transitions option.
3. Move the Zoom extent slider slightly to the right.
4. Click OK.
14 Workshop: Workshop — X7 - Civil Design Review: 3D Modeling and
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Chapter 2: Clash Detection

+'t Clash Display Settings
fi. Hard Clash Display
Element A color:
Element A transparency:

Element B color

e m @ =m
e

Element B transparency:
;:Ej_ Clearance Display

Element A color

Element A transparency:

Element B color 77,166, 255

¢ B @ m

Element B transparency: 25

#% Surroundings Display

vy B FEE s mmmm>@

~

Extent of surroundings:

V| Exclude obstructing elements

;‘7 Zoom -~

Zoom extent:

A

Zoom only in active view

| Animate transitions

0K Cancel
5. Click the Process button.

Two clashes will result.

Exercise: Create Markups for Clashl and Clash2
Lesson Objective:
This exercise will guide you through the steps to markups for the Class Detections.
Procedure:

1. Ensure that Clash1l is selected.

Click the Show Background button.
Zoom in closer to the pipe clash in View 1.

Y 4
4. Click the Create a markup for Clash1 button. b
5. Click the Next Clash button. ﬁ
Zoom in closer to the pipe clash in View 1.
%

Click the Create a markup for Clash2 button.
Select Job > Save Job to save the Job.
Close the Clash Detection dialog.

10. Select Review > Markup > Markups Dialog.
This will bring up the Markups dialog.

Workshop: Workshop — X7 - Civil Design Review: 3D Modeling and Clash Detection
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4 Markups
A ActiveMarkups [+ () TT | £ A X B Switch to Review | & Preview | Comments | ¥
Name Description Revew Model  Created By Date Created Proty Status AssgnedTo  Aop
Clash1_Pipe Clashes Pipe Clashes Default Dan Eskin 5/3/2011121937PM  Nomal Not started
Clash?_Pipe Clashes Pipe Clashes Default Dan Eskin 5/3/2011 122033 PM  Nomal Not started
i i D
Comment Reviewer Date

11. Put your cursor in the Assigned To field in the Clash1l_Pipe Clashes row.
12. Key in Mr. French in the Assigned To field.

A Markups
A activemaraps  J ()T |2 A X B switchtoReview | & Preview |5 comments | ¥
Name Descrption Review Model  Created By Date Created Prorty Status Assigned To Aop|
Clash1_Pipe Clashes Pipe Clashes Default Den Eskin 5/3/20111213:37PM  Nommal Not started Wi French]
Clash?_Pipe Clashes Pipe Clashes Default Dan Eskin 5/3/2011122033PM  Nommal Not started N
4 m 3
Comment Reviewer Date
Acsigred To was changed from "'t "Mr. French” Dan Eskin 5/3/2011 30520 PM

13. Change the Priority to from Normal to High.

Markups.

A activeMakups [ ()T | 2 A X B Svitch toRevien | L Preview | Comments £
Name Description Review Modsl ~ Created By Date Created Priorty Status Aesigned To Appr
Clash1_Pipe Clashes Pipe Clashes Defautt Dan.Eskin 5/3/201112:19:37PM  [Nommal | Mot stated Mr. French

Not started

Clash2_Pipe Clashes Pipe Clashes Defaut Dan Eskin 5/2011122033PM | Low
Normal

.

l

Comment Reviewer Date
Assigned To was changed from ™ to "Mr. French”’ Dan Eskin 5/3/2011 3:05:20 PM

14. Click the Comments button. Et)
15. Key in “This pipe is clashing with the asphalt” and click OK.

- - 2
e RN
| [
| Markup: Clash1_Pipe Clashes N

Comment
This pipe is clashing with the asphalt

16. Right-click on the Clash1_Pipe Clashes row and select Open.
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Exercise: Redline Clashl and Clash2

Lesson Objective:
This exercise will guide you through the steps to redline the Class Detections.
Procedure:

1. From the Task Menus, select the Redline tasks.

File Edit Settings Tools Review Window Help

0060 b uE o & IEE

Tasks
s X = View1, Clashl_Pipe Clashes [Displayset]
[E-«. Review - |
- Examine n= = El;l Tasks
=R 3 Feview
“2 Measure Distance -7 Examine
e P
} i [ AL Draw
@ Section View | -8 Visuslize
H Animate
j.: Create Markup ---ttl:lash Detection
. -] Schedule Simulation
M Draw [ Markup
08 wisualize il Redine
H Animate
ﬂ: Clash Detection -
?—El Schedule Simulation -

2. Select the Place Note command from the Redline menus.

File Edit Settings Tools Review Window H

Q-0 (&-O s8ARIUE

Tasks X ;

[{\! Redline - |

yyyi
sfd d-¢
X

3. Keyin “Pipe is too high on this end” in the Text Editor dialog.
4. Click once near the pipe and click again to locate the text.
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Repeat these steps for the Clash2.
Select Review > Switch to Review from the Bentley Navigator menus.

Exit Bentley Navigator.

o N o w

This will bring up an Alert dialog.

‘_) Save changes to:

Corporate Drive Clash Detection.overlay.dgn

) -

9. Click Yes on the Alert dialog.
10. Click Save to save the Overlay file named Corporate Drive Clash Detection.overlay.dgn.
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	14. Click the Comments button.
	15. Key in “This pipe is clashing with the asphalt” and click OK.
	16. Right-click on the Clash1_Pipe Clashes row and select Open.

	 Exercise: Redline Clash1 and Clash2
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	9. Click Yes on the Alert dialog.
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